Highlighted

Oracle Backup channels failing 130 from many days

Hi All,

 

We had issue with one of our unix server and we dont have backups since 2 months due to system error  (130). can you suggest me how we can resolve the issue asap please .

Tags (2)
3 Replies

Re: Oracle Backup channels failing 130 from many days

Error 130 for Oracle backups is reported when the su command to switch to the oracle user fails on the client machine just before the backup..

Is there any security product on the client machine such as etrust.? Your linux admin would need to check why the the switch to oracle user is failing causing the backups to fail..

Since there are no backups for a long time, I would suggest it would be a good idea to connect to rman directly and run the commands to take a backup using sbt_tape and the configured policy name.. atleast you would have 1 recent backup in that case..

The bprd logs on the master server should be able to give you the error message where it says it could not switch to the oracle user

Re: Oracle Backup channels failing 130 from many days

Try to run "su - oracle" on the client to check if it's possible to become oracle user. Could you also share /var/log/messages  (or /var/adm/messages in case of Solaris), please? We'd like to check bphdb and dbclient logs.

Re: Oracle Backup channels failing 130 from many days


@sadareddy23 wrote:

Hi All,

 We had issue with one of our unix server and we dont have backups since 2 months due to system error  (130). can you suggest me how we can resolve the issue asap please .


@sadareddy23

If you want to resolve the issue ASAP, you really need to give us more info ASAP. 

We can only work with the info that you give us. 
Since the issue is clearly on the client, you need to collect logs on the client and upload here so that we can try and assist you. 

Before collecting logs - what troubleshooting have you and the dba(s) done thus far?
Can the dba use rman to backup to local disk?
Can the dba use same rman commands and parameters (just with sbt_tape instead of disk) from cmd to backup to NBU?
Only if all of the above is working fine should we investigate the script, the rman output and the logs.

Please share the script, the rman output file and NBU logs - dbclient and bphdb 
Ensure that the folders in /usr/openv/netbackup/logs have 777 permission. 
Copy all of these files to .txt files (e.g. script.txt, dbclient.txt, etc) and upload here.