Highlighted

PROBLEM WITH INSTALL PBX ON AIX 5.3 IBMSERIESP

HIE EVERYBODY!!!! YOU KNOW I´VE GOT A PROBLEM, I HAVE A AIX 5.3 IBMSERIESP SERVER AND I WANT TO INSTALL NB 6.5 MEDIA SERVER, BUT WHEN I WANT TO INSTALL THE PBX PACKAGE, DISPLAY DE NEXT ERROR:

MXPRU1 /sapcds/nbinst/NB_65_ICS_1.4.37.0_AIX =>./install

Can't locate CPI/common/CPI.pm in @INC (@INC contains: ./authentication/scripts ./perl/lib/5.8.8/aix-thread-multi ./perl/lib/5.8.8/aix-thread-multi ./perl/lib/5.8.8 ./perl/lib/site_perl/5.8.8/aix-thread-multi ./perl/lib/site_perl/5.8.8/aix-thread-multi ./perl/lib/site_perl/5.8.8 ./perl/lib/site_perl/5.8.8/aix-thread-multi ./perl/lib/site_perl/5.8.8 ./perl/lib/site_perl /opt/VRTSperl/lib/5.8.8/aix-thread-multi /opt/VRTSperl/lib/5.8.8 /opt/VRTSperl/lib/site_perl/5.8.8/aix-thread-multi /opt/VRTSperl/lib/site_perl/5.8.8 /opt/VRTSperl/lib/site_perl .) at ./installics line 7.

BEGIN failed--compilation aborted at ./installics line 7.

I HOPE THAT SOMEBODY HELPS ME, PLISS!!
THAK YOU!!

1 Solution

Accepted Solutions
Highlighted
Accepted Solution!

released on 27032008

6.5_ICS.1.4.37.5_AIX this was the latest verison available in software site; i have cross-verfied... this version itself worked for me for same issue..
can recheck in excecuting that script.

View solution in original post

9 Replies
Highlighted

PROBLEM WITH INSTALL PBX ON AIX 5.3 IBMSERIESP

I have the same problem Smiley Happy Anybody knows what is it???
Highlighted

find..

 I believe that the install script is looking for CPI.pm which is a perl module required for installation.

Try running this:

From the directory where installics is located:

find ./ -name CPI.pm

Also run:

grep -i CPI installics


Post the outputs here and may be we can find a clue..
Highlighted

Solution is here

PBX installables for AIX provided with the release media had a known issue; so it was updated with new installables; login to Symantec softwares downloads and get the latest base.

it worked for me;
Highlighted

I don't know why but when I

I don't know why but when I put Install CD into CD-ROM in my server and try to install from there it's working, but when I try to install from binnary copied to local disk it;s not wirkingSmiley Happy

regards
Highlighted

then it should it untar problem

uncompression would have failed, in earlier case and the workaround stated earlier worked in my case.
Highlighted

6.5 pbx error - Downloaded latest but still same error

Hi, I also have the same prob, I have got the 6.5_ICS.1.4.37.5_AIX download for this software (no cd available),

I can see the pm module in:

# find ./ -name CPI.pm
./infrastructure_core_services/scripts/CPI/common/CPI.pm

and this is the script that is using it:


# grep -i CPI installics
CPI=`find $DIRNAME -name CPI | sort | sed -n 1p | sed 's/\/CPI//'`
[ -n "$CPI" ] && IOPT="-I$CPI "
IOPT="-I/opt/VRTSperl/lib/site_perl/CPI "
use CPI::common::CPI;
use CPI::train::common::ICS;
use CPI::train::AIX::ICS;
CPI::main();

Am I using the latest or can anybody help with the above,

Cheers
Gav

Highlighted

Install script error

I have found this from www.netbackuphowto.com

not sure if it should be used or not but seemed to get past the above error but did get a new error which I have posted aswell...


""Copying the files from a Windows machine will indeed break the ICS installation, however this message is not caused by missing execute permissions. It is caused by a substandard installation script:

# grep CPI installics | grep find
CPI=`find $DIRNAME -name CPI | sort | sed -n 1p | sed ’s/\/CPI//’`
# find $DIRNAME -name CPI | sort | sed -n 1p | sed ’s/\/CPI//’
./authentication/scripts
# find . -name CPI.pm
./infrastructure_core_services/scripts/CPI/common/CPI.pm

I changed “1p” to “3p” and now ./installics gets past this error. But why the script developer decided to pick the first directory named CPI rather than the directory containing CPI.pm, I do not know.""

Highlighted
Accepted Solution!

released on 27032008

6.5_ICS.1.4.37.5_AIX this was the latest verison available in software site; i have cross-verfied... this version itself worked for me for same issue..
can recheck in excecuting that script.

View solution in original post

Highlighted

Re-run ?

Hi, did you manage to re-run that script ? I can get past the error above by making that script change but then get the errors in the below discussion thread.  Not sure if its a solution yet though ?

https://www-secure.symantec.com/connect/forums/vrtsicsco-install-problems-when-upgrading-60mp4-653

Thanks
Gavin.