Highlighted

RMAN restore failing with ORA-27191: sbtinfo2 returned error

Hello,

The DBAs are doing an RMAN restore which was taken on server 1 seprdu05. They are trying to restore on server 2 seppuu03.

Both clients are Solaris 10 machines with oracle database 11.2.0.

The master server is RHEL 5.9.

The netbackup master server version is 7.5.0.7

The netbackup client version is 7.5.0.4

The error is as below:

  Oracle instance shut down                                                                                      

  RMAN-00571: ===========================================================                                       

  RMAN-00569: =============== ERROR MESSAGE STACK FOLLOWS ===============                                        

  RMAN-00571: ===========================================================                                       

  RMAN-03002: failure of Duplicate Db command at 08/16/2015 06:57:26                                             

  RMAN-05501: aborting duplication of target database                                                           

  RMAN-03015: error occurred in stored script Memory Script                                                     

  ORA-27191: sbtinfo2 returned error                                                                            

  Additional information: 3480   

 

On the client, nothing is reported in the netbackup logs: /usr/openv/netbackup/logs/user_ops/dbext/logs/

 

It seems that the error "Additional information: 3480" would come from the MML (Media Manager Layer). Is there any logs on the master server that could give more details wether the RMAN job has interacted with netbackup so far?

 

Any sugestion would be very helpful.

 

 

4 Replies
Highlighted

Why are they using duplicate?

Why are they using duplicate? that is not a normal restore process. Duplicate is used in a clone operation.

 

Please post what they (or you) are doing to initiate the restore.

 

Also refer to this note on how to perform an alternate restore of Oracle. https://support.symantec.com/en_US/article.HOWTO64200.html

Highlighted

Hello, yes it was a clone

Hello,

 

yes it was a clone operation:

 

here is how they were launching the cloning:

rman target sys/*******@iprd01 catalog xxrman/******@RMNSE01 auxiliary /

 

run {

ALLOCATE AUXILIARY CHANNEL CH1 TYPE 'SBT_TAPE' parms 'ENV=(NB_ORA_CLIENT= seprdu05.sagir.qc), SBT_LIBRARY=/usr/openv/netbackup/bin/libobk.so64.1';

ALLOCATE AUXILIARY CHANNEL CH2 TYPE 'SBT_TAPE' parms 'ENV=(NB_ORA_CLIENT=seprdu05.sagir.qc), SBT_LIBRARY=/usr/openv/netbackup/bin/libobk.so64.1';

SEND 'NB_ORA_POLICY=RMAN_SEPRDU05_BD,NB_ORA_SERV=sesegx10.sagir.qc';

SET UNTIL SCN 7368762180776;

duplicate target database to ipru01;

}

 

Highlighted

Please see the TN in Riaan's

Please see the TN in Riaan's post. You need to create altnames file on the master server to authorise redirected restore.

Hello, Thank you for your

Hello,

 

Thank you for your sugestions. This is what actually was the issue. We found that the error started following some cleanups done in the bp.conf file. We cleaned FQDN entries for the master server considering it was a duplicate since the short hostname entry was already there (SERVER = sesegx10 and SERVER = sesegx10.sagir.qc)However the Netbackup clients was not able to ping the short hostname but only the FQDN, it was due to missing domain name in the resolve.conf

It was not clear because backup and restore other that the cloning were still working withour the FQDN.