cancel
Showing results for 
Search instead for 
Did you mean: 

Restoring Images from decommissioned Mediaserver

JDK76
Level 3

Hi all,

 

I am trying to restore an image from a  clustered media server which was decommissioned. The media server was decommissioned and I had to remove all instances from NBU later on. This was done with the use of the utility ( nbudecommision ) Still I am unable to restore the image --> ( cannot connect to server backup restore manager(205))

is there a step I am missing ?

Master-, Media and clients are all running NBU 6.5.3.1 on Win 2003 R2.

thank you very much in advance.

1 ACCEPTED SOLUTION

Accepted Solutions

Marianne
Moderator
Moderator
Partner    VIP    Accredited Certified

Is ******18c your decommissioned media server?

Extract from log:

restore -mpx_restore -S ******02 -mt 2 -to 1960560 -mud 180 -mediasvr ******18c -masterversion 650000

10:27:05.456 [10156.9444] <2> local_bpcr_connect: nb_connect_to_vnetd_service(******18c) failed: 25

10:27:05.456 [10156.9444] <2> local_bpcr_connect: Can't connect to client ******18c

10:27:05.456 [10156.9444] <2> ConnectToBPCD: bpcd_connect_and_verify(******18c, ******18c) failed: 25

 

The master is still trying to connect to this media server  - seems your Media Host Override did not work?

Please double-check your entries and confirm what you have under "Original Backup Server" and under "Restore Server".

If the entries are correct, you will see a line like this after all the "restorefiles" criteria is defined in bprd log:

restorefiles: Because of FORCE_RESTORE_MEDIA_SERVER, changing server of bid client_image from ******18c to new-server

 

(When you enter server names in "Media Host Override", it updates the master server's registry with FORCE_RESTORE_MEDIA_SERVER entry. See http://www.symantec.com/docs/TECH28314)

 

View solution in original post

19 REPLIES 19

RiaanBadenhorst
Moderator
Moderator
Partner    VIP    Accredited Certified

Hi,

Quick fix is

GUI : Host Properties -> Master -> General Server. Specify original and new media server under Media Host Override.

Once you have that done we can look at why its still referencing the old media server.

Deeps
Level 6

Which server is it trying to contact ? Is it refering to old media server or new media server ? MAke sure you use the virtual name of the decommissioned media server in the host properties as sugegsted by Riaan . This could be a network issue not a config issue.

JDK76
Level 3

hi all,

 

thank you for your response.

 

@Riaan, yes I have specified the media host override. still no succes.

@deeps, not really clear what you mean by which server is trying to contact.

I've set the masterserver in the media host overwrite settings.

I've specified the full qualified domain names in the media host overwrite settings

 

thanks again for your help!

Rajesh_s1
Level 6
Certified

Go to the Master server host properties and in General server tab you will get a option as media server override.

Suppose if you have taken a backup from 'A' server which is Decommissioned and you want to restore from another media server which is active i.e 'B'

Then on original bakup server give server name 'A'

and restore server as 'B' ....

It should work , else you may need to restart the NetBackup services once..

 

JDK76
Level 3

@rajesh I've done so.... I've set the Masterserver as restore server ( is this a working solution or should I set another media server as the restore server ? )

Rajesh_s1
Level 6
Certified

Anything you can do , If your Master server is also a Media server and your tapes drives are shared and configured to it then you can use your Master server , else you need to use any media server where the tape drives are shared and configured ...

If it didn't works even after changing , then you may need to restart the Netbackup master server services once . Because some time changes done to host properties will get effected only after recycling Netbackup services..

Marianne
Moderator
Moderator
Partner    VIP    Accredited Certified

Please ensure you have bprd log on the master server. (Restart NBU after creating the directory).

You wiil be able to see which media server is selected for the restore.

You can also post bprd log as an attachment.

JDK76
Level 3

@all thank you for your reactions ( I am unable to test today since we have an issue with our tape library)

I've also found this : https://www-secure.symantec.com/connect/forums/restore-after-media-servers-decommed

I've found the reg-key. is the "="  between the "old" media server and the "new" also needed in windows ?

 

thanks again for your help and I will start testing as soon as our Lib. is up and running again.

Marianne
Moderator
Moderator
Partner    VIP    Accredited Certified

No - on a Unix master, the entries are added to a text file (bp.conf).

If you add the entries in Host Properties of the Windows Master, the Master server's registry will be updated with correct format.

JDK76
Level 3

@all .... still struggling with our lib. I will get back at you as soon as I can.

JDK76
Level 3

@all, the probs which we experienced with our Lib have been solved ( finally)

however the tapes needed for the restore are not in house. they will be delivered tomorrow.

I will update as soon as can ....

 

JDK76
Level 3

HI, i've implemented all the hints above and still the restore fails with ( cannot connect to server backup restore manager(205))

i've attached the bprd log of the resore only. ( I needed to blank the client names, hope this is no prob.)

 

thank you very much in advance

Stumpr2
Level 6

create file on master server $INSTALL_DIR\netbackup\db\altnames\No.Restrictions

Marianne
Moderator
Moderator
Partner    VIP    Accredited Certified

Is ******18c your decommissioned media server?

Extract from log:

restore -mpx_restore -S ******02 -mt 2 -to 1960560 -mud 180 -mediasvr ******18c -masterversion 650000

10:27:05.456 [10156.9444] <2> local_bpcr_connect: nb_connect_to_vnetd_service(******18c) failed: 25

10:27:05.456 [10156.9444] <2> local_bpcr_connect: Can't connect to client ******18c

10:27:05.456 [10156.9444] <2> ConnectToBPCD: bpcd_connect_and_verify(******18c, ******18c) failed: 25

 

The master is still trying to connect to this media server  - seems your Media Host Override did not work?

Please double-check your entries and confirm what you have under "Original Backup Server" and under "Restore Server".

If the entries are correct, you will see a line like this after all the "restorefiles" criteria is defined in bprd log:

restorefiles: Because of FORCE_RESTORE_MEDIA_SERVER, changing server of bid client_image from ******18c to new-server

 

(When you enter server names in "Media Host Override", it updates the master server's registry with FORCE_RESTORE_MEDIA_SERVER entry. See http://www.symantec.com/docs/TECH28314)

 

View solution in original post

Amit_Karia
Level 6

use bpmedia -movedb command to move media server host from old server to new server

bpmedia -movedb -m <mediaid> -newserver <newservername> -oldserver <decomm. media server>

any ways your decommission script should have ensured your media server refrences including medias are moved to new server.

JDK76
Level 3

As it turned out itr was a POBCAC.... I've removed all entries for the failover restore server and re-added them. restore works like a charm!!!!

 

thanks for all the time and effort !

Andy_Welburn
Level 6

laugh

JDK76
Level 3

Occurs Between Computer And Chair ...

Andy_Welburn
Level 6

viz: Problem Exists Between Keyboard And Chair :D