Highlighted

SAN Client Problem

my problem is :

I have client with hostname DBSAND and connected to netbackup and when trying to enable SAN client it appears in the master server GUI in the SAN Client area with hostname DBTEST why this behavior , Please your help

Tags (2)
8 Replies
Highlighted

Re: SAN Client Problem

Have you changed the name ? Was it dbtest before? If yes you should do a bpclntmch -clear_host_cache on both client and master
Also verify registry key or bp.conf file on the client
Highlighted

Re: SAN Client Problem

the host cache cleared from client , master and media also the bp.conf is correct

this host dbtest appear only when configure the SAN client

Tags (2)
Highlighted

Re: SAN Client Problem

@mohamed 

Please post output of these commands on the client:

bpclntcmd -self

bpclntcmd -pn

Highlighted

Re: SAN Client Problem

the output:

./bpclntcmd -self
 
yp_get_default_domain failed: (6) internal yp server or client error

NIS does not seem to be running: (1) args to yp function are bad

gethostname() returned: dbsand

host dbsand.eeeeeeeeee.com: dbsand.eeeeeeeee.com at 192.168.x.x

aliases:     dbsand.eeeeeeeeee.com     192.168.x.x

getfqdn(dbsand.eeeeeeeeee.com) returned: dbsand.eeeeeeeeee.com


# ./bpclntcmd -pn

expecting response from server master.server

dbsand.eeeeeeeeee.com dbsand.eeeeeeeeee.com 11.0.0.125 56454
#

Tags (2)
Highlighted

Re: SAN Client Problem

Hi

I think I do see two different IPs...

192.168.x.x and 11.0.0.125

please post outcome from nslookup dbsand.eeeee.com and naslookup against these two IPs...

Highlighted

Re: SAN Client Problem

differnt IP because :

 

the 192.168. ip is the client we backup it on isolated network 11.0.0.125

Highlighted

Re: SAN Client Problem

Please check how the master and FT Media server are resolving the 2 IP addresses: 

bpclntcmd -ip 192.168.x.x

bpclntcmd -ip 11.0.0.125

Also, have you checked hosts files on all servers? Client, FT Media server, master.
My gut feel is that dbtest is somewhere in a hosts file. 

Highlighted

Re: SAN Client Problem

the problem has been solved .

using this command on master nbemmcmd –listhosts 

and found the strange host name dbtest 

then deleted this host using this command nbemmcmd -deletehost -machinename dbtest -machinetype client

now every thing is working good , Thanks every one.