cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted

SLP Nightmare - multiple versions of incomplete duplication

Hello All, 

 

I had to replace some hardware in a tape drive (picker & drive).  The tape # changed from tld4 to tld3. Of course after the fact I'm getting errors (2001) because Version 8 of the SLP is still trying to process to tld 4 that doesn't exist.  

Is there an easy way to fix this?   I'm a gui girl.   Can I remove/delete slps?  or change I modify the previous version to point to the new tld3?

SLPs are great , but not when you have to modify.  You either have to change all the policies or the SLP.  Or create a new one, but how does that help the old images that are incomplete? 

 

1 Solution

Accepted Solutions
Highlighted
Accepted Solution!

Re: SLP Nightmare - multiple versions of incomplete duplication

You would need to run below commands:-

Path is <install path>\netbackup\bin\admincmd or /usr/openv/netbackup/bin/admincmd:-

nbstl QTS-ATL-7Year -modify_version -version 2 -residence LDATL00NASBAK02STU,lsatl00bakmed02-hcart2-robot-tld-3

nbstl QTS-ATL-7Year -modify_version -version 3 -residence LDATL00NASBAK02STU,lsatl00bakmed02-hcart2-robot-tld-3

nbstl QTS-ATL-7Year -modify_version -version 5 -residence LDATL00NASBAK02STU,lsatl00bakmed02-hcart2-robot-tld-3

Important for version 6 and 8 if you want to change or not:- Original Storage unit used for backup is LDATL00NASBAK02STU and for duplicate is lsatl00bakmed02-hcart2-robot-tld-2

Below is the command if you want to move it to tld3 for version 6 and 8:-

nbstl QTS-ATL-7Year -modify_version -version 6 -residence LDATL00NASBAK02STU,lsatl00bakmed02-hcart2-robot-tld-3

nbstl QTS-ATL-7Year -modify_version -version 7 -residence LDATL00NASBAK02STU,lsatl00bakmed02-hcart2-robot-tld-3

Then activate the SLP and monitor the jobs.

To check the size of duplication pending you can run below command:-

nbstlutil report

View solution in original post

10 Replies
Highlighted

Re: SLP Nightmare - multiple versions of incomplete duplication

You would want to use the nbstl command. Take a look at the Commands Guide PDF that you can download from Veritas and review the section in regards to the nbstl command.

In order to edit your older SLP version, it would look something like this. If you have multiple destinations, they would be added to the residence attribute in the order they are written to.

<install path>\admincmd\nbstl <SLP name> -modify_version -version <version number> -residence <tld3_name>

Here is link to a pretty simple explanation about the process, hope it helps.

https://www.veritas.com/support/en_US/article.000091418

Highlighted

Re: SLP Nightmare - multiple versions of incomplete duplication

Helps a lot!!  Working on it now.   I will update you when solved.

 

Highlighted

Re: SLP Nightmare - multiple versions of incomplete duplication

Helps a lot!!  Working on it now.   I will update you when solved.

 

Highlighted

Re: SLP Nightmare - multiple versions of incomplete duplication

You should be able to list the SLP versions with the nbstl command, and I think I saw somewhere on here where you can use the nbstlutil command to tell it to use another version.

So - update the SLP as you want, determine the version, update the SLP image to use the new version.

I have not done this, so it may not work.

 

In the mean time, you should be able to inactive the SLP images so they stop trying to run.

 

 

NetBackup 8.1.2 on Solaris 11, writing to DataDomain 9800 6.0.2.50
duplicating via SLP to LTO5 in SL8500 via ACSLS
Tags (2)
Highlighted

Re: SLP Nightmare - multiple versions of incomplete duplication

When I run the command I get No entity found.  

I'm guessing because the library tld-4 has already been deleted.   

 

Highlighted

Re: SLP Nightmare - multiple versions of incomplete duplication

If you run "nbstl-b " it should list your SLP, find the one you need, and review the versions.

you are going to need to review the nbsl commands, because when you modify an SLP, you hav to supply ALL the information! I usually use a script, because it is so painful.

You should be able to look at the versions of the SLP, and find you have SLPv1 and SLPv2 - you can run the command to modify SLPv1 and replace the storage with the updated one, then restart it and it should work.

 

NetBackup 8.1.2 on Solaris 11, writing to DataDomain 9800 6.0.2.50
duplicating via SLP to LTO5 in SL8500 via ACSLS
Tags (2)
Highlighted

Re: SLP Nightmare - multiple versions of incomplete duplication

nbstl storage_lifecycle_name -modify_version -dp duplication_priority -version version_number 

[-uf used_for1 [,used_for2,..used_forn]]

[-source source1[,source2,..sourcen]]

[-residence storage_unit1 | __NA__[,storage_unit2 |
__NA__,..storage_unitn | __NA__]]

[-pool volume_pool1 | __NA__[,volume_pool2 |
__NA__,..volume_pooln | __NA__]]

[-server_group host1 | __NA__[,host2 | __NA__,..hostn |
__NA__]]

[-managed m1[,m2,..mn]] [-rl retention_level1 | __NA__
[,retention_level2 | __NA__,..retention_leveln | __NA__]]
[-as alt_read_server1 | __NA__ [,alt_read_server2 |
__NA__,..alt_read_servern | __NA__]]

[-mpx T | F [,T | F,..,T | F]] [-target_master
target_master_server1 | __NA__ [,target_master_server2 |
__NA__,..target_master_servern | __NA__]][-target_importslp
target_importslp1 | __NA__ [,target_importslp2 |
__NA__,..target_importslpn | __NA__]] [-defop T | F [,T |
F,..,T | F]] [-v] [-M master_server] [-destpri priority1
[,priority2,..priorityn]] [-window window_1
[,window_2,..window_n]] [-wcopt option_set1
[,option_set2,..option_setn]

 

Here is the command used to modify one of mine (actually used in a script) notice I have two levels, so each option MUST have two values, even if __NA__! 

nbstl SLPNAME -modify -v -dp 10002 -uf 0,1 -residence DD-vnx8422,MEDIASERVER01-LTO5 -pool DD.ndmp,E.1year_pool -server_group All_Servers,All_Servers -managed 0,0 -mpx F,f -rl 0,8 -as __NA__,MEDIASERVER01 -source 0,1

NetBackup 8.1.2 on Solaris 11, writing to DataDomain 9800 6.0.2.50
duplicating via SLP to LTO5 in SL8500 via ACSLS
Tags (2)
Highlighted
Accepted Solution!

Re: SLP Nightmare - multiple versions of incomplete duplication

You would need to run below commands:-

Path is <install path>\netbackup\bin\admincmd or /usr/openv/netbackup/bin/admincmd:-

nbstl QTS-ATL-7Year -modify_version -version 2 -residence LDATL00NASBAK02STU,lsatl00bakmed02-hcart2-robot-tld-3

nbstl QTS-ATL-7Year -modify_version -version 3 -residence LDATL00NASBAK02STU,lsatl00bakmed02-hcart2-robot-tld-3

nbstl QTS-ATL-7Year -modify_version -version 5 -residence LDATL00NASBAK02STU,lsatl00bakmed02-hcart2-robot-tld-3

Important for version 6 and 8 if you want to change or not:- Original Storage unit used for backup is LDATL00NASBAK02STU and for duplicate is lsatl00bakmed02-hcart2-robot-tld-2

Below is the command if you want to move it to tld3 for version 6 and 8:-

nbstl QTS-ATL-7Year -modify_version -version 6 -residence LDATL00NASBAK02STU,lsatl00bakmed02-hcart2-robot-tld-3

nbstl QTS-ATL-7Year -modify_version -version 7 -residence LDATL00NASBAK02STU,lsatl00bakmed02-hcart2-robot-tld-3

Then activate the SLP and monitor the jobs.

To check the size of duplication pending you can run below command:-

nbstlutil report

View solution in original post

Highlighted

Re: SLP Nightmare - multiple versions of incomplete duplication

All the above duplications will go to  lsatl00bakmed02-hcart2-robot-tld-3

Highlighted

Re: SLP Nightmare - multiple versions of incomplete duplication

That did it!!!  Thank you so much.  I really appreciate your assistance.