cancel
Showing results for 
Search instead for 
Did you mean: 

Switched Volume Pool for a policy but it still backs up to original Pool (7.6.1.1)

dbarrett6
Level 2

We have two policies, called NBU-DP-SU-01-MON-SLP and NBU-DP-SU-02-MON-SLP, which originally were set to back up to a pool called "Netbackup". For some reason someone switched the pool to one called "NetbackupYearly" and for a couple weeks that policy has been writing to those tapes. However, we have tried to switch them back to the "Netbackup" pool, yet those policies still write to the "NetbackupYearly" tapes. The Pool has been switched under NetBackup Management > Storage > Storage Lifecycle Policies and then Change. Is there somewhere else this needs to be set or changed? Unfortunately I was not the one who initially set up our policies and configuration so I am only somewhat familiar with how it all works, but I couldn't find another location that identifies which tape pool a policy writes to.

 

9 REPLIES 9

Thiago_Ribeiro
VIP
Partner    VIP    Accredited

Hi @dbarrett6

Can you check if your Tapes are assigned for this Pool "NetbackupYearly", instead of "Netbackup"?

Under - Media and Device Management > Media > Volume Pool

 

Thiago



Well, what happens is that if there are no tapes in the Robot/Drive assigned to NetbackupYearly than those policies all fail with :1: (96) unable to allocate new media for backup, storage unit has none available 

But if I switch some tapes to NetbackupYearly than those policies complete and write to the tapes in the NetbackupYearly pool

Thiago_Ribeiro
VIP
Partner    VIP    Accredited

Exactly, if there are no tapes assigned to NetbackupYarly your backup will fail with status 96.

From what I understood, you wanto that the policies runs in "Netbackup" pool instead of "NetbackupYearly" right?

The "Netbackup" pool must have tapes assigned for it

 

Thiago

RiaanBadenhorst
Moderator
Moderator
Partner    VIP    Accredited Certified
Are you referring to backup jobs that had already been completed and the duplication is supposed to go to tape?

If the backups had already been taken on the old setting / volume pool they will continue with those settings.

If you want to update already taken but incomplete jobs you can use bpstlutil and modify the specific version of the slp.

Yes, sorry, these are jobs that have been backed up and are duplicating to tape (I only deal with the tapes and forget that's its just duplicating to tape). The processes (NBU-DP-SU-01-MON-SLP & 02) are recurring every night. I thought that if I just let them finish after the change was made, then the when it started the next day it would pick up the changed setting and start writing to the "Netbackup" pool, but this isn't the case. The change was made several days ago and each day that policy is still writing to the old volume pool.

And for clarification, there are 2 pools - "Netbackup" which all the policies should be writing to, there are lots of tapes in the robot/drive under this pool, and "NetbackupYearly" which should only be written to by 1 policy (NBU-DP-SU01-YEA-SLP) , these tapes get sent off site so I need the other policies to stop writing to these tapes so I send off ONLY the tapes written to by the YEA policy.

open the policy attribute and chek if the storage override is not chked there under the schedule. if yes, check i fhtey are refletign the correct slp  as u need.

RiaanBadenhorst
Moderator
Moderator
Partner    VIP    Accredited Certified

Hi,

Ok so you'll need to use the command line nbstl to update the older version. If you make a change in the GUI it makes a new version of the SLP. 

Example below will show you all the version of TestSLP

nbstl TestSLP -L -all_versions

Suppose you want to change the pool of version number 5, you'll need to run

nbstl TestSLP -modify_version -version 5 -pool__NA__,NetBackup

in the command above the __NA__ is used if the first location for backup is DISK.

manatee
Level 6

have you tried to just restart NBU?

Marianne
Moderator
Moderator
Partner    VIP    Accredited Certified

@dbarrett6

It may help us to understand what the issue is if you show us your config.

Please post output of the following:

 nbstl -L -all_versions

bppllist <policy-name> -U