cancel
Showing results for 
Search instead for 
Did you mean: 

Trouble getting Client dedupe to work error 83

yobole
Level 6

I am tring to backup up a remote server and when I set it up for client dedupe , I get an error 83

26/01/2015 10:18:39 - Info nbjm(pid=7092) starting backup job (jobid=2174552) for client uk1ser01, policy UK-File-WAN-Test, schedule Weekly-Full  
26/01/2015 10:18:39 - Info nbjm(pid=7092) requesting STANDARD_RESOURCE resources from RB for backup job (jobid=2174552, request id:{E529EA9E-3DD1-4D27-B681-FFC6EA5A93E1})  
26/01/2015 10:18:39 - requesting resource stu_disk_uk1bak01
26/01/2015 10:18:39 - requesting resource ser03col1se.NBU_CLIENT.MAXJOBS.uk1ser01
26/01/2015 10:18:39 - requesting resource ser03col1se.NBU_POLICY.MAXJOBS.UK-File-WAN-Test
26/01/2015 10:18:39 - granted resource ser03col1se.NBU_CLIENT.MAXJOBS.uk1ser01
26/01/2015 10:18:39 - granted resource ser03col1se.NBU_POLICY.MAXJOBS.UK-File-WAN-Test
26/01/2015 10:18:39 - granted resource MediaID=@aaab2;DiskVolume=PureDiskVolume;DiskPool=dp_disk_uk1bak01;Path=PureDiskVolume;StorageServer=uk1bak01;MediaServer=uk1bak01
26/01/2015 10:18:39 - granted resource stu_disk_uk1bak01
26/01/2015 10:18:40 - estimated 56 Kbytes needed
26/01/2015 10:18:40 - Info nbjm(pid=7092) started backup (backupid=uknth1ser01_1422267519) job for client uk1ser01, policy UK-File-WAN-Test, schedule Weekly-Full on storage unit stu_disk_uk1bak01
26/01/2015 10:18:42 - started process bpbrm (168808)
26/01/2015 10:18:49 - Info bpbrm(pid=168808) uk1ser01 is the host to backup data from     
26/01/2015 10:18:49 - Info bpbrm(pid=168808) reading file list for client        
26/01/2015 10:18:50 - Info bpbrm(pid=168808) accelerator enabled           
26/01/2015 10:18:53 - connecting
26/01/2015 10:18:55 - Info bpbrm(pid=168808) starting bpbkar on client         
26/01/2015 10:18:55 - connected; connect time: 0:00:02
26/01/2015 10:18:56 - Info bpbkar(pid=7460) Backup started           
26/01/2015 10:18:56 - Info bpbrm(pid=168808) bptm pid: 168831          
26/01/2015 10:18:56 - Info bpbkar(pid=7460) change time comparison:<enabled>          
26/01/2015 10:18:56 - Info bpbkar(pid=7460) accelerator enabled backup, archive bit processing:<disabled>       
26/01/2015 10:18:56 - Info bpbkar(pid=7460) will attempt to use change journal data for <D:\>    
26/01/2015 10:18:57 - Info bptm(pid=168831) start            
26/01/2015 10:18:59 - Info bptm(pid=168831) using 1048576 data buffer size        
26/01/2015 10:18:59 - Info bptm(pid=168831) using 1024 data buffers         
26/01/2015 10:19:00 - Info uklon1bak01(pid=168831) Using OpenStorage client direct to backup from client uk1ser01 to uk1bak01  
26/01/2015 10:19:04 - Critical bptm(pid=168831) sts_open_target_server failed: error 2060023 server is shut down     
26/01/2015 10:19:04 - Critical bptm(pid=168831) failure to open proxy target server uk1bak01: plug-in reports error 2060023 server is shut down
26/01/2015 10:19:05 - Error bptm(pid=168831) Could not set last backup info to client 2060001    
26/01/2015 10:19:05 - Info bptm(pid=168831) EXITING with status 83 <----------        
26/01/2015 10:19:07 - Info bpbkar(pid=7460) done. status: 83: media open error       
26/01/2015 10:19:07 - end writing
media open error(83)

 

However the backup is successful is I disable ClientSide dedupe   . In have configured the hosts files and  run bpclntcmd command successful from both client and  master server   http://www.symantec.com/docs/TECH50198

 

I really would like to use client side dedupe rather than medai side dedupe

 

1 ACCEPTED SOLUTION

Accepted Solutions

Marianne
Moderator
Moderator
Partner    VIP    Accredited Certified

I am out of ideas.

Now that compatibility issues have been addressed, I suggest you get your Symantec Support call escalated.

PS: about the firewall ports - please perform telnet tests in both directions between client and appliance.
Especially 10082 and 10102.
Duble-check forward and reverse name lookup as well.

View solution in original post

13 REPLIES 13

yobole
Level 6

http://www.symantec.com/business/support/index?page=content&id=TECH159295

 

This is the exact issue I am getting but I am on Netbackup 7.6.0.2 and have used the DNS \hosts files

Marianne
Moderator
Moderator
Partner    VIP    Accredited Certified

Have you verified firewall ports for client-side dedupe?

In addition to 1556 (and 13724 if you have enabled WAN Optimization), these ports must be open between client and MSDP server:
10082 
10102

See NetBackup Network Ports Reference Guide  

yobole
Level 6

yes I have the firewall and windows firewall open for Symantec Netbackup Client TCP - 1556, 13724, 13782, 111, 7394, 2049,  10082, 10102,

However the media server is a netbackup applaince 5230 . I have tested telnet on the applinace to the above ports and all is fine . Client is a Windows 2012 R2 64bit

Marianne
Moderator
Moderator
Partner    VIP    Accredited Certified

Troubleshooting is the same for NBU appliance.

Another TN: http://www.symantec.com/docs/TECH137755 

Double-check forward and reverse lookup for short and FQDN with this TN: 

How to verify name resolution for NetBackup (tm) systems, using the "bpclntcmd" command  
http://www.symantec.com/docs/TECH27430 

When and how to clear the NetBackup host cache 
http://www.symantec.com/docs/TECH136792

 

 

yobole
Level 6

Tried all the above still no joy logged a call with Symantec and they have no joy also

the entires below are from the nbostpxy clinet logs

10:18:41.807[12164.17536][ERROR][dummy][log_shmem]libsts openp() 15/01/26 10:18:41: stsm_open_module C:\Program Files\Veritas\NetBackup\bin\\ost-plugins\libstspizapi.dll failed err 2060053 platerr 193: LoadLibrary failed

10:18:58.479[12164.6728][ERROR][dummy][2174552:bptm:168831:uk1bak01][ERROR] PDVFS: pdvfs_register_create_ost_agent: _pdvfs_register_discover failed for spa_addr uk1bak01

10:18:58.479[12164.6728][ERROR][dummy][2174552:bptm:168831:uk1bak01][ERROR] PDVFS: PdvfsRegisterOST: pdvfs_register_create_ost_agent failed: There are no more files.  (10054)


10:18:58.479[12164.6728][ERROR][dummy][2174552:bptm:168831:uk1bak01][ERROR] PDSTS: pd_register: PdvfsRegisterOST(uk1bak01) failed (10054:An existing connection was forcibly closed by the remote host. )


10:18:58.479[12164.6728][ERROR][dummy][2174552:bptm:168831:uk1bak01][ERROR] PDSTS: get_agent_cfg_file_path_for_mount: pd_register() failed for configuration file:<C:\Program Files\Veritas\NetBackup\bin\\ost-plugins\uk1bak01.cfg> (2060019:error occurred on network socket)


10:18:58.479[12164.6728][ERROR][dummy][2174552:bptm:168831:uk1bak01][ERROR] PDSTS: pd_test_for_open_server: uk1bak01 isn't embedded, and get_agent_cfg_file_path_for_mount failed: (2060023:server is shut down)


10:18:58.479[12164.6728][ERROR][dummy][2174552:bptm:168831:uk1bak01][ERROR] PDSTS: impl_open_server: pd_test_for_open_server() failed (2060023:server is shut down)

 

alos found this article  http://www.symantec.com/business/support/index?page=content&id=TECH179320

 

 

 

Marianne
Moderator
Moderator
Partner    VIP    Accredited Certified

What is OS and NBU version on the Client?

Have you double-checked compatibility?

yobole
Level 6

Windows server 2012 R2  NBU version  7.6.0.2 Appliance version 2.6.0.2

yobole
Level 6

http://www.symantec.com/business/support/library/BUSINESS/xCL/TECH76648/nbu_7x_scl.pdf

Looking at the article is says Windows server 2012 R2  dedupe is supported on version 7.6.0.3..OUCH

 

I have configured the client to use  Media server dedupe till I can get the system updated to verion 7.6.0.4. . Whats the downside to this ?

 

will this affect the time the backup will take?

the amount of data sent accross the WAN ?

 

I do have accelerator and chnage journal enabled

Marianne
Moderator
Moderator
Partner    VIP    Accredited Certified

Full version for W2012 R2: 

NB_7.6.0.3.winnt.x64.Server.Win2012R2.exe provides a full installer for NetBackup 7.6.0.3 Servers on x64 Windows 2012 R2
www.symantec.com/docs/TECH217834 

Client can be point-patch higher than master and/or media server.
Version Compatibility TN: http://www.symantec.com/docs/TECH29677 

I cannot say what exactly the result will be with Client dedupe disabled and Accelerator and Change Journal enabled. 
You will have to try and see.

Install supported NBU version on client ASAP.

suhas_kakade
Level 3
Partner Accredited

Hi,

Verify that all remote client services startes i.e. running on server.

You need to upgrade teh agent to the final release.

 

 

 

yobole
Level 6

Master , Media server and clients have all been upgraded to verison 7.6.0.4

However still getting error 83 when using the Appliance Media server with client dedupe enabled . once I disable clie-side dedupe it works ..

On the windows Media server also on 7.6.0.4 it works wirh client-dedupe enabled

 

The client is on Windows 2012 R2 and really need it to work on the 5230appliance ....

Marianne
Moderator
Moderator
Partner    VIP    Accredited Certified

I am out of ideas.

Now that compatibility issues have been addressed, I suggest you get your Symantec Support call escalated.

PS: about the firewall ports - please perform telnet tests in both directions between client and appliance.
Especially 10082 and 10102.
Duble-check forward and reverse name lookup as well.

View solution in original post

yobole
Level 6

looks like i have found the culprit . we have an external firewall between the client and Medais server . although i can telnet on port 10102 there was still a rule denying the traffic ..

 

Thnaks for all your help