cancel
Showing results for 
Search instead for 
Did you mean: 

Trying to reconnect to a MSDP after Master reinstall

We cannot reconnect to a MSDP whose NetBackup software was reinstalled.

We have a NetBackup Master Server which is out of support because it's still using Windows 2008 R2, it had NetBackup 8.0 and has an underscore in its hostname. Also, it has a MSDP which is not recommended. We decided that the first thing to fix was to make an upgrade from 8.0 to 8.2.

The upgrade process ended succesfully but TomCat refused to work ("java.lang.IllegalArgumentException: The character [_] is never valid in a domain name."), so the Web Management Console Server presented problems and the platform was unusable.

So we just reinstalled NetBackup 8.0 and recovered the catalog, but the MSDP refused connections: "Wed 03/24/2021 7:44:21.19 ERROR: Your PDDE storage data format is ahead of software supported version, not allowed to reuse".

Therefore, we made a clean install of NetBackup 8.2 after renaming the Windows hostname (without an underscore) and adding the old hostname as an alias in the hosts table. This gave us new errors, where when trying to recreate the MSDP we could create a Disk Storage Server but not a Disk Pool. Specifically, we got a "No Volumes Found" while "nbdevconfig -previewdv" showed nothing. Also, spad.exe and spoold.exe both show the following errors:

Error: 25017: DaemonLockSimpleTestW: pipe already exists
Error: 25001: spoold: a conflicting instance is currently active.
Error: 26016: Veritas PureDisk Content Router: Bootstrap failure.

 

Thank you for reading so far and I would appreciate any ideas you could share with us.

1 Solution

Accepted Solutions
Accepted Solution!

Re: Trying to reconnect to a MSDP after Master reinstall

Hello
I am sorry to say this but It looks like the upgrade wasn’t planned well. You should have ran sort tool to generate upgrade checklist. This would have reported the problem with host name and the mess would have prevented.

https://www.veritas.com/support/en_US/article.100047335?profileURL=https%3A%2F%2Fvam-profile.veritas...

Hostnames with underscore in it are not supported.

I am afraid but the data on msdp is at risk.

May the power be with you!!
All The Best !!

View solution in original post

5 Replies

Re: Trying to reconnect to a MSDP after Master reinstall

Hi @Alexis_Jeldrez 

My suggestion is to log a support case and see if they can assist. The OS being out of support is a secondary issue in this case. 

That said - the server name is embedded within the MSDP configuration in a number of configuration files. All live under <Path to MSDP>\etc\puredisk\ - such as spa.cfg, agent.cfg & contentrouter.cfg - which may be why you are unable to reattach the MSDP as you have changed the server name. 

So I have no idea if this will work and it is not something I have tried, and definitedly not something I would recommend to try on a production system with important data. You could update the various places with the new server name and see if that allows your MSDP to come up. 

Again, if this is important data, my first recommendation is to log a case and get support to assist.

David

Re: Trying to reconnect to a MSDP after Master reinstall

I opened a Support Case before making this thread.

As for the embedded name, I searched for all the clear text files inside the MSDP folder and couldn't find present references to the old name (which had an underscore). I mean, there are references, but in old historic config files in desuse (instead of "agent.cfg" it's called "agent.cfg.2017-10-17_11-50-38"). In <MSDP>\log\spoold\ I even found folders for both the old and the new hostnames; the old one is no longer used though.

I'm attaching the current version of the cfg files you mentioned; they don't reference the old hostname with an underscore ("nb_server").

Accepted Solution!

Re: Trying to reconnect to a MSDP after Master reinstall

Hello
I am sorry to say this but It looks like the upgrade wasn’t planned well. You should have ran sort tool to generate upgrade checklist. This would have reported the problem with host name and the mess would have prevented.

https://www.veritas.com/support/en_US/article.100047335?profileURL=https%3A%2F%2Fvam-profile.veritas...

Hostnames with underscore in it are not supported.

I am afraid but the data on msdp is at risk.

May the power be with you!!
All The Best !!

View solution in original post

Re: Trying to reconnect to a MSDP after Master reinstall

Hi @Alexis_Jeldrez 

As you say, the new hostname is now in the config files. 

The only other thing to check might be to verify that the initial config file that tells NetBackup where the MSDP storage is located has the correct value. On windows this is stored in the registry <HKLM>\Software\Symantec\PureDisk\Agent\ ConfigFilePath and EtcPath. If these aren't pointing to the correct location maybe changing them will help. You will also probably need to manage/reenter the password used when you originally setup the pool (not sure if required).

Other than that I have no further advice other than to wait and see if support can help you - sorry

David

Re: Trying to reconnect to a MSDP after Master reinstall

Indeed, the upgrade wasn't properly planned. The NetBackup 8.2 Install guide clearly says that hostnames with underscores are not supported. We had a backup of almost everything but we did not backup the data in the MSDP storage.

To stay in support, we're migrating to a newer version of Windows Server. We will install NetBackup from scratch with no underscores anywhere. Importing hundreds of tapes will take us some months, though.

Thanks for the support.