cancel
Showing results for 
Search instead for 
Did you mean: 

Unable to restore files (ndmp) using Veritas netbackup 6.5

Bnj_V
Level 3

Hello Guys,

I would like to ask assistance regarding the issue we encountered. Our restore jobs always fails. Unfortunately, Veritas netbackup 6.5 is already end of support from symantec. Please see logs below. I can also provide you additional logs if needed. 

=======================================================================

Job Deatails Logs:

07212015 151106 - begin Restore
07212015 151106 - media needed P30900
07212015 151106 - media needed P30068
07212015 151106 - media needed P30925
07212015 151106 - media needed P30901
07212015 151106 - restoring from image atp4nfs02P_1425571206
07212015 151107 - connecting
07212015 151107 - connected; connect time 00000
07212015 151107 - started process bptm (pid=15570)
07212015 151108 - requesting resource P30068
07212015 151110 - started process bptm (pid=15570)
07212015 151110 - mounting P30068
07212015 151112 - Error bptm (pid=15570) error requesting media, TpErrno = Robot operation failed
07212015 151109 - granted resource  P30068
07212015 151109 - granted resource  atp4nfs02P-drive
07212015 151112 - current media P30068 complete, requesting next media atp4nfs02P-driveInfinity_PoolP30068
07212015 151140 - started process bptm (pid=15570)
07212015 151140 - mounting P30068
07212015 151139 - granted resource  P30068
07212015 151139 - granted resource  atp4nfs02p-dr
07212015 151225 - mounted P30068; mount time 00045
07212015 151225 - positioning P30068 to file 3
07212015 151305 - positioned P30068; position time 00040
07212015 151305 - begin reading
07212015 163246 - started process bptm (pid=15570)
07212015 163246 - mounting P30900
07212015 163244 - current media P30068 complete, requesting next media atp4nfs02p-drP30900
07212015 163245 - granted resource  P30900
07212015 163245 - granted resource  atp4nfs02P-drive
07212015 163255 - Error bptm (pid=15570) error requesting media, TpErrno = Robot operation failed
07212015 163255 - current media P30900 complete, requesting next media atp4nfs02P-driveInfinity_PoolP30900
07212015 163327 - granted resource  P30900
07212015 163327 - granted resource  atp4nfs02p-dr
07212015 163329 - started process bptm (pid=15570)
07212015 163329 - mounting P30900
07212015 163411 - mounted P30900; mount time 00042
07212015 163411 - positioning P30900 to file 1
07212015 163411 - positioned P30900; position time 00000
07212015 163411 - begin reading
07212015 164114 - Error ndmpagent (pid=15569) Connection was closed but has not yet been destroyed.
07212015 164114 - Error ndmpagent (pid=15569) Connection was closed but has not yet been destroyed.
07212015 164114 - Error ndmpagent (pid=15569) MoverGetState called with no session
07212015 164114 - Error ndmpagent (pid=15569) Connection was closed but has not yet been destroyed.
07212015 164114 - Error ndmpagent (pid=15569) Connection was closed but has not yet been destroyed.
07212015 164114 - Error ndmpagent (pid=15569) MoverGetState called with no session
07212015 164114 - Error ndmpagent (pid=15569) NDMP restore failed from path voldata
07212015 164115 - Error ndmpagent (pid=15569) Connection was closed but has not yet been destroyed.
07212015 164115 - Error ndmpagent (pid=15569) Connection was closed but has not yet been destroyed.
07212015 164115 - Error ndmpagent (pid=15569) Connection was closed but has not yet been destroyed.
07212015 164115 - Error ndmpagent (pid=15569) MoverGetState called with no session
07212015 164115 - Error ndmpagent (pid=15569) Connection was closed but has not yet been destroyed.
07212015 164116 - Error bpbrm (pid=15559) client restore EXIT STATUS 23 socket read failed
07212015 164117 - restored from image atp4nfs02P_1425571206; restore time 13011
07212015 164117 - end Restore; elapsed time 13011
the restore failed to recover the requested files (5)

========================================================================

root@backupsp01 # /usr/openv/volmgr/bin/vmoprcmd -hoststatus

                       CURRENT HOST STATUS

Host backupsp01 is ACTIVE

 

root@abackupsp01 # /usr/openv/volmgr/bin/vmoprcmd

                           HOST STATUS
Host Name                                  Version   Host Status
=========================================  =======   ===========
backupsp01                             650000    ACTIVE

                                PENDING REQUESTS


                                    <NONE>

                                  DRIVE STATUS

Drive Name               Label   Ready  RecMID  ExtMID  Wr.Enbl.  Type
    Host                       DrivePath                            Status
=============================================================================
HP.ULTRIUM3-SCSI.000     Yes     Yes    P30829  P30829  Yes       hcart3
    backupsp01             /dev/rmt/2cbn                        ACTIVE

HP.ULTRIUM3-SCSI.001     Yes     Yes    P30524  P30524  Yes       hcart3
    backupsp01             /dev/rmt/4cbn                        ACTIVE

HP.ULTRIUM3-SCSI.004     Yes     Yes    P30892  P30892  Yes       hcart3
    backupsp01             /dev/rmt/0cbn                        ACTIVE

atp4nfs02P-drive         No      No                     No        hcart3
    backupsp01             rst1l (atp4nfs02P)                    TLD
    backupsp01             nrst1a (atp4nfs02P)                  TLD

atp4nfs02p-dr            No      No                     No        hcart3
    backupsp01             rst0l (atp4nfs02P)                   SCAN-TLD
    backupsp01             nrst0a (atp4nfs02P) 

============================================================================

I would appreciate your comments and suggestions.

Thank you very much in advance.

1 ACCEPTED SOLUTION

Accepted Solutions

Bnj_V
Level 3

Hi, this issue has been resolved. 

I am very much thankful to one symantec support engr for the continuous support even our nbu (6.5) is EOS.

 

This was her findings:

 "we found that drive 5 [atp4nfs02P-drive] contains stuck tape P30749.

Please make sure you remove the stuck tape and move it to appropriate slot.

Also for testing purpose I had moved media P30068 to drive 3. Please move the tape back to the slot.

Then stop and restart nbu services.

Once done test a restore."

After all, restore jobs were successful. Im just confused why error and logs are different from the real case. It should say there's a stucked tape. Anyway..thanks!!

 

 

 

View solution in original post

2 REPLIES 2

Marianne
Level 6
Partner    VIP    Accredited Certified

This looks like a network timeout.

You need the following logs on NDMP media server:

ndmpagent, bpbrm and bptm.

Increase logging level for bptm and bpbrm to minimum of 3.

Bnj_V
Level 3

Hi, this issue has been resolved. 

I am very much thankful to one symantec support engr for the continuous support even our nbu (6.5) is EOS.

 

This was her findings:

 "we found that drive 5 [atp4nfs02P-drive] contains stuck tape P30749.

Please make sure you remove the stuck tape and move it to appropriate slot.

Also for testing purpose I had moved media P30068 to drive 3. Please move the tape back to the slot.

Then stop and restart nbu services.

Once done test a restore."

After all, restore jobs were successful. Im just confused why error and logs are different from the real case. It should say there's a stucked tape. Anyway..thanks!!