cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted

Unable to retrieve old backups from cartridges

Hi Everyone,

I have an issue in retrieving data from cartridges which was backedup in the month of May and June and was written from universal share to Tape directly. It backup only one copy which was written on tape, and then in the month of July The Customer required to make copies to DR side, so we create SLP's and override it in the policy. Now i want to restore data from the month May and July and i can't see any backup from these months while its retention was set to 2 years. I can't see backups in catalogs  or anywhere else. Can you guys help me out.

My environment is  three tier on PR side and tow tier on DR side. Your help in this regard will be highly appreciated. 

Tags (2)
13 Replies
Highlighted

Re: Unable to retrieve old backups from cartridges

Hi Amjad , are you trying to restore on Production site or on DR site ? SLP operations does not work on the already backedup data , it will apply to new bakups only  ,so if you are trying to restore from DR site , data from May and June probably wont be there. And if youy are trying to restore fromproduction server and you cant find the data , that indicates imaegs are expired manually .Inthat case , import the images.

 

DeepS

Highlighted

Re: Unable to retrieve old backups from cartridges

search the catalog for those images and check the copy number. That could be the issue.

If you copied the image and allocated the DR as primary, then when you restore that is the one that it will ask for, even though  there may be a local image. You can change the primary image with the GUI catalog, or there is a touch file you can create that allows you to restore from a non primary image.

 

NetBackup 8.1.2 on Solaris 11, writing to DataDomain 9800 6.0.2.50
duplicating via SLP to LTO5 in SL8500 via ACSLS
Tags (2)
Highlighted

Re: Unable to retrieve old backups from cartridges

Hi Deeps, thanks for your reply i am trying to restore on Primary side as my data was backedup here and was not replicated to DR side before 27th of august, and backups were taken from universal share to tape directly using Co-pilot technique, i have opened case with veriras, the siupport engineer also told me that the images might be expired manually or may be it retention was lower before the creation of SLP. when i see the cartridges in that pool created for this client the cartridges are full with data and it is also showing first and last mount. I the catalogs there is not any information of that data even i have imported data from those cartridges.

Now i want help to get information on is there any way to retrieve data, or if someone expires those images accidentally OR incidentally how can i get that information, OR how can i see what was the retention of that data before creation of SLP. Someone also clear the logs. 

Now in the catalogs i can see only the data from 27th of auggust.

Highlighted

Re: Unable to retrieve old backups from cartridges

Hi Genericus,

We were not creating any copies untill 27th of the august, we were just backing up that data from universal share to directly tape. 

Tags (1)
Highlighted

Re: Unable to retrieve old backups from cartridges

@Amjad_Mehmood 

Your opening post is slightly confusing....  It seems that the duplication process that was added afterwards is totally irrelevant? 

What did your backup policy look like between May and June/July? 

If you backed up the Universal Share, it means that the Client in the policy was an Appliance hostname, right? 
What was the policy type? And retention?

Can you run Client backup report (or bpimagelist) for this client name for that period? 

Highlighted

Re: Unable to retrieve old backups from cartridges

Hi Mariane,

From 1st of may 2019 we were backing up data from universal share which was created on appliance which is also our media server OR we can say from MSDP which we mounted on client machine, DB adminstrator copies dump files over this universal share from where we took backups to the tape. 

From August 27 customer require different copies for further data of this client, so craete an SLP in which the primary copy was written on MSDP, 1st copy was written on tape and the 2nd copy was replicated to DR MSDP and then to DR Tape. Data retention was set to 2 years.

Now i am just getting data or information in catalog from 5 july not any previus data. Here are some Logs which may help you understanding this issue

./nbauditreport | grep -i ExaData_DB_10

11/14/2019 13:21:54      root@         Policy 'ExaData_DB_10' was saved but no changes were detected

11/11/2019 15:53:58      root@         Policy 'ExaData_DB_10' was activated

11/11/2019 14:06:41      root@         Policy 'ExaData_DB_ 10' was deactivated

11/06/2019 11:29:20      root@         Policy 'ExaData_DB_ 10' was saved but no changes were detected

10/24/2019 12:53:31      root@         Policy 'ExaData_DB_10' was activated

10/24/2019 12:53:28      root@         Policy 'ExaData_DB_10' was saved but no changes were detected

10/24/2019 12:41:32      root@         Policy 'ExaData_DB_10' was deactivated

10/15/2019 10:46:13      root@         Policy 'ExaData_DB_10' was activated

10/15/2019 10:38:23      root@         Include list settings of Policy 'ExaData_DB_10' were modified

10/15/2019 10:38:23      root@         Include list settings of Policy 'ExaData_DB_10' were modified

10/15/2019 10:38:23      root@         Policy 'ExaData_DB_10' was saved but no changes were detected

10/14/2019 17:17:28      root@         Policy 'ExaData_DB_10' was deactivated

10/07/2019 18:07:31      root@         Policy 'ExaData_DB_10' was activated

10/07/2019 18:07:29      root@         Policy 'ExaData_DB_10' was deactivated

10/07/2019 12:09:24      root@         Policy 'ExaData_DB_10' was activated

10/04/2019 10:49:41      root@         Policy 'ExaData_DB_10' was deactivated

10/02/2019 15:46:52      root@         Attributes of Policy 'ExaData_DB_10' were modified

10/02/2019 11:52:23      root@         Attributes of Policy 'ExaData_DB_10' were modified

10/02/2019 10:32:51      root@         Policy 'ExaData_DB_10' was activated

09/30/2019 09:08:12      root@         Policy 'ExaData_DB_10' was deactivated

09/26/2019 11:19:46      root@         Policy 'ExaData_DB_10' was activated

09/25/2019 08:49:34      root@         Policy 'ExaData_DB_10' was deactivated

09/24/2019 17:25:44      root@         Policy 'ExaData_DB_10' was activated

09/17/2019 15:15:49      root@         Policy 'ExaData_DB_10' was deactivated

09/13/2019 17:59:03      root@         Policy 'ExaData_DB_10' was activated

09/13/2019 17:56:16      root@        Policy 'ExaData_DB_10' was deactivated

09/13/2019 10:00:34      root@         Policy 'ExaData_DB_10' was activated

08/30/2019 16:04:49      root@         Policy 'ExaData_DB_10' was deactivated

08/29/2019 12:29:18      root@         Policy 'ExaData_DB_10' was activated

08/28/2019 20:11:10      root@         Policy 'ExaData_DB_10' was deactivated

08/28/2019 16:19:26      root@         Policy 'ExaData_DB_10' was activated

08/27/2019 18:41:27      root@         Policy 'ExaData_DB_10' was deactivated

08/27/2019 18:21:40      root@         Policy 'ExaData_DB_10' was activated

08/27/2019 18:20:21      root@         Attributes of Policy 'ExaData_DB_10' were modified

08/27/2019 18:15:26      root@         Storage Lifecycle Policy 'ExaData_DB_10_SLP' was deleted.

08/27/2019 18:07:53      root@         Attributes of Storage Lifecycle Policy 'ExaData_DB_10_SLP' were modified.

08/27/2019 12:46:46      root@         Attributes of Storage Lifecycle Policy 'ExaData_DB_10_SLP' were modified.

08/27/2019 12:33:13      root@         Storage Lifecycle Policy 'ExaData_DB_10_SLP' was created.

08/23/2019 17:25:44      root@         Policy 'ExaData_DB_10' was deactivated

08/23/2019 12:17:29      root@         Policy 'ExaData_DB_10' was activated

08/22/2019 17:42:03      root@         Policy 'ExaData_DB_10' was deactivated

08/22/2019 10:40:14      root@         Policy 'ExaData_DB_10' was activated

08/21/2019 16:18:05      root@         Policy 'ExaData_DB_10' was deactivated

08/21/2019 10:43:04      root@         Policy 'ExaData_DB_10' was activated

[root@ admincmd]# ./nbauditreport | grep -i ExaData_SLP

10/28/2019 20:41:52      root@         Storage Lifecycle Policy 'ExaData_SLP_PRI_10' was activated.

10/28/2019 20:17:08      root@         Storage Lifecycle Policy 'ExaData_SLP_PRI_10' was deactivated indefinitely.

08/27/2019 18:41:22      root@         Attributes of Storage Lifecycle Policy 'ExaData_SLP_PRI_10' were modified.

08/27/2019 18:21:09      root@         Attributes of Storage Lifecycle Policy 'ExaData_SLP_PRI_10' were modified.

08/27/2019 18:19:19      root@         Attributes of Storage Lifecycle Policy 'ExaData_SLP_PRI_10' were modified.

08/27/2019 18:15:43      root@         Attributes of Storage Lifecycle Policy 'ExaData_SLP_PRI_10' were modified.

08/27/2019 18:15:17      root@         Storage Lifecycle Policy 'ExaData_SLP_PRI_10' was created.

Re: Unable to retrieve old backups from cartridges

If you backed up the Universal Share, it means that the Client in the policy was an Appliance hostname, right? 

Yes


What was the policy type?

Standard

And retention?

for tape it was for 10 years

Highlighted

Re: Unable to retrieve old backups from cartridges

@Amjad_Mehmood 

Output of nbauditreport does not tell us what policies looked like during before the changes.

If your retention period was long enough, and nobody has manually expired backups, and your search criteria is correct, then there is no reason why backups cannot be seen.

Can you run Client backup report (or bpimagelist) for this client name (Appliance) for that period? 

 

Highlighted

Re: Unable to retrieve old backups from cartridges

@Marianne 

From bpimagelist it is showing 1st backup from 5th of July. Before 5th July nothing is shoing anywhere. 

As vendor we are not allowed to share thoses logs with. 

Highlighted

Re: Unable to retrieve old backups from cartridges


From bpimagelist it is showing 1st backup from 5th of July. Before 5th July nothing is shoing anywhere. 

 


One of 3 possible reasons:

1. Retention in policy schedules was shorter than you think it was
2. Incorrect search criteria
3. Someone has manually expired images

If you need assistance with investigation, you and your customer will need to trust someone to have a look at logs and image listings.
Will your customer allow you to log a call with Veritas Support?

Highlighted

Re: Unable to retrieve old backups from cartridges

@Marianne 

Thank you for your help. We already created the case with veritas they looked into logs as well and they also told same as you did weather  

1. Retention in policy schedules was shorter earlier and then it was increased

3. Someone has manually expired images

and so far we are unable get the data.

Highlighted

Re: Unable to retrieve old backups from cartridges

@Amjad_Mehmood 

If retention was incorrect or images were manually expired, there is nothing within NBU that will have any record of those backups or tapes/media-id's that were used.

There are 2 possibilities where you might be able to retrieve info - 
- If you have OpsCenter Analytics, you might be able to retrieve backup reports prior to July to see which media-ids were used
- If you track tapes being sent offsite outside of NBU, you can check which tapes were used.

Check reports such as Tape List report to see when last these tapes were used for backups.
If tapes have not been overwritten in the meantime, you will be able to put the tapes back in the robot, add them to a non-backup pool (to prevent accidental overwrite) and import the tapes. 
Run phase 1 import on all tapes in the backup set, then run phase 2 import on required images.

 

Highlighted

Re: Unable to retrieve old backups from cartridges

One teeny tiny additional suggestion to what Marianne said regarding the media, if you can locate the earlier stuff, BEFORE you put them in the library to import, set the write protect tabs on them.  This way, in case there's a bit of a lag between when the media go in and get inventoried by NetBackup, and when you go to move them to the non-backup pool, they can't be used by NetBackup. (particularily helpful when you have a busy NB environment, and tape operator's or automatic processes that keep NB's inventory up to date with the library's inventory.)

You can clear the write protect tabs later, once you deem these media safe to re-use, and then move them to Scratch.