cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted

Unable to take SAP online backup using RMAN - Linked with Netbackup

Hi Friends,

Need your expert advice to resolve this issue... Thanks in advance.

 

Error when backup initiated using BRTOOL

RMAN-03009: failure of allocate command on sbt_1 channel at 03/21/2014 17:29:42
ORA-19554: error allocating device, device type: SBT_TAPE, device name:
ORA-27211: Failed to load Media Management Library

 

Scenario:
Policy: Configured RMAN scripts to take SAP online backup using BRTOOL
Environment: SAP on Oracle 11g with RMAN (Windows)
Backup Initiator: In this scenario SAP team will be initiated backup from BRTOOL (not from NetBackup)
Netbackup: Netbackup Software Version 7.6.0.1 (Appliance 5230, Firmware 2.6)

(Attached .sap, .utl & sap_rman_backup cmd file for your reference)

 

Thank You,

Vaibhav

1 Solution

Accepted Solutions
Highlighted
Accepted Solution!

How to I fix the ORA-19554

How to I fix the ORA-19554 and ORA-27211 errors?

Answer:  The "failed to load media management library" error can happen when libobk.so is not linked to your backup vendor supplied rman library. 

http://www.dba-oracle.com/t_ora-19554_ora-27211_failed_media_management_library.htm

 

View solution in original post

4 Replies
Highlighted

The issue isn't with the

The issue isn't with the scripts - it's with the ability to allocate a drive.

 

What is the storage unit in the policy?  (policy sap_backup)

Highlighted

Dear Deb, I am using

Dear Deb,

I am using Netbackup appliance and storage unit in policy is dedupe storage of same appliance.

Highlighted
Accepted Solution!

How to I fix the ORA-19554

How to I fix the ORA-19554 and ORA-27211 errors?

Answer:  The "failed to load media management library" error can happen when libobk.so is not linked to your backup vendor supplied rman library. 

http://www.dba-oracle.com/t_ora-19554_ora-27211_failed_media_management_library.htm

 

View solution in original post

Highlighted

Resolved:) orasbt.dll file

ResolvedSmiley Happy

orasbt.dll file was missing in oracle/bin directiry. Normally It should show by default after agent installation.

Copied it from \windows\system32 to %install path%\oracle\bin