VCenter HTML5 plugin problem

Hi

I have NetBackup 8.2 and want install plugin for vsphere client 6.7 U2 (Html5)

in Support for NetBackup 7.7.x and 8.x in virtual environments Requirement is:

The NetBackup plug-in for vSphere Client (HTML5) is introduced at NetBackup 8.1.2.

vSphere Client (HTML5) 6.5 update 1 and later

is it included vSphere Client (HTML5) 6.7 update 2?

 

as Veritas NetBackup™ Plug-in for VMware vSphere Client (HTML5) Guide Release I followed this steps:

master and media server are as backup host

the credential is administrator, DNS name and fqdn is OK, credential has Extension privilege, the VimApiUrl and Runtime value is OK, I execute vwcp_manage.exe and everything is ok and said:

The NetBackup Plug-in for VMware vSphere Web Client is currently not registered with the vCenter server.
The NetBackup Plug-in for VMware vSphere Web Client has been registered successfully. Please see the topic 'Port usage for the plug-in' in the Web Client plug-in guide for a list of standard ports used by the NetBackup Plug-in for VMware vSphere Web Client.

I reloeded HTML5 page (log off and login) but plugin is not available, but in FLEX it's OK

in event said:

Cannot complete the operation. See the event log for details.

This is a vSphere Web Client (Flash) only plugin indicated by the missing type="html" plugin manifest attribute.

in https://communities.vmware.com/thread/609452 it says:

There is a new vSphere Client (HTML) feature in 6.7U2 that displays plugin deployment status messages for the HTML Client. and another one says:

I think this is why the error messages happened . That is flash only plugin , when you login HTML5 web client , this plugin is incompatible. I think we can ignore the error message.

I dunno this message is for HTML5 or Flex.

 

in vsphere_client_virgo.log I found this:

[2019-08-18T14:52:13.700Z] [INFO ] -extensionmanager-pool-27127 70013556 101086 200042 com.vmware.vise.vim.extension.PluginStatusTaskManager DOWNLOADING: Downloading plugin package com.symantec.netbackup.plugin:8.2 from https://***.***.net:8443/nbwebservice/plugins/netbackup-vwc-plugin.zip ...
[2019-08-18T14:52:13.701Z] [INFO ] ce-extension-mngr-pool-27128 70013556 101086 200042 com.vmware.vise.util.PropertyUtil Property 'plugin.signature.check.enabled' is missing. Will use the default: true
[2019-08-18T14:52:13.702Z] [WARN ] ce-extension-mngr-pool-27128 70013556 101086 200042 c.vmware.vise.vim.directory.extensions.DirectoryExtensionManager Detected an invalid signature for plugin: com.vmware.vcIntegrity.vcIntegrity:6.7.0.41703 - com.vmware.vise.extensionfw.signing.PluginSignatureException: No META-INF/MANIFEST.MF entry found in the plugin zip file.
[2019-08-18T14:52:13.703Z] [INFO ] ce-extension-mngr-pool-27128 70013556 101086 200042 com.vmware.vise.vim.extension.PluginStatusTaskManager DEPLOYING: Deploying plugin package com.vmware.vcIntegrity.vcIntegrity:6.7.0.41703 ...
[2019-08-18T14:52:13.731Z] [INFO ] ce-extension-mngr-pool-27130 70013556 101086 200042 com.vmware.vise.util.PropertyUtil Property 'plugin.signature.check.enabled' is missing. Will use the default: true
[2019-08-18T14:52:13.731Z] [WARN ] ce-extension-mngr-pool-27130 70013556 101086 200042 c.vmware.vise.vim.directory.extensions.DirectoryExtensionManager Detected an invalid signature for plugin: com.vmware.fallback.mixed:6.5.0 - com.vmware.vise.extensionfw.signing.PluginSignatureException: No META-INF/MANIFEST.MF entry found in the plugin zip file.
[2019-08-18T14:52:13.764Z] [WARN ] ce-extension-mngr-pool-27129 70013556 101086 200042 c.vmware.vise.vim.directory.extensions.DirectoryExtensionManager Could not download bundle com.vmware.imagebuilder.imagebuilder from https://***.***.net:443/vmw/imagebuilder/httpd/autodeploy-modules-plugins.zip.
[2019-08-18T14:52:13.933Z] [INFO ] m-catalog-manager-pool-27123 70013556 101086 200042 com.vmware.vise.vim.lookup.LsCatalogManager detectServiceProviders took (ms):429
[2019-08-18T14:52:13.933Z] [ERROR] m-catalog-manager-pool-27123 70013556 101086 200042 com.vmware.vise.vim.lookup.LsCatalogManager Unable to extract service version for: NetBackup_8.2 java.lang.NumberFormatException: For input string: "NetBackup_8"
at java.lang.NumberFormatException.forInputString(NumberFormatException.java:65)
at java.lang.Integer.parseInt(Integer.java:580)
at java.lang.Integer.parseInt(Integer.java:615)
at com.vmware.vise.util.Version.<init>(Version.java:58)
at com.vmware.vise.vim.lookup.LsCatalogManager.extractServiceInfoVersion(LsCatalogManager.java:1348)
at com.vmware.vise.vim.lookup.LsCatalogManager.extractBestServiceInfo(LsCatalogManager.java:1314)
at com.vmware.vise.vim.lookup.LsCatalogManager.hasBetterServiceInfoCandidate(LsCatalogManager.java:1064)
at com.vmware.vise.vim.lookup.LsCatalogManager.access$800(LsCatalogManager.java:98)
at com.vmware.vise.vim.lookup.LsCatalogManager$2.call(LsCatalogManager.java:832)
at com.vmware.vise.vim.lookup.LsCatalogManager$2.call(LsCatalogManager.java:788)
at java.util.concurrent.FutureTask.run(FutureTask.java:266)
at com.vmware.vise.util.concurrent.QueuingCachedThreadPool$QueueProcessor.run(QueuingCachedThreadPool.java:1229)
at java.util.concurrent.Executors$RunnableAdapter.call(Executors.java:511)
at java.util.concurrent.FutureTask.run(FutureTask.java:266)
at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1149)
at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:624)
at com.vmware.vise.util.concurrent.WorkerThreadFactory$1.run(WorkerThreadFactory.java:64)
at java.lang.Thread.run(Thread.java:748)

[2019-08-18T14:52:13.934Z] [ERROR] m-catalog-manager-pool-27123 70013556 101086 200042 com.vmware.vise.vim.lookup.LsCatalogManager Unable to extract service version for: NetBackup_8.2 java.lang.NumberFormatException: For input string: "NetBackup_8"
at java.lang.NumberFormatException.forInputString(NumberFormatException.java:65)
at java.lang.Integer.parseInt(Integer.java:580)
at java.lang.Integer.parseInt(Integer.java:615)
at com.vmware.vise.util.Version.<init>(Version.java:58)
at com.vmware.vise.vim.lookup.LsCatalogManager.extractServiceInfoVersion(LsCatalogManager.java:1348)
at com.vmware.vise.vim.lookup.LsCatalogManager.hasBetterServiceInfoCandidate(LsCatalogManager.java:1065)
at com.vmware.vise.vim.lookup.LsCatalogManager.access$800(LsCatalogManager.java:98)
at com.vmware.vise.vim.lookup.LsCatalogManager$2.call(LsCatalogManager.java:832)
at com.vmware.vise.vim.lookup.LsCatalogManager$2.call(LsCatalogManager.java:788)
at java.util.concurrent.FutureTask.run(FutureTask.java:266)
at com.vmware.vise.util.concurrent.QueuingCachedThreadPool$QueueProcessor.run(QueuingCachedThreadPool.java:1229)
at java.util.concurrent.Executors$RunnableAdapter.call(Executors.java:511)
at java.util.concurrent.FutureTask.run(FutureTask.java:266)
at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1149)
at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:624)
at com.vmware.vise.util.concurrent.WorkerThreadFactory$1.run(WorkerThreadFactory.java:64)
at java.lang.Thread.run(Thread.java:748)

[2019-08-18T14:52:13.941Z] [INFO ] m-catalog-manager-pool-27132 70013564 101086 200042 com.vmware.vise.vim.lookup.LsCatalogManager Loading properties for /etc/vmware/vsphere-ui/cmCatalog/com.vmware.cis.com.symantec.netbackup.plugin.zip:US
[2019-08-18T14:52:13.942Z] [INFO ] m-catalog-manager-pool-27131 70013563 101086 200042 com.vmware.vise.vim.lookup.LsCatalogManager downloadResourceBundle: Trying https://***.***.net:443/catalog/com.symantec.netbackup.plugin_catalog.zip
[2019-08-18T14:52:13.946Z] [INFO ] m-catalog-manager-pool-27123 70013556 101086 200042 com.vmware.vise.vim.lookup.LsCatalogManager processResourceBundles took (ms):12
[2019-08-18T14:52:13.946Z] [INFO ] m-catalog-manager-pool-27133 70013565 101086 200042 com.vmware.vise.vim.lookup.LsCatalogManager Loading properties for /etc/vmware/vsphere-ui/cmCatalog/com.vmware.vim.sms.sms-6.7.0.0.zip:US
[2019-08-18T14:52:13.946Z] [INFO ] m-catalog-manager-pool-27133 70013565 101086 200042 com.vmware.vise.vim.lookup.LsCatalogManager Time waiting for csp info (ms) for /etc/vmware/vsphere-ui/cmCatalog/com.vmware.vim.sms.sms-6.7.0.0.zip:US: 0
[2019-08-18T14:52:13.950Z] [INFO ] m-catalog-manager-pool-27133 70013565 101086 200042 com.vmware.vise.vim.lookup.LocalizedMessageDictionary Loaded Resource bundle cis.sms.ResourceBundle
[2019-08-18T14:52:13.951Z] [WARN ] m-catalog-manager-pool-27133 70013565 101086 200042 com.vmware.vise.vim.lookup.LocalizedMessageDictionary 227 Resource Bundle entry conflicts found for: /etc/vmware/vsphere-ui/cmCatalog/com.vmware.vim.sms.sms-6.7.0.0.zip/cis.sms.ResourceBundle:US
[2019-08-18T14:52:13.951Z] [INFO ] m-catalog-manager-pool-27133 70013565 101086 200042 com.vmware.vise.vim.lookup.LocalizedMessageDictionary Loaded 227 elements from bundle: /etc/vmware/vsphere-ui/cmCatalog/com.vmware.vim.sms.sms-6.7.0.0.zip/cis.sms.ResourceBundle:US
[2019-08-18T14:52:13.951Z] [INFO ] m-catalog-manager-pool-27133 70013565 101086 200042 com.vmware.vise.vim.lookup.LsCatalogManager Time to load properties (ms)/etc/vmware/vsphere-ui/cmCatalog/com.vmware.vim.sms.sms-6.7.0.0.zip:US: 5
[2019-08-18T14:52:13.961Z] [INFO ] -extensionmanager-pool-27127 70013556 101086 200042 com.vmware.vise.vim.commons.vcservice.impl.VcServiceImpl loginByToken successful on vc https://***.***.net:443/sdk
[2019-08-18T14:52:13.961Z] [INFO ] -extensionmanager-pool-27127 70013556 101086 200042 com.vmware.vise.vim.commons.vcservice.impl.VcServiceImpl logged in VC with id 3000001
[2019-08-18T14:52:13.961Z] [INFO ] -extensionmanager-pool-27127 70013556 101086 200042 com.vmware.vise.vim.commons.vcservice.impl.VcServiceImpl Successfully logged into VC https://***.***.net:443/sdk for session: 101086
[2019-08-18T14:52:14.001Z] [INFO ] m-catalog-manager-pool-27131 70013563 101086 200042 com.vmware.vise.vim.lookup.LsCatalogManager executeDownload: ResourceBundle https://***.***.net:443/catalog/com.symantec.netbackup.plugin_catalog.zip download succeeded with Status Code: 200
[2019-08-18T14:52:14.001Z] [INFO ] m-catalog-manager-pool-27131 70013563 101086 200042 com.vmware.vise.vim.lookup.LsCatalogManager downloadResourceBundle: Took (ms) for the resource bundle /etc/vmware/vsphere-ui/cmCatalog/com.vmware.cis.com.symantec.netbackup.plugin.zip,https://***.***.net:443/catalog/com.symantec.netbackup.plugin_catalog.zip: 59
[2019-08-18T14:52:14.001Z] [INFO ] m-catalog-manager-pool-27131 70013563 101086 200042 com.vmware.vise.vim.lookup.LsCatalogManager The HttpClient is no longer used. Will Close it.
[2019-08-18T14:52:14.003Z] [INFO ] m-catalog-manager-pool-27132 70013564 101086 200042 com.vmware.vise.vim.lookup.LsCatalogManager Time waiting for csp info (ms) for /etc/vmware/vsphere-ui/cmCatalog/com.vmware.cis.com.symantec.netbackup.plugin.zip:US: 62
[2019-08-18T14:52:14.004Z] [INFO ] m-catalog-manager-pool-27132 70013564 101086 200042 com.vmware.vise.vim.lookup.LocalizedMessageDictionary Loaded Resource bundle cis.vcextension.com_symantec_netbackup_plugin.ResourceBundle
[2019-08-18T14:52:14.005Z] [INFO ] m-catalog-manager-pool-27132 70013564 101086 200042 com.vmware.vise.vim.lookup.LocalizedMessageDictionary Loaded 10 elements from bundle: /etc/vmware/vsphere-ui/cmCatalog/com.vmware.cis.com.symantec.netbackup.plugin.zip/cis.vcextension.com_symantec_netbackup_plugin.ResourceBundle:US
[2019-08-18T14:52:14.005Z] [INFO ] m-catalog-manager-pool-27132 70013564 101086 200042 com.vmware.vise.vim.lookup.LsCatalogManager Time to load properties (ms)/etc/vmware/vsphere-ui/cmCatalog/com.vmware.cis.com.symantec.netbackup.plugin.zip:US: 1
[2019-08-18T14:52:14.017Z] [INFO ] taskExecutor-1 70013556 101086 200042 c.vmware.license.client.management.adapter.LicenseInventoryCache Retrieved 3 licenses.
[2019-08-18T14:52:14.022Z] [INFO ] -extensionmanager-pool-27127 70013556 101086 200042 com.vmware.vise.vim.extension.util.VcExtensionUtil No proxy server configured.
[2019-08-18T14:52:14.023Z] [INFO ] -extensionmanager-pool-27127 70013556 101086 200042 com.vmware.vise.vim.extension.VcExtensionManager Downloading plugin package from https://***.***.net:8443/nbwebservice/plugins/netbackup-vwc-plugin.zip (no proxy defined)
[2019-08-18T14:52:14.053Z] [WARN ] ce-extension-mngr-pool-27128 70013556 101086 200042 com.vmware.vise.extensionfw.impl.PackageManifestParser Plugin id mismatch between the registered extension key (com.vmware.vcIntegrity.vcIntegrity)
and the id specified in plugin-package.xml (com.vmware.vumclient). The registration id will be used but you should keep them in sync.
[2019-08-18T14:52:14.053Z] [WARN ] ce-extension-mngr-pool-27128 70013556 101086 200042 com.vmware.vise.extensionfw.impl.PackageManifestParser Plugin version mismatch for com.vmware.vcIntegrity.vcIntegrity between the plugin registration info (6.7.0.41703)
and the version specified in plugin-package.xml (6.7.0). The registration version will be used but you should keep them in sync.
[2019-08-18T14:52:14.619Z] [INFO ] -extensionmanager-pool-27127 70013556 101086 200042 com.vmware.vise.vim.extension.VcExtensionManager Done downloading plugin package from https://***.***.net:8443/nbwebservice/plugins/netbackup-vwc-plugin.zip
[2019-08-18T14:52:14.620Z] [WARN ] -extensionmanager-pool-27127 70013556 101086 200042 com.vmware.vise.vim.extension.VcExtensionManager Detected an invalid signature for plugin: com.symantec.netbackup.plugin:8.2 - com.vmware.vise.extensionfw.signing.PluginSignatureException: No META-INF/MANIFEST.MF entry found in the plugin zip file.
[2019-08-18T14:52:14.628Z] [INFO ] ce-extension-mngr-pool-27128 70013556 101086 200042 com.vmware.vise.vim.extension.PluginStatusTaskManager DEPLOYMENT_FAILED: Error deploying plugin package com.vmware.vcIntegrity.vcIntegrity:6.7.0.41703. Reason: Incompatible. This is a vSphere Web Client (Flash) only plugin indicated by the missing type="html" plugin manifest attribute.
[2019-08-18T14:52:14.636Z] [INFO ] plugin-validation1 com.vmware.vise.extensionfw.impl.OsgiUsageValidationService Started validation of OSGi bad practices.
[2019-08-18T14:52:14.636Z] [INFO ] plugin-validation1 com.vmware.vise.extensionfw.impl.OsgiUsageValidationService Finished validation of OSGi bad practices.
[2019-08-18T14:52:14.636Z] [INFO ] ce-extension-mngr-pool-27130 70013556 101086 200042 com.vmware.vise.vim.extension.PluginStatusTaskManager DEPLOYING: Deploying plugin package com.vmware.fallback.mixed:6.5.0 ...
[2019-08-18T14:52:14.651Z] [INFO ] ce-extension-mngr-pool-27130 70013556 101086 200042 com.vmware.vise.vim.extension.PluginStatusTaskManager DEPLOYMENT_FAILED: Error deploying plugin package com.vmware.fallback.mixed:6.5.0. Reason: Incompatible. This is a vSphere Web Client (Flash) only plugin indicated by the missing type="html" plugin manifest attribute.
[2019-08-18T14:52:14.651Z] [INFO ] plugin-validation1 com.vmware.vise.extensionfw.impl.OsgiUsageValidationService Started validation of OSGi bad practices.
[2019-08-18T14:52:14.652Z] [INFO ] plugin-validation1 com.vmware.vise.extensionfw.impl.OsgiUsageValidationService Finished validation of OSGi bad practices.
[2019-08-18T14:52:14.773Z] [INFO ] -extensionmanager-pool-27127 70013556 101086 200042 com.vmware.vise.vim.extension.VcExtensionManager Done expanding plugin package to /etc/vmware/vsphere-ui/vc-packages/vsphere-client-serenity/com.symantec.netbackup.plugin-8.2
[2019-08-18T14:52:14.773Z] [INFO ] -extensionmanager-pool-27127 70013556 101086 200042 com.vmware.vise.vim.extension.PluginStatusTaskManager DOWNLOADED: Downloaded plugin package com.symantec.netbackup.plugin:8.2 from https:/***.***.net:8443/nbwebservice/plugins/netbackup-vwc-plugin.zip successfully.
[2019-08-18T14:52:14.785Z] [INFO ] -extensionmanager-pool-27127 70013556 101086 200042 com.vmware.vise.vim.extension.PluginStatusTaskManager DEPLOYING: Deploying plugin package com.symantec.netbackup.plugin:8.2 ...
[2019-08-18T14:52:15.150Z] [WARN ] http-nio-5090-exec-6 70013571 101086 200042 com.vmware.vise.mvc.tree.TreeNodeStateManagerImpl Failed to load user preferences.
[2019-08-18T14:52:15.347Z] [INFO ] plugin-deploy11 com.vmware.vise.extensionfw.impl.PackagesDeployer Deploying plugin package 'com.symantec.netbackup.plugin:8.2'.
[2019-08-18T14:52:15.347Z] [INFO ] plugin-deploy11 com.vmware.vise.extensionfw.impl.DeploymentEventLoggerImpl Event=PACKAGE_DEPLOY_BEGIN; Params=com.symantec.netbackup.plugin, 8.2

 

 

 

Tags (1)
10 Replies

Re: VCenter HTML5 plugin problem

All I have to add is that  6.7 U2 is certainly supported by NBU 8.1.2 and 8.2 (as per the OS SCL ). 

I think that you should log a call with Veritas Support, as this seems to be related to the plugin and not general compatibility. 

PS: 
Best to add log files to a .txt file that you upload as an attachment. I found your post in the spam quarrantine - possibly because of the amount of text in the post..

Re: VCenter HTML5 plugin problem

Thanks Marianne

yes, my question is about Plugin and I guess it's not compatible with VCenter 6.7 U2

Re: VCenter HTML5 plugin problem

Re: VCenter HTML5 plugin problem

The old problem referred to in the prior vox threads is solved in NetBackup 8.2. The cause was two dots in the vSphere version, such as 6.7.1. The plug-in registration code was trying to interpret this as a decimal number.

I don't know what the current problem is. I defer to the experts on this.

Re: VCenter HTML5 plugin problem

now vcenter 6.7.3 released

I'm afraid of Veritas solve it for 6.7.2 and again doesn't work

I had bad experience with VCenter Plugins in VCenter Upgrade

I had SRM and upgrading is failed, deregistering and uninstalling plugin not solved the problem

then installed new VCenter!!!

Highlighted

Re: VCenter HTML5 plugin problem

I have the same problem for NetBackup plug-in 8.2 and version 6.7.0U2. In 6.7.0U1, 6.7.0U1a, and 6.7.0U1b, this works correctly but not after upgrading to 6.7.0U2, although it is on the list of supported.
Tags (2)

Re: VCenter HTML5 plugin problem

We have an engineering escalation that seems to be on the same issue. We can't reproduce it yet in house. Your evidence may help. Kindly refer your Veritas Support engineer to Service Request 3984013.

Re: VCenter HTML5 plugin problem

You have a solution because my support engineer didn't respond at all.
Unfortunately I have already vcsa 6.7.0 U3, but it did not work on version 6.7.0 U2 nor on version 6.7.0 U2c. Last time it worked correctly on version 6.7.0U1b.
NetBackup is version 8.2

Tags (1)

Re: VCenter HTML5 plugin problem

The Service Request I mentioned is still open. Our engineer still has not been able to reproduce the problem. He has pointed out that the procedure for replacing the plugin includes manual removal of some files before regiestering the new plug-in.

See https://www.veritas.com/content/support/en_US/doc/95632443-127304944-0/v97544734-127304944as. It's for the Flex appliance, but the procedure is more broadly applicable.

1) /usr/openv/netbackup/bin/goodies/vwcp_manage -u <username> -p <passwordfile> -v <vcenter> --unregister
2) ssh -l root <vcenter>
*3) find / | grep -i netbackup
*4) remove files found in step 3
5) service-control --stop vsphere-ui
6) service-control --start vsphere-ui
7) /usr/openv/netbackup/bin/goodies/vwcp_manage -u <username> -p <passwordfile> -v <vcenter> --register
8) service-control --stop vsphere-ui
9) service-control --start vsphere-ui

* The Service Request recommends that you also check for and remove "NBUMonitor" files:

find / | grep -i NBUMonitor

Re: VCenter HTML5 plugin problem

Link See is correct in this form:
without the two letters "as" at the end.
I have done everything written there 58 times without it working properly.
Don't take the number 58 times literally, I mean very many times
It works right up to U1b since U2 no longer.
Tags (1)