cancel
Showing results for 
Search instead for 
Did you mean: 

Vault Job Problem

Cappino
Level 4

 

Hello!
We have a problem with the vault, because the job ends almost immediately and did not make the vault.
We have both master and media on Linux Red Hat and our version of NetBackup is 7.5.0.6.
Below you will find the job log when it is started:

 

10-giu-2015 15.39.57 - Info nbjm (pid=2449) starting backup job (jobid=331041) for client master-srvrm-01.cogetech.it, policy Vault_Cogetech, schedule Full_DB_Vault
10-giu-2015 15.39.57 - vault waiting for session ID lock
10-giu-2015 15.39.57 - Info nbjm (pid=2449) requesting NO_STORAGE_UNIT resources from RB for backup job (jobid=331041, request id:{2F0C16EC-0F76-11E5-B793-E0B73237A177})
10-giu-2015 15.39.57 - requesting resource master-srvrm-01.cogetech.it.NBVAULT.MAXJOBS
10-giu-2015 15.39.57 - requesting resource master-srvrm-01.cogetech.it.NBU_POLICY.MAXJOBS.Vault_Cogetech
10-giu-2015 15.39.57 - granted resource  master-srvrm-01.cogetech.it.NBVAULT.MAXJOBS
10-giu-2015 15.39.57 - granted resource  master-srvrm-01.cogetech.it.NBU_POLICY.MAXJOBS.Vault_Cogetech
10-giu-2015 15.39.57 - estimated 0 kbytes needed
10-giu-2015 15.39.57 - begin Parent Job
10-giu-2015 15.39.57 - begin Vault: Start Notify Script
10-giu-2015 15.39.57 - Info RUNCMD (pid=12687) started
10-giu-2015 15.39.57 - Info RUNCMD (pid=12687) exiting with status: 0
Operation Status: 0
10-giu-2015 15.39.57 - end Vault: Start Notify Script; elapsed time 0:00:00
10-giu-2015 15.39.57 - begin Vault: Execute Script
10-giu-2015 15.39.57 - started process bpbrm (pid=12693)
10-giu-2015 15.40.23 - vault session ID lock acquired
10-giu-2015 15.40.23 - vault session ID lock released
10-giu-2015 15.40.24 - vault waiting for duplication lock
10-giu-2015 15.40.24 - vault duplication lock acquired
10-giu-2015 15.40.25 - begin Duplicating Images
10-giu-2015 15.40.25 - end Duplicating Images; elapsed time 0:00:00
10-giu-2015 15.40.25 - vault duplication lock released
10-giu-2015 15.40.25 - vault waiting for assign slot lock
10-giu-2015 15.40.25 - vault assign slot lock acquired
10-giu-2015 15.40.25 - vault assign slot lock released
10-giu-2015 15.40.25 - Catalog Backup skipped
10-giu-2015 15.40.25 - vault waiting for assign slot lock
10-giu-2015 15.40.26 - vault assign slot lock acquired
10-giu-2015 15.40.26 - vault assign slot lock released
10-giu-2015 15.40.26 - Eject deferred
10-giu-2015 15.40.26 - Reports deferred
10-giu-2015 15.40.26 - vault global lock released
10-giu-2015 15.40.22 - requesting resource master-srvrm-01.cogetech.it.VAULT_CREATE_SESSION_ID.LOCK_TLD(0)_Vault_Cogetech
10-giu-2015 15.40.23 - granted resource  master-srvrm-01.cogetech.it.VAULT_CREATE_SESSION_ID.LOCK_TLD(0)_Vault_Cogetech
10-giu-2015 15.40.24 - requesting resource master-srvrm-01.cogetech.it.VAULT_DUPLICATION.LOCK_TLD(0)_Vault_Cogetech
10-giu-2015 15.40.24 - granted resource  master-srvrm-01.cogetech.it.VAULT_DUPLICATION.LOCK_TLD(0)_Vault_Cogetech
10-giu-2015 15.40.25 - requesting resource master-srvrm-01.cogetech.it.VAULT_ASSIGN_SLOT.LOCK_TLD(0)_Vault_Cogetech
10-giu-2015 15.40.25 - granted resource  master-srvrm-01.cogetech.it.VAULT_ASSIGN_SLOT.LOCK_TLD(0)_Vault_Cogetech
10-giu-2015 15.40.25 - requesting resource master-srvrm-01.cogetech.it.VAULT_ASSIGN_SLOT.LOCK_TLD(0)_Vault_Cogetech
10-giu-2015 15.40.26 - granted resource  master-srvrm-01.cogetech.it.VAULT_ASSIGN_SLOT.LOCK_TLD(0)_Vault_Cogetech
10-giu-2015 15.40.26 - end writing
Operation Status: 0
10-giu-2015 15.40.26 - end Vault: Execute Script; elapsed time 0:00:29
10-giu-2015 15.40.26 - begin Vault: Validate Image
Operation Status: 0
10-giu-2015 15.40.26 - end Vault: Validate Image; elapsed time 0:00:00
10-giu-2015 15.40.26 - begin Vault: End Notify Script
10-giu-2015 15.40.26 - Info RUNCMD (pid=12729) started
10-giu-2015 15.40.26 - Info RUNCMD (pid=12729) exiting with status: 0
Operation Status: 0
10-giu-2015 15.40.26 - end Vault: End Notify Script; elapsed time 0:00:00
Operation Status: 0
10-giu-2015 15.40.26 - end Parent Job; elapsed time 0:00:29
the requested operation was successfully completed  (0)

 

 

Note that this "problem" occurred now, after three months of vault.
I also tried to cancelalre and recreate both the policy that the profile of the vault.

 

Thanks for the support.

Daniele

 

1 ACCEPTED SOLUTION

Accepted Solutions

Cappino
Level 4

Hello everyone and thanks for the responses.
The problem was due to the deduplication vault that did not start properly.
Now I restored the situation, the deduplication are turning and will surely also the vault!

Thanks!

View solution in original post

4 REPLIES 4

GulzarShaikhAUS
Level 6
Partner Accredited Certified

Looks like your vault profile does not find any images to duplicate. 

Can you share following - 

1. zip following folder and upload .

install_path\NetBackup\vault\sessions\

2. Run following command

install_path\Netbackup\bin\vltrun <profile-name> -preview -verbose 

Once done send latest preview.list file from sessions folder mentioned ealier

Marianne
Moderator
Moderator
Partner    VIP    Accredited Certified
Carefully look at selection criteria in the 1st tab of Vault profile to ensure that everything you want duplicated is included in selection parameters.

watsons
Level 6

Is your vault doing eject and/or duplication? 

Check /usr/openv/netbackup/vault/sessions/<vaultname>/sid###/logs/detail.log

(where ### is the session ID)

That logs will tell you why it's rejecting some images (for duplication) or not picking up media (for eject). Then check it against your profile "select backup" filters.

Cappino
Level 4

Hello everyone and thanks for the responses.
The problem was due to the deduplication vault that did not start properly.
Now I restored the situation, the deduplication are turning and will surely also the vault!

Thanks!