Highlighted

Vault job failing with (306) vault duplication partially succeeded

Hi, Vault job is failing with error 306 . NBU 6.5.5

08/24/2011 01:00:00 - requesting resource master.com.NBVAULT.MAXJOBS
08/24/2011 01:00:00 - requesting resource master.com.NBU_POLICY.MAXJOBS.VAULT-Policy
08/24/2011 01:00:18 - granted resource  master.com.NBVAULT.MAXJOBS
08/24/2011 01:00:18 - granted resource  master.com.NBU_POLICY.MAXJOBS.VAULT-Policy
08/24/2011 01:00:30 - estimated 0 kbytes needed
08/24/2011 01:00:30 - begin Parent Job
08/24/2011 01:00:30 - begin Vault: Start Notify Script
08/24/2011 01:00:30 - started process RUNCMD (pid=7597)
Operation Status: 0
08/24/2011 01:00:30 - end Vault: Start Notify Script; elapsed time 0:00:00
08/24/2011 01:00:30 - begin Vault: Execute Script
08/24/2011 01:00:31 - started process bpbrm (pid=7635)
08/24/2011 01:00:32 - vault waiting for session ID lock
08/24/2011 01:00:34 - vault session ID lock acquired
08/24/2011 01:00:34 - vault session ID lock released
08/24/2011 01:00:32 - requesting resource master.com.VAULT_CREATE_SESSION_ID.LOCK_TLD(0)_policy
08/24/2011 01:00:33 - granted resource  master.com.VAULT_CREATE_SESSION_ID.LOCK_TLD(0)_policy
08/24/2011 01:01:14 - vault waiting for duplication lock
08/24/2011 01:01:16 - vault duplication lock acquired
08/24/2011 01:01:14 - requesting resource master.com.VAULT_DUPLICATION.LOCK_TLD(0)_policy
08/24/2011 01:01:14 - granted resource  master.com.VAULT_DUPLICATION.LOCK_TLD(0)_policy
08/24/2011 01:04:03 - begin Duplicating Images
08/24/2011 01:04:07 - vault duplication validation of 5 images failed: Disk Only rule
08/24/2011 01:04:07 - Starting duplication batch 1 of 2 for 6 images
08/24/2011 01:04:07 - Starting duplication batch 2 of 2 for 4 images
08/24/2011 06:40:48 - Duplication batch 1 of 2 completed. 5 of 6 images duplicated
08/24/2011 09:07:44 - Duplication batch 2 of 2 completed. 4 of 4 images duplicated
08/24/2011 09:07:52 - end Duplicating Images; elapsed time 8:03:49
08/24/2011 09:07:52 - vault duplication lock released
08/24/2011 09:07:53 - vault waiting for assign slot lock
08/24/2011 09:07:53 - requesting resource master.com.VAULT_ASSIGN_SLOT.LOCK_TLD(0)_policy
08/24/2011 09:08:51 - vault assign slot lock acquired
08/24/2011 09:08:50 - granted resource  master.com.VAULT_ASSIGN_SLOT.LOCK_TLD(0)_policy
08/24/2011 09:08:55 - vault assign slot lock released
08/24/2011 09:08:55 - Catalog Backup skipped
08/24/2011 09:08:55 - vault waiting for assign slot lock
08/24/2011 09:08:55 - requesting resource master.com.VAULT_ASSIGN_SLOT.LOCK_TLD(0)_policy
08/24/2011 09:09:49 - vault assign slot lock acquired
08/24/2011 09:09:51 - vault assign slot lock released
08/24/2011 09:09:49 - granted resource  master.com.VAULT_ASSIGN_SLOT.LOCK_TLD(0)_policy
08/24/2011 09:15:56 - begin Eject and Report
08/24/2011 09:15:56 - connecting
08/24/2011 09:15:56 - connected; connect time: 0:00:00
08/24/2011 09:15:58 - vault waiting for eject lock
08/24/2011 09:15:58 - requesting resource master.com.VAULT_EJECT.LOCK_0
08/24/2011 09:17:00 - vault eject lock acquired
08/24/2011 09:16:59 - granted resource  master.com.VAULT_EJECT.LOCK_0
08/24/2011 09:17:04 - Starting Eject of 8 media
08/24/2011 09:18:36 - Media Ejected from Robot.  Please empty MAP.
08/24/2011 09:18:56 - Eject complete with status 0. 8 of 8 media ejected
08/24/2011 09:18:59 - vault eject lock released
08/24/2011 09:43:49 - vault global lock released
08/24/2011 09:43:49 - end writing
Operation Status: 306
08/24/2011 09:43:49 - end Eject and Report; elapsed time 0:27:53
08/24/2011 09:43:49 - begin Vault: Validate Image
Operation Status: 0
08/24/2011 09:43:50 - end Vault: Validate Image; elapsed time 0:00:01
08/24/2011 09:43:50 - begin Vault: End Notify Script
08/24/2011 09:43:50 - started process RUNCMD (pid=24483)
Operation Status: 0
08/24/2011 09:43:50 - end Vault: End Notify Script; elapsed time 0:00:00
Operation Status: 306
08/24/2011 09:43:50 - end Vault: Execute Script; elapsed time 8:43:20
vault duplication partially succeeded (306)

1 Solution

Accepted Solutions
Accepted Solution!

I've managed to solve the

I've managed to solve the issue by simply restarting NBU on all media servers... I don't know what that did exactly, but I haven't had any errors for 4 days now, and not only did I solve the vaulting issue but I'm also seeing that no errors whatsoever (!) have popped up ever since... to me, considering the downrev of the client, that is worryingly astounding...

View solution in original post

6 Replies

moved to correct forum

moved to correct forum (NetBackup)

https://www.linkedin.com/in/alex-allen-turl-07370146

Same issue here

I'm having the same issue, but my setup is way downrev than lype's... NBU 5.0 (un-patched!) running on solaris 5.9:

 1126140          Vault   Done    306                                    vault-daily-eject                               daily-eject        backup34_1      backup34_1 09/02/11 11:39:29 000:03:14 09/02/11
 11:42:43         
 

 bperror -jobid 1126140
1314956369 1 4 4 backup34_1 1126140 1126140 0 backup34_1 bpsched added backup job (jobid=1126140) for client backup34_1, policy vault-daily-eject, schedule daily-eject part 0 to NetBackup scheduler work queue
1314956369 1 4 4 backup34_1 1126140 1126140 0 backup34_1 bpsched started backup job for client backup34_1, policy vault-daily-eject, schedule daily-eject on storage unit N/A(Vault)
1314956372 1 4 4 backup34_1 1126140 1126140 0 backup34_1 bpsched client backup34_1 handling path /opt/openv/netbackup/bin/vlteject -eject -report -vault Schufa_VAULT
1314956568 1 4 16 backup34_1 1126140 1126140 0 backup34_1 bpsched suspending further backup attempts for client backup34_1, policy vault-daily-eject, schedule daily-eject because it has exceeded the configured number of tries
1314956568 1 68 4 backup34_1 1126140 1126140 0 backup34_1 bpsched CLIENT backup34_1  POLICY vault-daily-eject  SCHED daily-eject  EXIT STATUS 252 (the error status has been written to stderr)
1314956568 1 4 16 backup34_1 1126140 1126140 0 backup34_1 bpsched backup of client backup34_1 exited with status 252 (the error status has been written to stderr)

Can any1 explain where I should look for vaulting logs like the one above?

Accepted Solution!

I've managed to solve the

I've managed to solve the issue by simply restarting NBU on all media servers... I don't know what that did exactly, but I haven't had any errors for 4 days now, and not only did I solve the vaulting issue but I'm also seeing that no errors whatsoever (!) have popped up ever since... to me, considering the downrev of the client, that is worryingly astounding...

View solution in original post

Thanks Chronos, This worked

Thanks Chronos, This worked for me too..after restarting the NBU on the media server, am not getting any 306 errors now.

Re: Thanks Chronos, This worked

What if we have multiple media servers in environment? and many are self media servers ?

What logs will help to identify which media server is creating this skipping of some duplications?

 

 

Re: Thanks Chronos, This worked


@sai_1411 wrote:

What if we have multiple media servers in environment? and many are self media servers ?

What logs will help to identify which media server is creating this skipping of some duplications?


@sai_1411

The Vault session logs on the master server will be a good starting point.
The master server determines the images to be duplicated (depending on criteria specified in the Vault profile) and then sends the instruction to bpbrm on the media server.

I have locked this discussion as the 2011 post was solved.

If you have any further queries, please start a new discussion. 
Remember to share information about your environment, e.g. NBU version, OS, etc.