Highlighted

agent version upgrade

Shall we upgrade the ‘’NetBackup clients version which equals to the media server version’’, Example -  if the media server is 8.2 version, shall we upgrade the clients to 8.2 version.
3 Replies
Highlighted

Re: agent version upgrade

While it is NOT necessary to immediately upgrade your clients, since NetBackup supports down level clients, there are reasons such as software support or features that are only available once you update the clients.
I am at 8.1.2 on my master, all my media servers and 90% of my clients are upgraded to 8.1.2 - mostly for VM or OS features.
I have a couple of AIX systems still at 7.X due to "features" that actually mess them up - sometimes there are reasons to NOT upgrade!

I would recommend you check to see if there are features and benefits to guide you!

 

NetBackup 8.1.2 on Solaris 11, writing to DataDomain 9800 6.0.2.50
duplicating via SLP to LTO5 in SL8500 via ACSLS
Tags (2)
Highlighted

Re: agent version upgrade

One other thing - please define a measured schedule of upgrades - it is one thing to have to back out the update on the master, or the media servers, but removing and reinstalling all the clients is not a happy time. Make sure all is well, maybe even upgrade some of each before doing a blanket install, better safe than sorry.

You will only do this once, lol

NetBackup 8.1.2 on Solaris 11, writing to DataDomain 9800 6.0.2.50
duplicating via SLP to LTO5 in SL8500 via ACSLS
Tags (2)
Highlighted

Re: agent version upgrade

Not necessarily so but it's the best practice to keep their versions sync unless there's no compatibility issue with OS/app etc.

Besides, NBU 8.2 has VxUpdate feature, allowing you to perform the client and media server upgrades through JAVA UI. It's policy based and you can pick which clients to be upgraded.