cancel
Showing results for 
Search instead for 
Did you mean: 

app_cluster is not able to detect the Switch of cluster VIP after its failover

sai_1411
Level 3

**** Moved to new post from   https://vox.veritas.com/t5/NetBackup/App-cluster-does-not-follow-active-cluster-node/m-p/688258

HI Marrinne,

app_cluster is not able to detect the Switch of cluster VIP after its failover.

Everytime after performing these actions NBU database is updated about switch of VIP

Restarting NBU on both the cluster physical nodes.

Changing state of Disk Pool to UP.

Clearing Cache

 

this issue being for days not just for one hour. EMM DB is not updated at all.

 

Any suggestions on it ?

3 REPLIES 3

Marianne
Moderator
Moderator
Partner    VIP    Accredited Certified

@sai_1411

Always good to start a new discussion for your specific situation and share all relevant info such as OS, NBU version, type of storage used, etc.

The user in the 2014 post managed to solve the issue himself.
If the steps listed in the Solution post are not working for you, then best to log a Support Call with Veritas.

I seem to remember that app_cluster was not supported for Advanced disk or MSDP, but I have not read recent NBU documentation (NBU in Highly Available Environments Admin Guide) to see if the situation has changed. 

Marianne
Moderator
Moderator
Partner    VIP    Accredited Certified

@sai_1411

I have just had a look at the NBU 7.7 NetBackup in Highly Available Environments Administrator's Guide    
(For some reason the app_cluster steps were removed from 8.x manuals)

Adding disk storage units topic on page 26 says absolutely nothing about Advanced Disk or MSDP. 
There is no mention of the Storage Server configuration (using local nodenames and/or virtual hostname), so, my gutfeel is that these steps are meant for Basic Disk. 

There were a couple of discussions a number of years ago about app_cluster and Advanced disk with no solution and very poor response from Veritas/Symantec Support at the time, e.g:

https://vox.veritas.com/t5/NetBackup/SQL-cluster-backup-error-no-storage-units-available-for-use-213...

https://vox.veritas.com/t5/NetBackup/Quesiton-regarding-restoring-from-a-cluster/m-p/614221

https://vox.veritas.com/t5/NetBackup/Backup-images-on-disk-that-aren-t-in-catalogue/td-p/622331

https://vox.veritas.com/t5/NetBackup/Disk-Full-129-but-other-disks-in-storage-group-are-empty/m-p/68...

https://vox.veritas.com/t5/NetBackup/SQL-cluster-backup-error-no-storage-units-available-for-use-213...

So, if you have Advanced Disk or MSDP in your app_cluster, my recommendation is to log a Support call. 

Mike_Gavrilov
Moderator
Moderator
Partner    VIP    Accredited Certified

Have you tried to disable NBU cache on master server?