cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted

bptestbpcd works with hostname by not ip in NBU 8.1

Hi Everyone,

 I am seeing a strange behaviour here in NBU 8.1.

When i run bptestbpcd with hostname it works fine, However if fails when I try it with ip. see snap shot, 

Also i check certificate on client which is trusted and fine.

 

Tags (2)
8 Replies
Highlighted

Re: bptestbpcd works with hostname by not ip in NBU 8.1

@Sid1987

I tried the same thing in 8.1.2 and it worked with ip address. So it would be an issue with 8.1.

This issue is caused because NetBackup is trying to find a certificate or assocation with a known host in certificate database (i am using this term loosly) for ip address. It could not find one hence it failed.

Simple solution is to add host mappings for ip address to the client host name. NetBackup console -> Security management -> Host management -> Double click your client on right hand side -> Click "Add" on "Add or remove host mappings" window -> add ip adress and save it. 

Now if you try the connection with ip address it will work. 

Highlighted

Re: bptestbpcd works with hostname by not ip in NBU 8.1

Highlighted

Re: bptestbpcd works with hostname by not ip in NBU 8.1

@Marianne It looks like @Sid1987 is looking for solution from last 6 months Smiley Very Happy

@Sid1987 Try the step that I have mentioned and let us know if it worked.

Highlighted

Re: bptestbpcd works with hostname by not ip in NBU 8.1

Sorry marriane for the duplicate post, will mark answer for both once i have solution.

@Anshu_Pathak It didn't resolve the issue, I have added ip address and now under Host Management, Host shows Mapped hostname, ip addresses. However bptestbpcd with ip fails.

Highlighted

Re: bptestbpcd works with hostname by not ip in NBU 8.1

Any further suggestion or should i open a case for this?

Highlighted

Re: bptestbpcd works with hostname by not ip in NBU 8.1

You can upgrade....

See @Anshu_Pathak 's post:

I tried the same thing in 8.1.2 and it worked with ip address. So it would be an issue with 8.1.

Your other option is to view this as a 'none issue'. 
As per your other post - backups are working. Nothing is broken. 

Highlighted

Re: bptestbpcd works with hostname by not ip in NBU 8.1

I'll agree with marianne with this, it's almost just cosmetic.

Yes, it's not perfect, clearly something got messed up at 8.1, if I had to add a guess I'd suggest it was related to secure comms code changes and it wasn't spotted but it's not really a show stopper.  Yes, it's nice if it works, but I could also argue that that a machine you run it on, being a NBU machine of some type, has to be able to correctly resolve host names anyway - so there should be no need to use IP addresses (although if the ip works and the hostname doesn't it is a neat way of spotting a resolution issue).

Highlighted

Re: bptestbpcd works with hostname by not ip in NBU 8.1

@Sid1987 @Marianne @mph999 

I did some tests on 8.1 and things worked for me. In my investigation I found out what happens when we run bptestbpcd for ipaddress.

#1 NetBackup does the reverse lookup and if it is successful, it get the hostname.

#2 Now in-order to connect we need to use certificates, there is no certificate issued for ip address hence it will not work. As we have seen in step 1, after successful reverse lookup NetBackup knows the host name and its corresponding certificate which can be used. 

#3 NetBackup cannot directly use the certificate of other entity (host name) without creating an association of new entity (IP address) with old one. This is called host mappings (Security management -> Host Management -> hostname -> Add or remove host mappings). By default NetBackup has the POWER to create this mappings, so most of the customers will never notice any issues with bptestbpcd with host name or IP address as mappings will atumatically get added. This power is granted by the check box: Security management -> Global security settings -> Automatically map NetBackup host ID to host names.

There could be two reasons why you are facing this issue.

#1 "Automatically map NetBackup host ID to host names." setting is not enabled/checked.

#2 Reverse name resolution issue. 

Also check Security management -> Host Management -> Mappings for approval

This will show you any pending mapping requests and you should see ip address to hostname mappings request. 

I hope this works for you and saves you from opening an support case.