cancel
Showing results for 
Search instead for 
Did you mean: 

found no images or media matching the selection criteria  (190)

bal2
Level 3

Hi Friends, 

Could really use your help here.

I am trying to duplicate images on datadomain to tape. Using GUI, I have slected imgaes in catalogue, right clicked and duplicate. To  my surprise I get error : 

found no images or media matching the selection criteria  (190)

 

7 REPLIES 7

Marianne
Level 6
Partner    VIP    Accredited Certified

@bal2 

Are the DD images under SLP control ?

Please show us image info for one of the select images:

bpimagelist -backupid <image-id> -L

@Marianne 

Thank you for helping. Applogies for late reply, we are in different time zones. 

bpimagelist -backupid <image-id> -L , please advise where I can locate imageid. In GUI catalogue I could see backup id. 

When I ran this command without image id following output : 

D:\Program Files\Veritas\NetBackup\bin\admincmd>bpimagelist -backupid AS001ADCV0
1_1612094402
IMAGE AS001ADCV01 0 0 13 AS001ADCV01_1612094402 AS001ADCV01_GRT_SystemState_Back
up 13 *NULL* root Monthly_FULL 0 8 1612094402 3216 1643630402 0 0 106876018 1292
42 1 1 0 AS001ADCV01_GRT_SystemState_Backup_1612094402_FULL.f *NULL* *NULL* 0 1
0 0 0 *NULL* 0 0 0 0 0 0 0 *NULL* 0 0 0 *NULL* 1001 0 0 17709567 0 0 *NULL* *NUL
L* 0 0 0 0 *NULL* *NULL* 0 1 0 0
HISTO 0 0 0 0 0 0 0 0 0 0
FRAG 1 1 106876018 0 0 0 0 @aaaag XXX.XXXX.net 262144 0 0 -1 0 1;D
ataDomain;DFC-FO-DD-255;DFC-FO-DD-255_Pool;SUPPORT_LSU;0 1643630402 0 65544 0 0
0 6 0 1612097618 1 1 *NULL* *NULL* 0 0

Also I am not sure if its related, All Duplication jobs are stuck in Queued state, some failed with error 190 , rest all in Queued state. Except one job which completed partially. Please note Duplication is from Data Domain to Tapes (LTO7) (Netbackup 8.1.2)

Appreciate your help as always. 

* I have cancelled all jobs and restarted from gui by right clicking on selected images under catalogue. Same issue

* Recycled  netbackup services / media manager device deamon. 

* Daily catalogue backup to tapes is successful , this rules out any issues with tape library / drive. 

* Duplication is manual through GUI , no SLP

**Details for queued jobs : 

Feb 3, 2021 11:37:10 AM - begin Duplicate
Feb 3, 2021 11:37:11 AM - requesting resource  New_LTo7
Feb 3, 2021 11:37:11 AM - requesting resource  @aaaag
Feb 3, 2021 11:37:11 AM - reserving resource @aaaag
Feb 3, 2021 11:37:14 AM - awaiting resource New_LTo7. No drives are available.
Feb 3, 2021 5:34:05 PM - resource @aaaag reserved
Feb 3, 2021 5:34:05 PM - granted resource  E00067
Feb 3, 2021 5:34:05 PM - granted resource  Drive001
Feb 3, 2021 5:34:05 PM - granted resource  New_LTo7
Feb 3, 2021 5:34:05 PM - granted resource  MediaID=@aaaag;DiskVolume=SUPPORT_LSU;DiskPool=DFC-FO-DD-255_Pool;Path=SUPPORT_LSU;StorageServer=DFC-FO-DD-255;MediaServer=XXhiddenXXX

 

Marianne
Level 6
Partner    VIP    Accredited Certified

@bal2 Apologies for confusing you.
Backup ID and Image ID is the same thing.

You forgot the -L when you ran the bpimagelist command.
Can you run the command again and post the output, please?

About queued jobs - you need to check in Job Details to see why the job is queued.

How many tape drives do you have? On how many media servers?
Is the DD and tape drive(s) configured on the same media server (MediaServer=XXhiddenXX )?

The Job details that you posted shows that there was no tape drive available between 11:37am and 5:34pm.

The last we see is the granting of resources. What happened after that? Did the job progress beyond this point?

What is logged in the 'Results' tab of the GUI where you started the Duplication?

Can you show us Job Details as well as Results of a job that failed with 190?

Last question - Do you quit/close the Admin Console after duplication jobs are started?

We normally see useful duplication info in the admin log on the master server.
So, please double-check that you have all of these log folders in place:

On master: admin
On media server: bpbrm, bptm, bpdm

PS:
I am curious to know why you are doing manual duplications and not using SLPs ?

Thank you @Marianne  for helping : 

1. BPimagelist command output : 

D:\Program Files\Veritas\NetBackup\bin\admincmd>bpimagelist -backupid AS001ADCV
1_1612094402 -L

Client: AS001ADCV01
Backup ID: AS001ADCV01_1612094402
Policy: AS001ADCV01_GRT_SystemState_Backup
Policy Type: MS-Windows (13)
Proxy Client: (none specified)
Creator: root
Name1: (none specified)
Sched Label: Monthly_FULL
Schedule Type: FULL (0)
Retention Level: 1 year (8)
Backup Time: 1/31/2021 4:00:02 PM (1612094402)
Elapsed Time: 3216 second(s)
Expiration Time: 1/31/2022 4:00:02 PM (1643630402)
Maximum Expiration Time: 1/31/2022 4:00:02 PM (1643630402)
Compressed: no
Client Encrypted: no
Kilobytes: 106876018
Number of Files: 129242
Number of Copies: 1
Number of Fragments: 1
Histogram: 0 0 0 0 0 0 0 0 0 0
DB Compressed: no
Files File Name: AS001ADCV01_GRT_SystemState_Backup_1612094402_FULL.f
Previous Backup Files File Name: (none specified)
Parent Backup Image File Name: (none specified)
SW Version: (none specified)
Options: 0x0
MPX: 0
TIR Info: 0
TIR Expiration: 1/1/1970 4:00:00 AM (0)
Keyword: (none specified)
Ext Security Info: no
File Restore Raw: no
Image Dump Level: 0
File System Only: no
Object Descriptor: (none specified)
Previous BI Time: 1/1/1970 4:00:00 AM (0)
BI Full Time: 1/1/1970 4:00:00 AM (0)
Request Pid: 0
Backup Status: 0
Stream Number: 0
Backup Copy: Standard (0)
Files File size: 17709567
PFI type: 0
IMAGE_ATTRIBUTE: 0
Primary Copy: 1
Image Type: 0 (Regular)
Job ID: 1001
Num Resumes: 0
Resume Expiration: 1/1/1970 4:00:00 AM (0)
Data Classification: (none specified)
Data_Classification_ID: (none specified)
Storage Lifecycle Policy: (none specified)
Storage Lifecycle Policy Version: 0
STL_Completed: 0
Remote Expiration Time: 1/1/1970 4:00:00 AM (0)
Origin Master Server: (none specified)
Origin Master GUID: (none specified)
Snap Time: 1/1/1970 4:00:00 AM (0)
IR Enabled: no
Client Character Set: 1
Image On Hold: 0
Kilobytes Data Transferred: 0
Copy number: 1
Fragment: 1
Kilobytes: 106876018
Remainder: 0
Media Type: Disk (0)
Density: qscsi (0)
File Num: 0
ID: @aaaag
Host: as008medp01.XXXX.net
Block Size: 262144
Offset: 0
Media Date: 1/1/1970 4:00:00 AM (0)
Dev Written On: -1
Flags: 0x0
Media Descriptor: 1;DataDomain;DFC-FO-DD-255;DFC-FO-DD-255_Pool;SUPPORT
LSU;0
Expiration Time: 1/31/2022 4:00:02 PM (1643630402)
MPX: 0
retention_lvl: 1 year (8)
Try to Keep Time: 1/1/1970 4:00:00 AM (0)
Copy Creation Time: 1/31/2021 4:53:38 PM (1612097618)
Data Format: Tar
checkpoint: 0
resume num: 0
Key tag: *NULL*
STL tag: *NULL*
Copy on hold: 0

*******************************************************************************************************

2. Job details are same as share before. 

Feb 3, 2021 11:41:58 AM - begin Duplicate
Feb 3, 2021 11:41:59 AM - requesting resource  New_LTo7
Feb 3, 2021 11:41:59 AM - requesting resource  @aaaag
Feb 3, 2021 11:41:59 AM - reserving resource @aaaag
Feb 3, 2021 11:42:03 AM - awaiting resource New_LTo7. No drives are available.
Feb 3, 2021 5:36:37 PM - resource @aaaag reserved
Feb 3, 2021 5:36:37 PM - granted resource  E00067
Feb 3, 2021 5:36:37 PM - granted resource  Drive001
Feb 3, 2021 5:36:37 PM - granted resource  New_LTo7
Feb 3, 2021 5:36:37 PM - granted resource  MediaID=@aaaag;DiskVolume=SUPPORT_LSU;DiskPool=DFC-FO-DD-255_Pool;Path=SUPPORT_LSU;StorageServer=DFC-FO-DD-255;MediaServer=as008medp01.XXXX.net

 

Only these details appear in GUI , under detaied status. So jobs are stuck in queue since 2 feb. However daily catalogue backup is successful 

3) 1 Tape drive, 1 media server.  Yes DD and tape drive are configurd on  the same media server. 

4 ) The Job details that you posted shows that there was no tape drive available between 11:37am and 5:34pm.

Its running one job at a time, I beleive thats the reason it showed no tape drive available. 

4) The last we see is the granting of resources. What happened after that? Did the job progress beyond this point?

Nothing happens after granting resource. 

5 )What is logged in the 'Results' tab of the GUI where you started the Duplication?

 11:15:58 INF - Created bpduplicate process, pid: 33328
11:16:01 Duplicate started 02/07/2021 11:16:01
11:16:01 Activity monitor job id = 5684
11:16:02 INF - Skipping copy 2 of backup id AS034BKPV01_1612094432, is not required copy 1.

6)Can you show us Job Details as well as Results of a job that failed with 190?

I lost this info now, rerunning jobs now. 

7) Last question - Do you quit/close the Admin Console after duplication jobs are started?

No 

8) Admin logs were not created on master , I am reading media server logs to find something useful. 

I inherited this position , previous sysadmin diabled all SLP and advised me to use manual duplication. 

Any help is appreciated. 

Marianne
Level 6
Partner    VIP    Accredited Certified

@bal2 

There should be more duplication attempts in the Results tab.

The one that you showed started at 11:15.
The job in Activity monitor started at 11:41.  This is the one that I'm looking for.
I am hoping to see if there is more info about the hung job.

Please create the admin log folder.

The job seems to be stuck at the point where the resource broker is allocating resources.

If no duplications are actually running, it might be a good idea to cancel all hung and queued jobs and reset all resource allocations before trying again.
nbrbutil -resetAll

1 tape drive to perform multiple duplications does not seem enough. Bear in mind that 1 tape drive can only run 1 duplication job.
You can see that the job that you posted was waiting for almost 6 hours for a tape drive.

I have asked about closing the Admin console because I have experienced something similar when the the RDP session was closed while the duplication was running. The job simply went into a hung state. bptm stopped logging, then we noticed in Task Manager that the bptm process was no longer there.
This sitiation is different - it did not even get to bptm process.

About SLPs - do yourself a favour and read up about SLPs. See for yourself the advantages of using SLPs vs manual duplications.

StoneRam-Simon
Level 6
Partner    VIP    Accredited Certified

Check if you have specified a "copy" to duplicate from...

11:16:02 INF - Skipping copy 2 of backup id AS034BKPV01_1612094432, is not required copy 1.

This implys that the only copy that NetBackup found for that image was copy 2 and that could mean that copy 1 has already expired.  It is possible that you have selected the same images in multiple DUPLICATION jobs and that they are running in the background and completing.

This image id in the RESULTS is not the same as the one you provided the "bpimagelist" output for.

You stated that SLPs had been "disabled" if all that is done is the "second operations" have been deactivated, then the SLP is still being used, and it will be generating a backlog of activity.   This can then prevent "manual" activitie taking place as the SLP needs to be in a completed or not managed state to run.    The image "AS001ADCV01_1612094402" is not managed by SLP "STL_Completed: 0" so this one should be available for duplication.

I think you need some help with looking at what is running / queued to run, determine if you have the same duplication scheduled to run by multiple  jobs...  Make sure that you have sufficient resources and that the only available tape device isn't busy doing another backup or duplication.

Regards Simon

 

Genericus
Moderator
Moderator
   VIP   

I do this exact same thing.  Try this:

Go to the GUI and catalog, select the client AS001ADCV01 and select the dates for your backup, range just before and after. Jan 31 at 4:00?

check and primary only, then copy 1, copy 2 etc. you should be able to see what you have.

If this is still doing the SLP, you CANNOT manually duplicate it.

use "nbstlutil inactive -backupid AS034BKPV01_1612094432",

then "nbstlutil cancel -backupid AS034BKPV01_1612094432"

At this point you should be able to manually bpduplcate your image.

 

BAD NEWS - I have a data domain and have seen a "bug" in the past where sometimes a backup cannot be duplicated, you will always get a 190 error. Have not seen recently, what version of DDOS are you at?

 

NetBackup 10.2.0.1 on Flex 5360, duplicating via SLP to Access 3350, duplicating via SLP to LTO8 in SL8500 via ACSLS