cancel
Showing results for 
Search instead for 
Did you mean: 

how to upgarde netbackup client software for single client using update_clients sciprt

NBU_Adm
Level 3

Hi,

 

how to upgarde netbackup client software from 6.5 to 7.1  for single linux/ unix client using update_clients sciprt.

1 ACCEPTED SOLUTION

Accepted Solutions

Will_Restore
Level 6

You'd have to update Linux client binaries on the Master to newer version.  Sounds like only Solaris was previously updated.

 

View solution in original post

10 REPLIES 10

RamNagalla
Moderator
Moderator
Partner    VIP    Certified

you need to put the client name in a file and provide the client name as input to upgrade_client command 

like below 

cat /tmp/client_list

Solaris Solaris10 cleint

then run the command 

update_clients -ClientList /tmp/client_list 

refer below doc for more options and details 

https://support.symantec.com/en_US/article.TECH19407.html

Nicolai
Moderator
Moderator
Partner    VIP   

I run:

/usr/openv/netbackup/bin/admincmd/bpplclients -allunique -noheader | grep {client_to_upgrade} >> /tmp/nbu_clients

This will provide the ClientList in the required format, then run

update_clients -ClientList /tmp/nbu_clients

Done !

NBU_Adm
Level 3

Thanks for the information.

i am getting below erro while ugprading. Please help me to fix the issue.

error :

Will not update client client
        client is defined as a client type from an earlier release of NetBackup.

 

I have provided the correct hardware and os type in the client list file

Marianne
Level 6
Partner    VIP    Accredited Certified

Have a look at the client type in the policy and ClientList. Does that correspond with required client type as per NBU OS SCL?

If the client 'version' file contains an older client type, you can use ForceInstall to force the newer version. 

See my own experience:

update_clients failure 

RamNagalla
Moderator
Moderator
Partner    VIP    Certified

make sure the OS type that you provide is matching the output of uname -a

else please provide the output of uname -a command output

and also the entiers that you used in clientlist file

 

have a look at the below TechNote

https://support.symantec.com/en_US/article.TECH155924.html

Nicolai
Moderator
Moderator
Partner    VIP   

Or use the GUI:

GUI - Policies  - > Open Policy - > Clients Tab - Select client to be upgraded - right click - Change - Use drop down to select a current OS and Hardware type - then OK

Run update_clients script

 

NBU_Adm
Level 3

I have modified with correct hardware and OS type and ran the update_client, but still it showing the below error.

"Will not update client is defined as a client type from an earlier release of NetBackup"

 

i have checked the redhat2.6 version in master server, it is pointing to the old version.

 

cat /usr/openv/netbackup/client/Linux/RedHat2.6/version
NetBackup-RedHat2.6 6.5.6

 

My Master server version is : 7.1

OS : solaris

 

Will_Restore
Level 6

You'd have to update Linux client binaries on the Master to newer version.  Sounds like only Solaris was previously updated.

 

Marianne
Level 6
Partner    VIP    Accredited Certified
As per Will's post, you need to install the NBU 7.1 Linux Client binaries on the master. If you have not already done so, download the 3 Unix Client installation files from FileConnect, join them as per the instructions in the Readme file on FileConnect and extract using gtar. Client software installation on a master server is documented in NBU Installation Guide. (Links to manuals in Handy NBU Links in my signature )

Genericus
Moderator
Moderator
   VIP   

Also - verifiy your client will work with the new NB version, for example, you can no longer do this process with 32 bit clients.

You need to keep the install software for the last 32 bit version and run the install from there, you cannot ever upgrade netbackup to that client - until you go to 64 bit.

NetBackup 10.2.0.1 on Flex 5360, duplicating via SLP to Access 3350, duplicating via SLP to LTO8 in SL8500 via ACSLS