how to upgrade JAVA for Veritas NBU Admin Console 8.1.1 on my windows desktop

I use the Veritas NBU 8.1.1 admin console on my windows desktop to control the NBU environment which is on our Linux MASTER/MEDIA servers.  Im getting hit with some vulnerabilities from our company scans saying that the JAVA that is used for the Admin console 8.1.1 is out of date.  Anyway to update the JAVA that is installed with the Veritas Netbackup Windows Admin 8.1.1 console.??  

Another words they are telling me that :  C:\Program Files\Veritas\Java\jre\bin\java.exe is installed version 1.8.0_151 and I need to have at least 1.8.0_181. 

I currently have  java 8 update 211 installed on workstation.
 
 
Thanks in Advance!
BC
 
1 Reply
Highlighted

Re: how to upgrade JAVA for Veritas NBU Admin Console 8.1.1 on my windows desktop

use nbcomponentupdate to udpate java version

you can use the nbcomponentupdate utility to update the JRE to a supported version for the products shown:

  • NetBackup master server, media server, or client software

  • NetBackup Remote Administration Console

  • OpsCenter Server, Agent, or View Builder

The NetBackup installed version of the JRE is the supported major version for that NetBackup release. Use this utility to update to a minor version of the supported major JRE version. For example, if NetBackup 8.0 installed JRE 1.8.0.31, the supported major version is 1.8. Use this utility to update to JRE 1.8.0.92.

Veritas recommends that you update to another major JRE version only if the JRE vendor declares an end-of-life for the installed JRE version. If the JRE vendor declares an end-of-life for JRE 1.8, which is also the installed JRE version in your environment, update to JRE 1.9.

Close the product, such as NetBackup, before you attempt to update the JRE. If the product is active when you attempt the update, the utility exits with an error message that requests you to close the product.

Caution:

Do not stop the utility while the JRE update is in progress. This action can cause the product that uses the JRE, such as NetBackup, to become unstable.

If there are additional versions of the JRE installed on your system for other applications, the NetBackup JRE does not interfere with them. The NetBackup JRE does not provide integration with web browsers and does not allow Java Applets or Web Start to run. For that reason, the NetBackup JRE cannot be used in a browser-based attack that uses Java Applet or Web Start vulnerabilities.

More information about NetBackup JRE alerts is available.

http://www.veritas.com/docs/TECH50711

 

Referece links:- 

https://www.veritas.com/support/en_US/doc/27801100-130536338-0/v109286267-130536338

https://www.veritas.com/content/support/en_US/doc/15263389-132009154-0/v121626809-132009154