cancel
Showing results for 
Search instead for 
Did you mean: 

mailbox backup error

________o
Level 4

hi,

mailbox backup fail with error  invalid filelist specification(69)

i have veritas netbackup 7.5 under windows 2008 and i am already started netbackup client service with netbackup account with domain admin

13 REPLIES 13

Marianne
Level 6
Partner    VIP    Accredited Certified

You forgot to mention your Exchange Version?

Please tell us what is in Backup Selection?

The reason for my version question is because MAPI mailbox backups cannot be done for Exch 2010. You need GRT.

For earlier version, there is more to the config than just NBU Client service account.

Exch 2003: http://www.symantec.com/docs/TECH18705

Exch 2007: http://www.symantec.com/docs/TECH87770

________o
Level 4

 

Exchange ver 2003

Backup selection Microsoft exchange mailboxes streams

N.B This Policy was work fine but suddenly stopped with above error

Job Details

 

/7/2012 5:43:37 PM - Info nbjm(pid=3224) starting backup job (jobid=141328) for client bap-mbx1, policy Bap-MBX1-MailBoxes, schedule Differential-Inc-mailbox 
4/7/2012 5:43:37 PM - Info nbjm(pid=3224) requesting STANDARD_RESOURCE resources from RB for backup job (jobid=141328, request id:{A87C866A-907C-4C17-A531-502C7E6FFF26}) 
4/7/2012 5:43:37 PM - requesting resource bap-mbx1-hcart-robot-tld-0
4/7/2012 5:43:37 PM - requesting resource bap-backup.NBU_CLIENT.MAXJOBS.bap-mbx1
4/7/2012 5:43:37 PM - requesting resource bap-backup.NBU_POLICY.MAXJOBS.Bap-MBX1-MailBoxes
4/7/2012 5:43:37 PM - awaiting resource bap-mbx1-hcart-robot-tld-0 Reason: Media is in use, Media Server: bap-mbx1,
  Robot Number: 0, Robot Type: TLD, Media ID: N/A, Drive Name: N/A,
  Volume Pool: bap-mail-pool, Storage Unit: bap-mbx1-hcart-robot-tld-0, Drive Scan Host: N/A
 
4/7/2012 5:43:50 PM - granted resource bap-backup.NBU_CLIENT.MAXJOBS.bap-mbx1
4/7/2012 5:43:50 PM - granted resource bap-backup.NBU_POLICY.MAXJOBS.Bap-MBX1-MailBoxes
4/7/2012 5:43:50 PM - granted resource 0034L4
4/7/2012 5:43:50 PM - granted resource IBM.ULT3580-TD4.001
4/7/2012 5:43:50 PM - granted resource bap-mbx1-hcart-robot-tld-0
4/7/2012 5:43:50 PM - estimated 1607698 Kbytes needed
4/7/2012 5:43:50 PM - Info nbjm(pid=3224) started backup (backupid=bap-mbx1_1333813430) job for client bap-mbx1, policy Bap-MBX1-MailBoxes, schedule Differential-Inc-mailbox on storage unit bap-mbx1-hcart-robot-tld-0
4/7/2012 5:44:22 PM - Info bpbrm(pid=6472) bap-mbx1 is the host to backup data from    
4/7/2012 5:44:22 PM - Info bpbrm(pid=6472) telling media manager to start backup on client    
4/7/2012 5:44:22 PM - Info bptm(pid=6340) using 65536 data buffer size       
4/7/2012 5:44:22 PM - Info bptm(pid=6340) using 12 data buffers        
4/7/2012 5:44:26 PM - Info bpbrm(pid=7532) sending bpsched msg: CONNECTING TO CLIENT FOR bap-mbx1_1333813430    
4/7/2012 5:44:26 PM - Info bpbrm(pid=7532) start bpbkar32 on client        
4/7/2012 5:44:26 PM - connecting
4/7/2012 5:44:26 PM - connected; connect time: 00:00:00
4/7/2012 5:44:26 PM - begin writing
4/7/2012 5:44:30 PM - Info bpbkar32(pid=4552) Backup started          
4/7/2012 5:44:30 PM - Info bpbrm(pid=7532) Sending the file list to the client     
4/7/2012 5:44:32 PM - Warning bpbrm(pid=7532) from client bap-mbx1: WRN - unable to successfully enumerate folder: Microsoft Exchange Mailboxes:\
4/7/2012 5:44:32 PM - Error bpbrm(pid=7532) from client bap-mbx1: ERR - object not found for file system backup: Microsoft Exchange Mailboxes:\[i-l]*
4/7/2012 5:44:32 PM - Info bpbkar32(pid=4552) bpbkar waited 0 times for empty buffer, delayed 0 times.  
4/7/2012 5:44:32 PM - Error bpbrm(pid=7532) could not send server status message      
4/7/2012 5:44:36 PM - Info bpbrm(pid=6472) child done, status 69        
4/7/2012 5:44:36 PM - Info bpbrm(pid=6472) sending message to media manager: STOP BACKUP bap-mbx1_1333813430    
4/7/2012 5:44:42 PM - Info bpbrm(pid=6472) media manager for backup id bap-mbx1_1333813430 exited with status 150: termination requested by administrator
4/7/2012 5:44:42 PM - end writing; write time: 00:00:16
invalid filelist specification(69)

Marianne
Level 6
Partner    VIP    Accredited Certified

Double-check the maibox account as well Client Service logon account.

During NBU upgrade, we often see that the login account is reset to Local System.

Also check that the service account stil has the necessary Exchange permissions and that the password has not perhaps expired.

________o
Level 4

i checked maibox account and make sure that the Client Service logon with it.

and i check that the service account stil has the necessary Exchange permissions and that the password has not perhaps expired.

Kindlly assist me how i can check login account is reset to Local System

Marianne
Level 6
Partner    VIP    Accredited Certified

If you have checked NBU Client Service Account after 7.5 upgrade/install then nothing else needs to be done as far is that is concerned.

Logon to Exchange server with this account, open BAR and see if you can expand and browse mailboxes.

If you cannot, carefully go through http://www.symantec.com/docs/TECH18705 and re-check each step.

________o
Level 4

 

I am already did this steps before and I am checked it now and everything ok

But I still can't expand Microsoft exchange mailboxes under backup, archive and restore

N.B

i have another mail server in my network and I can't expand Microsoft exchange mailboxes under backup ,archive and restore but backup job for mailboxes running without any problem

Marianne
Level 6
Partner    VIP    Accredited Certified

The user that is used for Mailbox backups must be able to browse using BAR.

If you are logged in on Exchange Server as this user and you cannot browse using BAR, there is something wrong with Exchange permissions.

________o
Level 4

when i logon to exchange server and open system manager i can browse mailboxes but i can't show mailboxes when i open backup ,archive and restore and try expand Microsoft exchange mailboxes

Marianne
Level 6
Partner    VIP    Accredited Certified

You need to find out what happened to make it stop working.

Was this a new NBU 7.5 install or an upgrade from an older version? Did it ever work on 6.5?

Was anything changed on Exchange side? Or in AD?

To find out why NBU is not working, enable bpbkar log on Exchange server and retry backup.

Check bpbkar log for errors.

 

________o
Level 4

 

I am upgraded NBU from ver 7.0 to 7.5 and after upgrade mailboxes job was working without any problems

I doubt about any changes happened in AD or Exchange because I have another mail server have mailboxes and mailboxes backup still running till now without any problems (I think if any changes happened in AD or exchange will effect on another exchange server)

Kindly find attached file bpbkar log from exchange server but i can't understand anything from log file

Marianne
Level 6
Partner    VIP    Accredited Certified

Apologies for only getting back to you now.

There is for sure a problem with credentials:


12:41:40.072 PM: [6572.4560] <2> ov_log::V_GlobalLog: ERR - bedsExchangeMailboxInit() FS_AttachToDLE() DeviceName:'\\bap-mbx1\Microsoft Exchange MailBoxes' MailBox:'(null)' Failed! (0xE00002FE:Cannot log on to MAPI with the specified credentials. Review the resource credentials for the job, and then run the job again.

J_H_Is_gone
Level 6

I see in your output you are going for mailboxes that start with i through l

Microsoft Exchange Mailboxes:\[i-l]*
 

can you check your exchange and verify that you do HAVE mailboxes that start with i j k or l?

don't know how big your company is but could be some got removed and there are no longer any that match that criteria and maybe you need to add those letters into the same group that end with h.

falti_manullang
Level 5
Partner

69 on exchange is about the permision of exchange user.

 

Create a user on admin domain and delegate control full administrator rights.