media is not fully used and backup keeps using tape in scratch pool.

Hi,

I keep run out of tapes for backup.

Some backup continue to use tape from scratch pool even it has not fully consumed the tape.

Please advise, thanks.

 

 

Tags (2)
2 Solutions

Accepted Solutions
Accepted Solution!

Re: media is not fully used and backup keeps using tape in scratch pool.

Media sharing is good, as all media servers can use the same media.  The effect of not using it, is that you probably end up needing more tapes

You want to avoid 'multiple retentions per media' that over time with tie media up and you will use many times more media than you need.

View solution in original post

Accepted Solution!

Re: media is not fully used and backup keeps using tape in scratch pool.

Media sharing will help, but will certainly not resolve your problem 100%. 

With media sharing, other media servers will be able to append to a tape if all other criteria is a match: pool, robot rumber, retention.
Bear in mind that only one media server can use a piece of media at any given time.

You can read up about advantages of media sharing in Admin Guide I.
Please read up about 'unrestricted media sharing' and 'sharing groups' before you decide to enable media sharing. 
Make sure that you understand how to use 'Maximum Partially Full' setting in Volume Pools (also covered in Admin Guide I).

I still think that you have way too many pools and not enough scratch tapes. 

View solution in original post

10 Replies

Re: media is not fully used and backup keeps using tape in scratch pool.

Does the tape say its full or not? Just because it's not used "all" the space the tape is designed to have doesn't mean its not full. A tape might be rated to take 2TB but you'll only fit 1.5TB on it due to the compression of the data.

Re: media is not fully used and backup keeps using tape in scratch pool.

Hi RiaanBadenhorst, thanks for your reply. Here is the screenshot, F40135 F40135L4 Active HCART 11.12.2020 05:01:02 12.12.2017 05:01:02 TLD 0 F40120 F40120L4 Active HCART 18.08.2022 05:00:08 18.04.2018 05:01:02 TLD 0 F40094 F40094L4 Active HCART 16.04.2021 05:01:03 30.12.2016 05:00:06 TLD 0 F40082 F40082L4 Active HCART 08.01.2020 05:00:06 30.12.2016 05:00:08 TLD 0 F40069 F40069L4 Active HCART 07.03.2021 05:01:03 24.01.2018 05:01:03 TLD 0 F40036 F40036L4 Full HCART 11.12.2020 05:01:02 13.06.2016 05:00:01 TLD 0 F40030 F40030L4 Active HCART 07.01.2020 05:00:12 07.01.2017 05:00:12 TLD 0 F40018 F40018L4 Active HCART 16.02.2020 05:00:04 29.12.2016 05:00:03 TLD 0
Highlighted

Re: media is not fully used and backup keeps using tape in scratch pool.

@kkhoo 

What output/screenshot is this?

I have tried to make sense of the output by inserting some <CR>, but there are no headings:

F40135 F40135L4 Active HCART 11.12.2020 05:01:02 12.12.2017 05:01:02 TLD 0
F40120 F40120L4 Active HCART 18.08.2022 05:00:08 18.04.2018 05:01:02 TLD 0
F40094 F40094L4 Active HCART 16.04.2021 05:01:03 30.12.2016 05:00:06 TLD 0
F40082 F40082L4 Active HCART 08.01.2020 05:00:06 30.12.2016 05:00:08 TLD 0
F40069 F40069L4 Active HCART 07.03.2021 05:01:03 24.01.2018 05:01:03 TLD 0
F40036 F40036L4 Full HCART 11.12.2020 05:01:02 13.06.2016 05:00:01 TLD 0
F40030 F40030L4 Active HCART 07.01.2020 05:00:12 07.01.2017 05:00:12 TLD 0
F40018 F40018L4 Active HCART 16.02.2020 05:00:04 29.12.2016 05:00:03 TLD 0

Can you perhaps run 'available_media' and save to a .txt file and upload it? 
e.g. /usr/openv/netbackup/bin/goodies/available_media >/tmp/media.txt

Re: media is not fully used and backup keeps using tape in scratch pool.

Hi @Marianne ,

Thanks for your reply.

I attached in txt file.

Btw, media sharing is disabled.

We have total of 8 media servers and 6 retentions.

 

Thanks in advance.

 

Re: media is not fully used and backup keeps using tape in scratch pool.

@kkhoo 

I can imagine that media management must be a nightmare for you - not only do you have 8 media servers and 6 retentions, you also have about 16 data pools! 
And 2 robots. 

Looking at available_media output, I don't see any obvious issues.
When a media server needs media in a pool in a particular robot, it should select an 'Active' tape with matching retention to append to until Full. 
The large amount of Full tapes makes me believe that this is happening.

The first problem I see is an excessive amount of pools - the recommendation is to limit amount of pools.

The other problem I see is insufficient amount of scratch tapes - there is only 1 tape in robot 1, nothing in robot 0, 3 not in any robot (NONE).

You simply need more tapes for the amount of media servers, retentions, pools and robots. 

 

Re: media is not fully used and backup keeps using tape in scratch pool.

@Marianne , thanks for quick reply.

What i think is that the problem wil somehow get resolved if i enable media sharing. Is this correct?

Coz right now, even media is on the same pool but owned by different media server, the media will not be shared for other usage.

Please advise?

What is the importance of media sharing?

Accepted Solution!

Re: media is not fully used and backup keeps using tape in scratch pool.

Media sharing is good, as all media servers can use the same media.  The effect of not using it, is that you probably end up needing more tapes

You want to avoid 'multiple retentions per media' that over time with tie media up and you will use many times more media than you need.

View solution in original post

Accepted Solution!

Re: media is not fully used and backup keeps using tape in scratch pool.

Media sharing will help, but will certainly not resolve your problem 100%. 

With media sharing, other media servers will be able to append to a tape if all other criteria is a match: pool, robot rumber, retention.
Bear in mind that only one media server can use a piece of media at any given time.

You can read up about advantages of media sharing in Admin Guide I.
Please read up about 'unrestricted media sharing' and 'sharing groups' before you decide to enable media sharing. 
Make sure that you understand how to use 'Maximum Partially Full' setting in Volume Pools (also covered in Admin Guide I).

I still think that you have way too many pools and not enough scratch tapes. 

View solution in original post

Re: media is not fully used and backup keeps using tape in scratch pool.

thanks @mph999 . I will take note on this.

Re: media is not fully used and backup keeps using tape in scratch pool.

@Marianne . noted and thanks. Will definitely read the Admin Guide.