Highlighted

start multiple restore jobs from same policy

I have to start multiple restore jobs from same policy. This will include multiple folders which are in different medias. The data which I am trying to restore, was not backup using multiplexing Can any one guide me to accomplish this. Netbackup Version = 8.1.2 Media used = LTO6 Dell TL2000 Let me know if you need any information.

Tags (2)
7 Replies

Re: start multiple restore jobs from same policy

Step 1 = select files and restore

step 2-n = select files and restore

 

Re: start multiple restore jobs from same policy

Riaan,

 

Did not get you, can you please eloborate for me?

Thanks for replying.

Re: start multiple restore jobs from same policy

@tateajit7887 

I notice that you have abandoned your 2-week-old post : https://vox.veritas.com/t5/NetBackup/start-multiple-restore-jobs-from-a-policy/m-p/873365

It took you 2 weeks to come back and say that it is not multiplexed backup.

This means that the only thing that is irrelevant in that post is 'multiplex restore delay '.

Can you tell us what have you tried thus far? 

Have you tried to open multiple windows and start multiple restores?

Or tried multiple bprestore commands?

Re: start multiple restore jobs from same policy

Do the restores. You're presenting a hypothetical problem that doesn't exist. You would have seen this if you tried to do the restores. The only time you'll face an issue is with multiplexing, or when you select different files in different restores that reside on the same tape thereby creating a contention (which by the way there is nothing you can do about).

So the answer is, just do the restores. And as Marianne said, you can do them via CLI if you don't want to click click click.

Re: start multiple restore jobs from same policy

There is one important backup running on the system now. So I will try once this backup is done.

Re: start multiple restore jobs from same policy

Hey,

I have tried restoring some small files by opening multiple windows, but the restores are not happening on both drives. Only first drive starts restore and other drive become idle.

The same is happening when I tried with bprestore command also. In the activity monitor, its only showing all the medias which will be needed to restore, its not goying beyond that point.

Dec 2, 2019 7:20:20 PM - media needed: 001876
Dec 2, 2019 7:20:20 PM - media needed: 001877
Dec 2, 2019 7:20:20 PM - media needed: 001878
Dec 2, 2019 7:20:20 PM - media needed: 001881
Dec 2, 2019 7:20:20 PM - media needed: 001882
Dec 2, 2019 7:20:20 PM - media needed: 001883
Dec 2, 2019 7:20:20 PM - media needed: 001884
Dec 2, 2019 7:20:20 PM - media needed: 001885

Something like this.....

Thanks,

AJju

Re: start multiple restore jobs from same policy

@tateajit7887 

Can we have another look at your opening post?

You said :

I have to start multiple restore jobs from same policy. This will include multiple folders which are in different medias. 

This implies that you have Multi-streaming enabled (different to multiplexing), so that stream 1 (folder1) goes to media id ABC in Drive1, stream 2 (folder2) goes to Media id DEF in Drive2, etc... etc.. 

If the above is true, then restore for folder1 will request tape ABC, folder2 restore will request media DEF.
The tapes will then be loaded in different drives for 2 simultaneous retores.

If you do not have multistreaming enabled, it means that all folders were sequentially written in a single stream to tape ABC until full, then to tape DEF until full, then tape XXX, and so on. So, single stream of multiple folders or volumes  - all media id's part of a single backup set.

If this was the case, then multiple restores won't work. 

So, let us start from scratch - please show us your policy config: 

bppllist <policy-name> -U