cancel
Showing results for 
Search instead for 
Did you mean: 

warning: unable to obtain list using specified search criteria

________o
Level 4

hi,

when i try open backup achive and restore GUI and choice server to restore show error warning: unable to obtain list using specified search criteria

my veritas ver 7.5 under windows 2008

37 REPLIES 37

Yogesh9881
Level 6
Accredited

make sure Policy Name & type / Source & Desti Client name is accurate (upper & lower case)

Client name need to exact same as mentioned in policy 

also make sure the data u wnat to restore is not expired as per the retention .....smiley

Andy_Welburn
Level 6

Sorry, looks like that comes up with a slightly different warning message.

Are there actually any backups for that client? Is it an "empty" backup that you're selecting?
e.g. we have some incrementals that generally don't change much, so when we select one in the history timeline that didn't actually save anything per se we do get this messsage

Marianne
Level 6
Partner    VIP    Accredited Certified

On W2008, always open GUI with right-click, Run as Administrator (some actions work fine without this, some not).

When machine names are selected, bear the following in mind:

  • Server name MUST be master server name (this is where image database resides)
  • Source client name MUST match policy client name exactly (NBU is case sensitive, also - Client1 is not the same as Client1.xxxxxx.yyy)
  • Policy type must match the type specified in policy at the time when backup was done.
  • Valid/successful backup exist for client name.

For browse and restore troubleshooting, ensure that bprd log folder exist on the master server (if not, create folder under logs and restart NBU).

________o
Level 4

Dear all i would like to thank all

 

I am try all recomendation but the problem still as it

i think this problem start after upgrade to ver 7.5 so may be bug in software

 

any comment

Andy_Welburn
Level 6

There are also the various options under the "Select for Restore" drop-down box which may be incorrect depending on what you're restoring?

 

Looks like there was also a 'bug' in one of the 7.5 betas but that shouldn't have made it into the FA or GA releases: http://www.symantec.com/business/support/index?page=content&id=TECH178262

Marianne
Level 6
Partner    VIP    Accredited Certified

I doubt that this a bug.

Please open cmd (Run as Administrator) and supply output of the following:

bpimagelist -client <client-name> -pt <policy_type> -d <start-date> -e <end-date>

where:
policy_type is one of the following:
AFS
Auspex-FastBackup
DataStore
DataTools-SQL-BackTrack
DB2
Enterprise-Vault
FlashBackup
FlashBackup-Windows
Informix-On-BAR
LotusNotes
MS-Exchange-Server
MS-Hyper-V
MS-SharePoint
MS-SQL-Server
MS-Windows
NDMP
NetWare
Oracle
OS/2
PureDisk-Export
SAP
Split-Mirror
Standard
Sybase
Vault
VMware
 

-d and -e is in the form of mm/dd/yyyy

bpimagelist is in <install-path>\netbackup\bin\admincmd

________o
Level 4

Andy_Welburn
Level 6

which states

"This issue is with NetBackup 7.5 Beta 2.

...

This issue is on-track to be fixed within NetBackup 7.5 First Availability and 7.5 GA."

________o
Level 4

i try work around in above link but didn't work

________o
Level 4

Dear Marianne

Kindly find below result after run your command

 

 

C:\Program Files\VERITAS\NetBackup\bin\admincmd>bpimagelist -client BAP-S-ECDB -
pt MS-Windows -d 3/12/2012 -e 3/12/2012
no entity was found

Marianne
Level 6
Partner    VIP    Accredited Certified

Please open Windows Explorer and navigate to C:\Program Files\VERITAS\NetBackup\db\images.

Please find Client name in the list of folders.

Please tell us what the folder name looks like and what the contents of this folder is.

Also ensure that bprd log folder exists under C:\Program Files\VERITAS\NetBackup\logs.

After NBU is restarted to enable the log, you will find a filename in this folder with today's date. Please copy this file, rename it to bprd.txt and post as attachment.

I notice that you are looking for a backup done on 12 March. This was a Monday. Most people run incrementals on a Monday. What is your retention period for incrementals?

________o
Level 4

acuale now i found another sever wiith the same problem

i am navigate to C:\Program Files\VERITAS\NetBackup\db\images i folders for all servers in backup jobs and found 2 folders for 2 server have problem

the folder name bap-sql1  kindly see attached and BAP-S-ECDB kindly see attached but i found a lot of  folders under 2 folder  the strange thing under 2  folders the date modified for folders and time the 13-3-2012 3:41pm? where new backup jobs till today

my retention  period 6 monthes

N.B

i try yesterday run full backup for bap-s-ecdb the backup job comleted succssfuly but when i try open restore GUI found the same problem and under image folder for this server i didn't found new folder for full backup by yesterday date kindly see attached (GUI restore error and GUI restore)

 bprd logs in attached

Marianne
Level 6
Partner    VIP    Accredited Certified

Look at the date-range that you are looking for:

08:38:41.786 [5644.4740] <2> fileslist:    starttime = 1334214350
08:38:41.786 [5644.4740] <2> fileslist:    endtime = 1334239682

UNIX time 1334214350 is 04/12/2012 7:05am GMT.
UNIX time 1334239682 is 04/12/2012 2:08pm GMT

Now look at the folders in BAP-S-ECDB image folder:

The oldest folder is : 1265000000
1265000000 is 02/01/2010 4:53am GMT.

The newest: 1281000000
UNIX time 1281000000 is 08/05/2010 9:20am GMT.

This means that you have done NO backups for client BAP-S-ECDB with that EXACT spelling since May 2010.

I can see other references in host-cache for client-name in lowercase and with FQDN (bap-s-ecdb.bapetco.com).

Now, please check what exactly is in the Client tab for the policy that is backing up this client.

You should see a folder name under images that corresponds exactly with the name as it appears in the policy.

If you are doing backups with lowercase FQDN name, this is what you need to select as Source Client.

________o
Level 4

no i am sure i take backup for 2 servers i checked restore every week and was opened last week

and i am run full backup yesterday fro BAP-S-ECDB and completed succssfuly if you see in pic (GUI restore error) you will see in left screen green dot for full backup was done yesterday

about FQDN this is becuse i am tried to remove netbackup client from server and reinstall by FQDN but before yesterday was without FQDN

 

________o
Level 4

sorry i sent to you pic's for old image folder i forget about i created altpath folder in another location sorry again kindly find new pic for altpath (image alt)

i found under altpath image folder for BAP-S-ECDB as attached but with old image dates and found another folder called BAP_S_ECDB as attached and  found under this folder new dates of backup image

i think NetBackup have conflict and store image for BAP-S-ECDB under BAP_s_ECDB is this right

Jeff_Foglietta
Level 5
Partner Accredited Certified

In the BAR Window please check your "Browse Directory" entry. That may be the cause for this error. Make sure the entry is set to the root path of your client.. for example if this is a UNIX client you would put a "/" in that dialogue box...

________o
Level 4

sorry i can't understand what do you mean please explain

Jeff_Foglietta
Level 5
Partner Accredited Certified

See attached screenshot.

This is from a linux machine. In the "Browse directory" you will see "/root/" .. Now If I try to fetch backups using that browse directory I will get the same error you are getting. Change the entry from "/root" to "/" and all is good....

Jeff_Foglietta
Level 5
Partner Accredited Certified

See attached... Note the Browse directory entry in each of the screenshots