cancel
Showing results for 
Search instead for 
Did you mean: 

No SNMP from OpsCenter

I am trying to monitor Netbackup through SCOM 2007 R2, but I am not receiving any traps.

My environment:
Symantec NetBackup 7.1.03
Symantec OpsCenter (on a Windows Server 2008 R2 box w. Quad cpu and 16Gb ram)

SNMP on OpsCenter:
- Security tab:
- - community: public, READ CREATE
- - Accept SNMP packets from: SCOM ip, OpsCenter ip
- Traps tab:
- - Community: public
- - Trap destinations: SCOM ip, OpsCenter ip
(OpsCenter ip is for testing the snmp)

SCOM server receives traps from other machines, so SNMP on public is working on the SCOM server.
Management Pack for Symantec NetBackup is installed, and the OpsCenter is discovered.
Also, the MIB files has been compiled on the SCOM server.

I have started SNMPUTIL on both SCOM server and OpsCenter server, and I can see SNMP between the boxes are working
(traps are showing up on both boxes ie when restarting SNMP service)

In OpsCenter, I have created a two snmp accounts. One for SCOM and one for OpsCenter (to see traps in SNMPUTIL). Both on port 162.scom
I have created a test alert policy, that should send a snmp trap on "Job Finalized" (and that should be a lot...)

My "nm.conf":
nm.trapversion=v2c
nm.hostname=localhost
nm.trapCommunity=public
(I have tried various entries... but with no succes.....and yes.... I have done a OpsAdmin stop and OpsAdmin start when changing something).

In the logs-directory, I can see the "trap_yyyy_mm_dd_time_.log" file,
and this log file is filled with (good) entries, like:
-------------------------------------------------------------------------------
Time stamp : Wed Feb 08 14:50:30 CET 2012
-------------------------------------------------------------------------------
[Wed Feb 08 14:52:37 CET 2012] sendV2cTrap success 10.107.6.14:162 1.3.6.1.4.1.1302.3.12.10.2.0.4 (1.3.6.1.4.1.1302.3.12.10.1.1,mddkcphhmrms01) (1.3.6.1.4.1.1302.3.12.10.1.2,509367 Active Job Completed with Exit Status 1) (1.3.6.1.4.1.1302.3.12.10.1.3,Alert Raised on: 8. februar 2012 14:52  Job: 8432896  Tree Type : Server   Tree Name : ALL MASTER SERVERS  Nodes : sucs20  Job Policy: DTDKCPHAS0456_MSSQL_TRANS  Exit Status: 1 (the requested operation was partially successful)  Client: dtdkcphas0456  New State: Done  Alert Policy: Test1  OpsCenter Server: DTDKCPHAS0408  ) (1.3.6.1.4.1.1302.3.12.10.1.4,Test1) (1.3.6.1.4.1.1302.3.12.10.1.5,) (1.3.6.1.4.1.1302.3.12.10.1.6,) (1.3.6.1.4.1.1302.3.12.10.1.7,DTDKCPHAS0408) (1.3.6.1.4.1.1302.3.12.10.1.8,) (1.3.6.1.4.1.1302.3.12.10.1.9,) (1.3.6.1.4.1.1302.3.12.10.1.10,) (1.3.6.1.4.1.1302.3.12.10.1.11,Informational) (1.3.6.1.4.1.1302.3.12.10.1.12,Wed Feb 08 14:52:37 CET 2012)
[Wed Feb 08 14:52:37 CET 2012] sendV2cTrap success 10.107.18.80:162 1.3.6.1.4.1.1302.3.12.10.2.0.4 (1.3.6.1.4.1.1302.3.12.10.1.1,dtdkcphas0408 - 162) (1.3.6.1.4.1.1302.3.12.10.1.2,509367 Active Job Completed with Exit Status 1) (1.3.6.1.4.1.1302.3.12.10.1.3,Alert Raised on: 8. februar 2012 14:52  Job: 8432896  Tree Type : Server   Tree Name : ALL MASTER SERVERS  Nodes : sucs20  Job Policy: DTDKCPHAS0456_MSSQL_TRANS  Exit Status: 1 (the requested operation was partially successful)  Client: dtdkcphas0456  New State: Done  Alert Policy: Test1  OpsCenter Server: DTDKCPHAS0408  ) (1.3.6.1.4.1.1302.3.12.10.1.4,Test1) (1.3.6.1.4.1.1302.3.12.10.1.5,) (1.3.6.1.4.1.1302.3.12.10.1.6,) (1.3.6.1.4.1.1302.3.12.10.1.7,DTDKCPHAS0408) (1.3.6.1.4.1.1302.3.12.10.1.8,) (1.3.6.1.4.1.1302.3.12.10.1.9,) (1.3.6.1.4.1.1302.3.12.10.1.10,) (1.3.6.1.4.1.1302.3.12.10.1.11,Informational) (1.3.6.1.4.1.1302.3.12.10.1.12,Wed Feb 08 14:52:37 CET 2012)
[Wed Feb 08 14:52:37 CET 2012] sendV2cTrap success 10.107.6.10:162 1.3.6.1.4.1.1302.3.12.10.2.0.4 (1.3.6.1.4.1.1302.3.12.10.1.1,scom35) (1.3.6.1.4.1.1302.3.12.10.1.2,509367 Active Job Completed with Exit Status 1) (1.3.6.1.4.1.1302.3.12.10.1.3,Alert Raised on: 8. februar 2012 14:52  Job: 8432896  Tree Type : Server   Tree Name : ALL MASTER SERVERS  Nodes : sucs20  Job Policy: DTDKCPHAS0456_MSSQL_TRANS  Exit Status: 1 (the requested operation was partially successful)  Client: dtdkcphas0456  New State: Done  Alert Policy: Test1  OpsCenter Server: DTDKCPHAS0408  ) (1.3.6.1.4.1.1302.3.12.10.1.4,Test1) (1.3.6.1.4.1.1302.3.12.10.1.5,) (1.3.6.1.4.1.1302.3.12.10.1.6,) (1.3.6.1.4.1.1302.3.12.10.1.7,DTDKCPHAS0408) (1.3.6.1.4.1.1302.3.12.10.1.8,) (1.3.6.1.4.1.1302.3.12.10.1.9,) (1.3.6.1.4.1.1302.3.12.10.1.10,) (1.3.6.1.4.1.1302.3.12.10.1.11,Informational) (1.3.6.1.4.1.1302.3.12.10.1.12,Wed Feb 08 14:52:37 CET 2012)
 

BUT.... none of these traps make it to SCOM.. and not even to the snmputil on the OpsCenter box.
(and there are no Firewall to block this).

What do I have to do, to get these snmp traps out of the OpsCenter box and to SCOM ?

9 Replies

Check Anti-Virus & and Security Software installed

Some A / V programs can block this type of traffic, and may need to be adjusted.

Do you have SMTP configured in OpsCenter to email alerts / reports / etc?  Is that working?

You could try a 3rd party snmp listner on the OpsCenter host to verify SNMP alerting is being broadcast.

 

In addition, the log entries above show

  • sendV2cTrap success 10.107.6.14:162 
  • sendV2cTrap success 10.107.6.10:162

 

Can you communicate across port 162 from the OpsCenter host to each of these IPs?

No blocking software

I have no A/V software on the box, and firewall is disabled.

I have tried with FW enabled and allowing all traffic (and pop-up if blocking), and this made no difference.

I enbled email alerts... and I got spammed :) that part works.

There are no changes made in the setup, so:
snmp 161/udp
snmptrap 162/udp

and Netstat -an shows ie:
UDP  0.0.0.0:161   *:*
UDP  0.0.0.0:162   *:*

Using SMNPUTIL I can see traps from OpsCenter box on SCOMserver when restarting SNMPservice on OpsCenter box.
And using SNMPUTIL on OpsCenter box, I can see traps from SCOMserver on OpsCenter box when restarting SNMPservice on SCOMserver.

But no Opscenter traps shows up anywhere (only looking fine in OpsCenter TRAPs log)
 

Sent versus Received?

From your previous statement is sounds like the SNMP alert is being sent and the SCOM host can see the alert... but the alert is never received / logged into SCOM itself.

Is this correct?

If so, there must be a configuration within SCOM that is not right.

Please refer to this document for the MIB pack - http://www.symantec.com/docs/TECH139344

The  file contains detailed instructions for deploying the SCOM Pack for NetBackup OpsCenter 

To me, it more seems like the

To me, it more seems like the traps from OpsCenter never made it to the network adapter.

OpsCenter is configured to send to scom and its own network adapter, but running snmputil on both boxes never shows any traps.

The only time snmp traffic is shown in snmputil (on both boxes) are when I restart the snmp service.

I would think that, if OpsCenter did send the traps, some snmp codes should show up in snmputil on both boxes.

I now send traps to my

I now send traps to my scom-box,
but nothing shows up in SCOM console.

For a start, I turned on the windows firewall, and in the fw-log I could see nothing trying on port 162.
Then I changed OpsCenetr to use SNMP v1, and then I got a lot of traffic, and now I can see snmp traps from OpsCenter in SNMPUTIL on the SCOM box.

But, I don't get data in SCOM console....
and the MIBs are compiled on the scom box, and the MP are imported....

Anyone knows how to get this to work ?

did you ever find the

did you ever find the solution? I have playing with OpsCenter 7.1 and SCOM 2007R2 recently and was able to make it work. As soon as SNMP traps from OpsCenter server were seen on the SCOM server you should be able to see the Alerts from OpsCenter after all the configuration on the SCOM and OpsCenter server. One thing is missed in the Guide that you have to do to see the Alerts in the NetBackup Views - Alert View is to uncheck the box in the Alert View properties - Criteria tab - Select conditions - "with specific text in Custom Field .." It is checked by default.

Does anybody knows how to remove clean the NetBackup Management pack from the SCOM server? Could some other Management pack or Rules on the SCOM server interfere with NetBackup pack and not allow the Alert View to display the alerts?

it is still not working for

it is still not working for me. I had hoped that the upgrade to OpsCenter 7.1 would help - but no.
I can see, that my SCOM server receives the traps from OpsCenter, but nothing pops up in the SCOM Console. I tried your trick - removing the check mark - but it did not help.

So - now I'm very tired of this MP. I will remove again, and instead - I will develop my own SNMP management pack (and thanks for NO help to symantec)

I agreed that the MP is kind

I agreed that the MP is kind of old and probably not reflect all the changes in SCOM 2007R2, and now they have SCOM 2012. My question to Symantec would be who is responsible for the SCOM 2007 R2 Management Pack for NetBackup 7.1 and higher, is Symantec working on this? The latest MP that you can download is from 2009.

Using SMNPUTIL I can see some

Using SMNPUTIL I can see some traps from OpsCenter box on SCOM server after restarting SNMP on OpsCenter.
And using SNMPUTIL on OpsCenter box, I can see traps from SCOMserver on OpsCenter box when restarting SNMPservice on SCOMserver. But it still not working for me... flyff private server