cancel
Showing results for 
Search instead for 
Did you mean: 

Windows Data Collector (WindDC_GUI.exe) Installation and Upgrade check fails "Active Directory Check"

kjbss
Level 5
Partner Accredited

Problem Type: Installing 

Product Name: Storage Foundation HA for Windows 

Product Version: 5.1SP2 

Platform: Windows Server 2008 R2 

Platform version: Enterprise (x64-64bit) 

Brief description of problem:
Windows Data Collector (WindDC_GUI.exe) Installation and Upgrade check fails "Active Directory Check"  

Problem:
========
When I run the Windows Data Collector (WindDC_GUI.exe) and tell it to do an Installation and Upgrade check for SFWHA 5.1 SP2, it report the following error condition:
---- begin ----
Active Directory Check

Checks if Active Directory is present

  Failed
   Reason: Unabled to querry the domain information. The DNS name of the primary domain is empty.

Possible resolution:  Ensures that the DNS name of the primary domain is not empty.
---- end ----
As far as I can tell, the Domain name is "corp.kjbss.int", and therefore not empty. 
Can anyone please describe the command it is using to obtain this result of "empty domain name".

Note that when you view the resport that can be uploaded to SORT, it shows the following additional hint(?):
---- begin ----
Required: 
SFW HA requires the presence of Microsoft Active Directory.
---- end ----
Again, As far as I can tell, Active Directory is present.  How do I verify this?  (what is the specific command to run?)

 

CONFIGURATION:
==============

Windows Server 2008 R2 Enterprise
Service Pack 1
System Type:  64 bit
Computer Name:  SFWHA-01
Full Computer Name:  SFWHA-01.corp.kjbss.int
Domain:  corp.kjbss.int

Roles: 
Active Directory Lightweight Directory Services


Various command output:

 
C:\Users\Administrator>nslookup corp
Server:  UnKnown
Address:  192.168.0.58

Name:    corp.kjbss.int
Addresses:  192.168.0.58
          192.168.214.2
          192.168.215.2


C:\Users\Administrator>nslookup corp.kjbss.int
Server:  UnKnown
Address:  192.168.0.58

Name:    corp.kjbss.int
Addresses:  192.168.0.58
          192.168.214.2
          192.168.215.2

C:\Users\Administrator>nslookup www.google.com
Server:  UnKnown
Address:  192.168.0.58

Non-authoritative answer:
Name:    www.google.com.kjbss.int
Address:  81.200.64.50

C:\Users\Administrator>ipconfig /all

Windows IP Configuration

   Host Name . . . . . . . . . . . . : SFWHA-01
   Primary Dns Suffix  . . . . . . . : corp.kjbss.int
   Node Type . . . . . . . . . . . . : Hybrid
   IP Routing Enabled. . . . . . . . : No
   WINS Proxy Enabled. . . . . . . . : No
   DNS Suffix Search List. . . . . . : corp.kjbss.int

Ethernet adapter Local Area Connection 3:

   Connection-specific DNS Suffix  . :
   Description . . . . . . . . . . . : Intel(R) PRO/1000 MT Network Connection #3
   Physical Address. . . . . . . . . : 00-50-56-2B-26-FA
   DHCP Enabled. . . . . . . . . . . : No
   Autoconfiguration Enabled . . . . : Yes
   IPv4 Address. . . . . . . . . . . : 192.168.215.3(Preferred)
   Subnet Mask . . . . . . . . . . . : 255.255.255.0
   Default Gateway . . . . . . . . . :
   NetBIOS over Tcpip. . . . . . . . : Enabled

Ethernet adapter Local Area Connection 2:

   Connection-specific DNS Suffix  . :
   Description . . . . . . . . . . . : Intel(R) PRO/1000 MT Network Connection #2
   Physical Address. . . . . . . . . : 00-50-56-29-92-79
   DHCP Enabled. . . . . . . . . . . : No
   Autoconfiguration Enabled . . . . : Yes
   IPv4 Address. . . . . . . . . . . : 192.168.214.3(Preferred)
   Subnet Mask . . . . . . . . . . . : 255.255.255.0
   Default Gateway . . . . . . . . . :
   NetBIOS over Tcpip. . . . . . . . : Enabled

Ethernet adapter Local Area Connection:

   Connection-specific DNS Suffix  . :
   Description . . . . . . . . . . . : Intel(R) PRO/1000 MT Network Connection
   Physical Address. . . . . . . . . : 00-50-56-29-BC-C1
   DHCP Enabled. . . . . . . . . . . : No
   Autoconfiguration Enabled . . . . : Yes
   IPv4 Address. . . . . . . . . . . : 192.168.0.60(Preferred)
   Subnet Mask . . . . . . . . . . . : 255.255.255.0
   Default Gateway . . . . . . . . . : 192.168.0.1
   DNS Servers . . . . . . . . . . . : 192.168.0.58
                                       194.168.4.100
   NetBIOS over Tcpip. . . . . . . . : Enabled

Tunnel adapter isatap.{433DFA3C-8171-4A0B-85C6-751C5242D69B}:

   Media State . . . . . . . . . . . : Media disconnected
   Connection-specific DNS Suffix  . :
   Description . . . . . . . . . . . : Microsoft ISATAP Adapter
   Physical Address. . . . . . . . . : 00-00-00-00-00-00-00-E0
   DHCP Enabled. . . . . . . . . . . : No
   Autoconfiguration Enabled . . . . : Yes

Tunnel adapter Local Area Connection* 12:

   Media State . . . . . . . . . . . : Media disconnected
   Connection-specific DNS Suffix  . :
   Description . . . . . . . . . . . : Teredo Tunneling Pseudo-Interface
   Physical Address. . . . . . . . . : 00-00-00-00-00-00-00-E0
   DHCP Enabled. . . . . . . . . . . : No
   Autoconfiguration Enabled . . . . : Yes

Tunnel adapter isatap.{14AD1B93-8887-4C7A-808D-0DB54DC5BD99}:

   Media State . . . . . . . . . . . : Media disconnected
   Connection-specific DNS Suffix  . :
   Description . . . . . . . . . . . : Microsoft ISATAP Adapter #2
   Physical Address. . . . . . . . . : 00-00-00-00-00-00-00-E0
   DHCP Enabled. . . . . . . . . . . : No
   Autoconfiguration Enabled . . . . : Yes

Tunnel adapter isatap.{FED9D559-349F-4572-93E7-3E483CFEC7BA}:

   Media State . . . . . . . . . . . : Media disconnected
   Connection-specific DNS Suffix  . :
   Description . . . . . . . . . . . : Microsoft ISATAP Adapter #3
   Physical Address. . . . . . . . . : 00-00-00-00-00-00-00-E0
   DHCP Enabled. . . . . . . . . . . : No
   Autoconfiguration Enabled . . . . : Yes 


  =====================

The Windows server is completely uptodate on all Windows updates.

IP 192.168.0.58 is the IP of the Domain Controller / DNS server.

Any pointers on how to diagnose this issue -- please provide specific commands to run, if/where appropriate.  IE:  How exactly would one "Ensures that the DNS name of the primary domain is not empty"?
 

1 ACCEPTED SOLUTION

Accepted Solutions

kjbss
Level 5
Partner Accredited

Well, I still have no explaination as to why the Windows Data Collector "Installation and Upgrade" option is STILL failing at the "Active Directory Check" with this strange error message: "Unabled to querry the domain information. The DNS name of the primary domain is empty".

However, I wanted to see how far the installer would go so that I could at least get SFW installed (as it has less system restrictions than the VCS component, and installs first).  So I went for an install, fully expecting it to fail.

But it didn't.  SFWHA 5.1 SP2 simply installed fine, just like it should!

Therefore, the Windows Data Collector is not checking, or not doing *something*, the same way that the installer does during it's pre-checks.

...and therefore, in my opinion, either the Windows Data Collector is broken, or the installer is broken, as they really should be running the exact same checks and *should* behave consistently. 

Contributing to this SFWHA-Install-problem was that I did not have the "Computer Browser" service running (as suggested by Tom) on the Domain Controller, and I also did not have the "Reverse Lookup up Zone" stuff set up correctly in the beginning.  Both of these items are listed in the install guide, but I missed it and subsequently got side-tracked by my over reliance on the Data Collector's "Installation and Upgrade" "feature" (which was (apparantly) lying to me ). 

 

Bottom line for me is that if this check reports "Unabled to querry the domain information. The DNS name of the primary domain is empty", don't believe it!  Go ahead and try the installation anyways.

Hope this helps somebody ... (or the SORT tools owners fix this).

View solution in original post

3 REPLIES 3

Tom_Sam
Level 2

Make sure computer browser services is running.

kjbss
Level 5
Partner Accredited

Tom: Thanks for the suggestion --

The Computer Browser service was Disabled on both the target system and the Domain Controller.  I configured it to start and rebooted on both.

Unfortunately, this had NO effect on the problem -- still failing the Active Directory check with "Unabled to querry the domain information. The DNS name of the primary domain is empty". 

Any idea how to verify that the "DNS name of the primary domain is not empty"? 

kjbss
Level 5
Partner Accredited

Well, I still have no explaination as to why the Windows Data Collector "Installation and Upgrade" option is STILL failing at the "Active Directory Check" with this strange error message: "Unabled to querry the domain information. The DNS name of the primary domain is empty".

However, I wanted to see how far the installer would go so that I could at least get SFW installed (as it has less system restrictions than the VCS component, and installs first).  So I went for an install, fully expecting it to fail.

But it didn't.  SFWHA 5.1 SP2 simply installed fine, just like it should!

Therefore, the Windows Data Collector is not checking, or not doing *something*, the same way that the installer does during it's pre-checks.

...and therefore, in my opinion, either the Windows Data Collector is broken, or the installer is broken, as they really should be running the exact same checks and *should* behave consistently. 

Contributing to this SFWHA-Install-problem was that I did not have the "Computer Browser" service running (as suggested by Tom) on the Domain Controller, and I also did not have the "Reverse Lookup up Zone" stuff set up correctly in the beginning.  Both of these items are listed in the install guide, but I missed it and subsequently got side-tracked by my over reliance on the Data Collector's "Installation and Upgrade" "feature" (which was (apparantly) lying to me ). 

 

Bottom line for me is that if this check reports "Unabled to querry the domain information. The DNS name of the primary domain is empty", don't believe it!  Go ahead and try the installation anyways.

Hope this helps somebody ... (or the SORT tools owners fix this).

View solution in original post