NFS cluster switchover getting failed from node1 to node2

I am facing  issue when i am trying to switch the resource group from node1 to node2 and getting attached error for the nfs mount point.

So can you please suggest the solution to this problem.

Below is the nfs export and fstab file entry on node1 ,node2.

[root@node1 ~]# cat /etc/exports
/nfsshr01 *(rw,sync,no_root_squash)
[root@node1 ~]#

[root@node1 ~]# cat /etc/fstab
/dev/VolGroup00/LogVol00 /                       ext3    defaults        1 1
LABEL=/boot             /boot                   ext3    defaults        1 2
tmpfs                   /dev/shm                tmpfs   defaults        0 0
devpts                  /dev/pts                devpts  gid=5,mode=620  0 0
sysfs                   /sys                    sysfs   defaults        0 0
proc                    /proc                   proc    defaults        0 0
/dev/VolGroup00/LogVol01 swap                    swap    defaults        0 0

# NOTE: When adding or modifying VxFS or VxVM entries, add '_netdev'
# to the mount options to ensure the filesystems are mounted after VxVM and
# VxFS have started.
192.168.56.121:/nfsshr01 /nfslock       nfs      defaults        0 0
[root@node1 ~]#

[root@node2 ~]# cat /etc/fstab
/dev/VolGroup00/LogVol00 /                       ext3    defaults        1 1
LABEL=/boot             /boot                   ext3    defaults        1 2
tmpfs                   /dev/shm                tmpfs   defaults        0 0
devpts                  /dev/pts                devpts  gid=5,mode=620  0 0
sysfs                   /sys                    sysfs   defaults        0 0
proc                    /proc                   proc    defaults        0 0
/dev/VolGroup00/LogVol01 swap                    swap    defaults        0 0

# NOTE: When adding or modifying VxFS or VxVM entries, add '_netdev'
# to the mount options to ensure the filesystems are mounted after VxVM and
# VxFS have started.
192.168.56.121:/nfsshr01 /nfslock       nfs      defaults        0 0
[root@node2 ~]#

When trying to do manually getting below error for mount point under vcs.

[root@node2 ~]# mount -t vxfs /dev/vx/dsk/nfsvdg01/nfsvol01  /nfsshr01
UX:vxfs mount.vxfs: ERROR: V-3-22168: Cannot open portal device: No such file or directory
UX:vxfs mount.vxfs: ERROR: V-3-25255: mount.vxfs: You don't have a license to run this program
[root@node2 ~]#

 

1 Solution

Accepted Solutions
Highlighted
Accepted Solution!

This is a duplicate

1 Reply
Highlighted
Accepted Solution!

This is a duplicate