cancel
Showing results for 
Search instead for 
Did you mean: 

SFHA install in Solaris 10 with Solaris 9 Branded Zone

We have install SFHA 5.1SP1RP3 in Solaris 10 update 10.

When we configure the VCS zone agent to handle the Solaris 9 Branded Zone. It can online, offline the Solaris 9 Branded Zone in SFHA, but we see that Online the zone in agent, it show boot single user mode first, and then reboot to multi user mode. After boot in multi user mode, it is normal in VCS.

Is that any solution for boot multi user mode only?

1 Solution

Accepted Solutions
Accepted Solution!

Thank you all of your reply,

Thank you all of your reply, support find that it is because the branded zone need to do the p2v script which running in single user mode and then boot up the branded zone in agent setting.

It is normal behavior for the zone agent.

View solution in original post

17 Replies

What value do you have for

What value do you have for the BootState attribute - see extract from Bundled agents guide:

BootState

The value for the milestone service. Acceptable values
follow:
■ single-user
■ multi-user
■ multi-user-server
Note: Symantec recommends that you use the multi-user-
server value for the BootState attribute.
Type and dimension: string-scalar
Default: multi-user
This says Symantec recommends multi-user-server, but default is multi-user, so you could try changing this, as I am not sure what this means multi-user-server means.
 
Mike

 

could you confirm/ensure: i)

could you confirm/ensure:

i) VCS Zone agent attribute 'BootState' is set to multi-user.

ii) milestone specified in BootState attribute is online for the zone using the below command from global zone.
#   zlogin $zone svcs -o state -H milestone/multi-user
 

multi-user is the equivalent

multi-user is the equivalent of run level 2 (ie: the services that would previously have been configured to be started by scripts in /etc/rc2.d )

multi-user-server is the equivalent of run level 3 (previously scripts run in /etc/rc3.d)

If BootState is set to multi-user - this means VCS will consider the zone to be online once it reaches that milestone (zone up, network available). The server might still continue past that point to the multi-user-server milestone anyway, but VCS will consider the zone online as soon as it gets to multi-user eg: the server might fail to get to multi-user-server (wouldn't start nfs server, applications, et al) but VCS would still consider the zone to be online.

If BootState is set to multi-user-server - VCS won't mark the zone as online until it reaches that milestone, so if it fails to reach it (due to service dependency within zone / some other problem within the zone), VCS would consider the zone to be offline / attempt to failover if configured as Critical, etc.

I have try multi-user and

I have try multi-user and multi-user-server, but it show the same issue.

It is Solaris 9 Branded Zone, so it doesn't have svcs for check

BootState attribute value

BootState attribute value would be ignored for branded zones by Zone agent. So there will not be any effect of this attribute in your case.

 

What exactly is the issue? Did you configure your zone by loging onto console (#zlogin -C <zone_name>)?

 

Also make sure you run hazonesetup command to configure zone into VCS.

 

Regards,

Venkat

right. sorry abt overlooking

right. sorry abt overlooking that.

Hi, sfchan   Does that happen

Hi, sfchan

 

Does that happen every time? on every server?

Yes, it happen every time on

Yes, it happen every time on the Solaris 9 Branded zone boot up only.

The Solaris 9 Branded zone is

The Solaris 9 Branded zone is not a failover zone, and both Global zone have a dedicate Solaris 9 Branded Zone.

Do it also need to run hazonesetup?

All types of zone need to run

All types of zone need to run hazonesetup.

Hazonesetup configures VCS entities like group, resrouce, user, password, etc.

In addition, hazonesetup runs halogin command inside local zone which enables passwordless communication between local zone and global zone. Passwordless communication is required by the applications running inside zone to communicate with 'had' in global zone.

 

The Zone agent boots the

The Zone agent boots the local zone with 'zoneadm -z <zone_anme> boot' command. The zoneadm internally might be booting the zone into single-user mode and then into multi-user mode. The Zone agent will not have any control over the actions performed by zoneadm or containers.

You can check this behavior by disabling the Zone resource for solaris 9 brand zone and booting the zone outside of VCS with the above command. I believe this is a natural process in booting the Zone or system into single-user mode and then into multi-user mode.

 

If you see any issue with this process you can check with Oracle on the correct behavior.

 

Regards,

Venkat

Thank you all reply,   I have

Thank you all reply,

 

I have use the hazonesetup to create the zone agents, however it is the same issue when online the zone like below console log messages.

 

NOTICE: Zone booting up]

SunOS Release 5.9 Version Generic_Virtual 64-bit
Copyright (c) 2008, 2011, Oracle and/or its affiliates.All rights reserved


INIT: SINGLE USER MODE

Type control-d to proceed with normal startup,
(or give root password for system maintenance):
[NOTICE: Zone halted]

[NOTICE: Zone booting up]

SunOS Release 5.9 Version Generic_Virtual 64-bit
Copyright (c) 2008, 2011, Oracle and/or its affiliates.All rights reserved

Hostname: test09
The system is coming up.  Please wait.
starting rpc services: rpcbind done.
syslog service starting.
May 27 14:42:14 test09 sendmail[11992]: My unqualified host name (localhost) unknown; sleeping for retry
May 27 14:42:14 test09 sendmail[11993]: My unqualified host name (localhost) unknown; sleeping for retry
prtconf: devinfo facility not available
prtconf: devinfo facility not available
The system is ready.

test09 console login: May 27 14:42:15 test09 snmpXdmid: Send Trap failed Return code =
May 27 14:43:14 test09 sendmail[11992]: unable to qualify my own domain name (localhost) -- using short name
May 27 14:43:14 test09 sendmail[11993]: unable to qualify my own domain name (localhost) -- using short name

 

=================================================================

When I run "zoneadm -z test09 boot", the zone will boot up to multi-user mode directly.

 

Hi, Sfchan    Do you check

Hi, Sfchan

 

 Do you check container's version:

======

For Solaris 10 10/08 or later
■ For Solaris 9 branded zones:
Install Solaris 9 Containers 1.0.1
=========
YoucanobtaintheContainerssoftwarebundlesfromOracleDownload
Center at: http://www.sun.com/software/solaris/containers. For
detailed information aboutthe above requirements, read Oracle'
README files from the software bundle.

 

The Solaris 9 Containers

The Solaris 9 Containers version is 1.0.1 

I had run the other server with the same Solaris 10 and SFHA, it is the same result, so it may the online script issue

Hi, sfchan    You can contact

Hi, sfchan

 

 You can contact support engineer if  it's a agent issue of vcs.

Have you tested running

Have you tested running "zoneadm -z zone_name boot" from a shell prompt as VCS is just calling the Solaris command to boot the zone and so it maybe this is expected behaviour from a Solaris point of view.

I suspect you will find that running "zoneadm -z zone_name boot" manually does the same, so you should check with Oracle if you can change the Zone configuration to prevent this happening.

Regarding hazonesetup - I don't believe this is required - this is just a wizard to set-up service group and resources and setup passwordless communication between local (non-global) zone and global zone.  In VCS 5.1 the passwordless communication between local zone and global zone is checked to see if it needs setuping up everytime the resource onlines and it if needs setting up the online does this by creating a VCS user and then uses halogin with this user in the local zone so you can check this has happened by seeing if there is a .vcspasswd file in root's home diretory in the local zone.  I assume this works the same in VCS 6.0

Mike

Accepted Solution!

Thank you all of your reply,

Thank you all of your reply, support find that it is because the branded zone need to do the p2v script which running in single user mode and then boot up the branded zone in agent setting.

It is normal behavior for the zone agent.

View solution in original post