cancel
Showing results for 
Search instead for 
Did you mean: 

Error creating the custom environment

Gilly-Bhoy
Level 6
Partner
Hi All,

I'm trying to create a Customized System Recovery Disk to recover a HP ML350 with a  P400 controller.
Now I added the 2008 drivers to the CSRD as previously advised by a Symantec Employee as i'm using BESR 8.5.3 which loads the 2008 environment on start up.

But every time I try to create the SRD I get the following message after a few minutes:
Error Creating the custom recovery environment

InjectingDriver
ECA3139C
Error ECA3139C: Symantec Recovery Disk does not support the type of driver.


So I created a CSRD a couple of weeks back for a Dell PE 1950, again with the 2008 driver for the Storage Controller and tried to do it again this evening - and now it won't work!!!
Same error each time.

What am I missing here?

Thanks,
Gilly
1 ACCEPTED SOLUTION

Accepted Solutions

marcogsp
Level 6
Gilly -- I've given up on trying to inject the drivers into the SRD so I take a brute strength an ignorance approach.  I copy the entire contents of the SRD to a local folder on my workstation.  I then copy the drivers to a subfolder (can be named anything descriptive) under the DDB folder.  Make sure to include the entire installation package -- extract from archive if necessary.  Then when asked for the location of the SRD during the custom build process, I select the local folder I copied the SRD to.  Sometimes the recovery environment finds the new drivers without issue.  Other times I have to browse to the CD to load the driver.  Either way, it is better than having to remember to mount an external drive where the drivers are stored.

You could also try the Vista drivers if available.  Vista and Server 2008 are the same code base so the drivers are supposed to same.  This might change as the separate products mature.

View solution in original post

23 REPLIES 23

marcogsp
Level 6
Gilly -- I've given up on trying to inject the drivers into the SRD so I take a brute strength an ignorance approach.  I copy the entire contents of the SRD to a local folder on my workstation.  I then copy the drivers to a subfolder (can be named anything descriptive) under the DDB folder.  Make sure to include the entire installation package -- extract from archive if necessary.  Then when asked for the location of the SRD during the custom build process, I select the local folder I copied the SRD to.  Sometimes the recovery environment finds the new drivers without issue.  Other times I have to browse to the CD to load the driver.  Either way, it is better than having to remember to mount an external drive where the drivers are stored.

You could also try the Vista drivers if available.  Vista and Server 2008 are the same code base so the drivers are supposed to same.  This might change as the separate products mature.

View solution in original post

Gilly-Bhoy
Level 6
Partner

Thank's marco!

I'll give that a shot.

Would appreciate a little more feedback though from someone in Symantec perhaps!

criley
Moderator
Moderator
Employee Accredited
Specifically which driver(s) are you trying to add that causes this error?

If you point me towards the download, I can test it here myself.

Gilly-Bhoy
Level 6
Partner
It's a HP ML350 G5 Series Server. Model Number is 458240-421.
I had to google it to find the proper link to the HP site.

I basically picked out the 2008 stoage controller drivers for this box from the HP site.

Funnily enough I tried this for a Dell PE 1950 and it failed in the same way. I got these drivers from the Dell site.

Thanks
Gilly

criley
Moderator
Moderator
Employee Accredited
When I look on the HP site, I see the following storage controllers for the ML350 G5:

HP 4/8 Internal Port SAS HBA with RAID and SCxxGe series HBA Driver for Windows Server 2008
HP ProLiant Smart Array Device Manager Extension for Windows Server 2003/2008
HP ProLiant Smart Array SAS/SATA Controller Driver for Windows Server 2008
HP ProLiant Smart Array SAS/SATA Controller Driver for Windows Server 2003/2008

Which one are you trying to add?

And I assume you are trying to add the drivers for W2K8 32bit and not 64bit..?

Gilly-Bhoy
Level 6
Partner
Last two chris. And yeah they are 32bit.

Cheers.

criley
Moderator
Moderator
Employee Accredited
Thanks for confirming.

I should be able to test this tomorrow when I'm back in the office so I will reply back here once I have tested this.

Gilly-Bhoy
Level 6
Partner
Thanks a mill Chris!

Much appreciated!

Gilly

criley
Moderator
Moderator
Employee Accredited
OK, I had some time to test this and I can add both drivers without issue. I'm using the 8.5.5 version of the SRD so you should test this at your end.

I will need to upload the 8.5.5 SRD to our FTP site for you - I will let you know when that's ready.

In the meantime, can you please send me a screenshot of the error you see so that I can document this issue?

Thanks,
Chris

Gilly-Bhoy
Level 6
Partner

Will do Chris. Give me a little while.

Cheers

Gilly-Bhoy
Level 6
Partner
imagebrowser image
imagebrowser image

criley
Moderator
Moderator
Employee Accredited
Thanks for that.

I have uploaded the 8.5.5 SRD to FTP.entsupport.Symantec.com - it's in /pub/support/outgoing/besr855srd.

Login using iosupport. Password is iS*pp8rT1

Let me know how you get on.

Chris

Gilly-Bhoy
Level 6
Partner
Hi Chris,

I see support but there is no "outgoing" directory underneath?
Just Documentation & Products.

Cheers
Gilly

criley
Moderator
Moderator
Employee Accredited
Try this instead:

ftp://iosupport:iS*pp8rT1@ftp.entsupport.symantec.com/pub/support/outgoing/besr855srd/BESR855_AllWin_English_SrdOnly.rar

criley
Moderator
Moderator
Employee Accredited
Have you been able to test the 8.5.5 SRD yet?

Gilly-Bhoy
Level 6
Partner

Exact same error with that CD!
Can you tell me which driver you tried when creating the SRD for the ML350 please Chris?
I used the one in the screenshot.

Thanks,

Gilly

criley
Moderator
Moderator
Employee Accredited
I downloaded the last 2 from here:

http://h20000.www2.hp.com/bizsupport/TechSupport/SoftwareIndex.jsp?lang=en&cc=us&prodNameId=3279711&prodTypeId=15351&prodSeriesId=1121586&swLang=8&taskId=135&swEnvOID=4022#113214

marcogsp
Level 6
Does the version 8.5.5 SRD need thae same version of BESR in order ot build properly?  LiveUpdate doesn't seem to be pushing out the update, but the fileconnect.symantec.com  download site has it available.

criley
Moderator
Moderator
Employee Accredited
marcogsp,

No, I used 8.5.3 to build a custom 8.5.5 SRD.

8.5.5 is not available on LiveUpdate yet, should be soon though..