cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted

Granular Restore 8.5 not able to open Exchange Mail

I just updated all my servers with BESR 8.5... it's working fine except for one thing... Granular restore 8.5 is not able to open "Exchange Mail"... I always get the following error :

**************************

(i) Make sure that the volume which contains 'N:\First Storage Group\Mailbox Database.edb' was selected for backup

(ii) Try selecting a different Storage Group

**************************

I get the same problem with all my databases...

 

if I open the same backup with Granular Restore 8.0 (previous version), it's working fine.

 

what can be the problem?

should I contact Symantec to get this resolved?

 

 

51 Replies
Highlighted

Re: Granular Restore 8.5 not able to open Exchange Mail

Were the backups taken with 8.5? The version of the installation of BESR on both the server being backed up and the machine running GRO have to be the same, as does the version of GRO itself.
Highlighted

Re: Granular Restore 8.5 not able to open Exchange Mail

yes they are exactly the same...

 

on my exchange server, BESR 8.5.0.28843 is installed.

on my backup server (where BESR, BESR manager and Granular is installed),  here is what is installed :

BESR Manager : 8.5.0.28865

BESR Manager server : 8.5.0.28849

BESR : 8.5.0.28843

BESR Granular restore option : 8.5.0.28740

 

on my Exchange server, I installed Granular restore  8.0.xxx and Outlook 2007 to do some test... and with this version, I can open my Exchange Backup... after that, I installed Granular Restore 8.5.xxx on the same server... but got the same problem (not able to open Exchange mail).

 

By the way, my Exchange databases are not stored on my system volume... they are stored a on different HDD on the same machine.

 

Today, I erased the ExchangeBackup.eif file on my system drive of my Exchange server and erase all my backup files from my backup server... I will report my results tomorrow...

 

Highlighted

Re: Granular Restore 8.5 not able to open Exchange Mail

Be sure that the backups of the Exchange server includes the system, Exchange binaries, and information stores all as part of a single backup job. Make sure that the ExchangeBackup.eif references to the various information stores are reflected in the *.sv2i file on the storage system.
Highlighted

Re: Granular Restore 8.5 not able to open Exchange Mail

Even after erasing the ExchangeBackup.eif file, I got the same problem..

I looked into this file with Notedpad and I can see that the volume that contain all my Exchange databases are in my backup files.

 

All my volumes on my Exchange server are backed up with the same backup job...

 

On my backup storage, I can see files like that :

ML150SRV.sv2i

ml150srv_C_Drive003.v2i

ml150srv_I_Drive003.v2i

ml150srv_N_Drive003.v2i

 

all those files are from the same backup job... they have all the same date, but not the same time.

C is the system volume

N contain all Exchange Databases

I contain some file not related to Exchange

 

I think I found what is the problem... but I don't have any solution...

 

In Granular Restore 8.0, if I open ML150SRV.sv2i, I can see all my volumes in Files and Folders Tab... and in Backup Dates, I only see one item.

In Granular Restore 8.5, if I open ML150SRV.sv2i, I only see one volume at a time in Files and Folders Tab... If I select another date in Backup Dates, I can see an other volume. I see one time/date for each volume... the time of those items are the same as my backup files.

By the way, I get those results with the same backups files...

 

So it seems that there is a bug in Granular Restore 8.5.

 

 

Highlighted

Re: Granular Restore 8.5 not able to open Exchange Mail

It may be best to open a case on this issue under your support agreement so we can troubleshoot the issue more directly.
Highlighted

Re: Granular Restore 8.5 not able to open Exchange Mail

can I open this case online?

 

I prefer online because my spoken english is not very good...

 

By the way, my support agreement is good until April 2009...

Highlighted

Re: Granular Restore 8.5 not able to open Exchange Mail

I found what was the email used to register the support for the BESR... and I created a new case on mysupport.symantec.com

 

We will see if my problem can be resolved... 

 

 

Highlighted

Re: Granular Restore 8.5 not able to open Exchange Mail

Please reply here after your case has been resolved in order to help other people on the forums who are experiencing the same issue.
Highlighted

Re: Granular Restore 8.5 not able to open Exchange Mail

Hello, 

 

I'm experiencing the same issue. My system volume is C, yet my exchange data is on D. The two volumes create their own backup, yet it's under the same server. How do I get GRO to recognize the Exchange Information File from C and the Storage Group data from D? I need to be able to recover data from an Exchange mailbox on an old date, so starting from scratch isn't the best option. 

 

Going forward, is there a better way to configure the backup?

 

 

Thanks! 

Highlighted

Re: Granular Restore 8.5 not able to open Exchange Mail

I submitted a case for this problem and I don't have any answer yet... I think they are working on the problem...

If you have a support agreement, I encourage you to do the same because when I reported this problem, they told me I was the first one to have this problem...

 

you can submit a case online at mysupport.symantec.com...

to register on this website, you will need you support agreement certificate and you will need to use the email address that is registered for this support agreement.

Highlighted

Re: Granular Restore 8.5 not able to open Exchange Mail

Make sure that the *.Sv2i file use within GRO shows both the C & D volumes of the backup job that is the only way really to have GRO read the Exchange information file and load the storage group stored on D.
Highlighted

Re: Granular Restore 8.5 not able to open Exchange Mail

So both volumes are in the sv2i file, but each volume has its own v2i file. Since each volume has its own v2i file, they're pulling up as different backups in GRO. I need for GRO to be able to see both volumes at once. 

 

I thought I could go into the Files and Folders tab, select both v2i files in Versions, then go to the Exchange Mail tab to pull up both volumes at the same time. When I tried this, GRO only sees the initial volume that I selected, not the additional volume that I selected in the Versions area.

 

Am I doing something wrong here? I need GRO to recognize both v2i files for the two volumes in the sv2i file.   

Highlighted

Re: Granular Restore 8.5 not able to open Exchange Mail

I would register for support, but I'm using the Trial version to evaluate the software. I understand that support is not given to users of the Trial version. 

 

Since this is a primary feature of the software, I can't recommend the purchase of this product if we can't get a granular restore to work properly. In fact, it's making me wonder if the bare metal recovery will work well. Do you have any experience with that for SBESR? 

Highlighted

Re: Granular Restore 8.5 not able to open Exchange Mail


@David F wrote:
Make sure that the *.Sv2i file use within GRO shows both the C & D volumes of the backup job that is the only way really to have GRO read the Exchange information file and load the storage group stored on D.

 

both volumes are in my backup...

GRO 8.0 works fine with my backup... but GRO 8.5 does not with the same backup files...

So I'm sure there is a problem in GRO 8.5...

 

I already submitted a case with Symantec... but as of today, I'm still waiting for a solution...

It seems that I was the first one to report this problem (this is what the support guy told me)...

Next week, if I don't have a response by email, I will call them.

 

 

Highlighted

Re: Granular Restore 8.5 not able to open Exchange Mail

Mario,

 

What version of BESR was used to create the images? What version of BESR is installed on the computer with GRO installed?

Highlighted

Re: Granular Restore 8.5 not able to open Exchange Mail


@Jon_R wrote:

Mario,

 

What version of BESR was used to create the images? What version of BESR is installed on the computer with GRO installed?


 

BESR 8.5.0.28843 on both computers.

GRO 8.5.0.28740 on my backup (console) server.

 

I installed GRO 8.0.x on another computer with BESR 8.5.0.28843 and I can open my exchange backup with this version... I also tried to install GRO 8.5.0.28740 on an other computer with the same BESR 8.5.0.28843 and I got the same problem (not able to open my exchange backup).

 

 

Highlighted

Re: Granular Restore 8.5 not able to open Exchange Mail

If you have not already done so, on your 8.5 version where you are unable to open the Exchange image, be sure to provide the BEER/GRO log files

1. A copy of the customers 'Exchange Information file'. This file will be located in the image on the drive with Exchange on it in the hidden directory 'Backup Information'. The file name is ExchangeBackup.eif; this file should also be located within the image file and if not there is likley the source of the issue.

2. The main BEER/GRO log in C:\Program Files\Symantec\Backup Exec System Recovery\Exchange Retrieve\EdbRestore.exe_run.log

3. Create a directory 'c:\tmp' on the system and then run BEER/GRO, a log file call ExchLog_*.txt will be created in C:\tmp.e the tech assigned to your case the BEER/GRO log files

Please feel free to post from these logs non-sensitive material to for the community to review with you.
Highlighted

Re: Granular Restore 8.5 not able to open Exchange Mail

(By the way, I don't know why, but I'm connected with an other account... my name is Mario Gaucher)

 

for step 2 and 3, there is not such files on my server (checked Exchange and Backup/console servers)...

 

by the way, I'm sure there is a problem with GRO 8.5 because GRO 8.0 works fine with the same backup files.

 

here is the content of the file for step 1 :

 

<?xml version="1.0" encoding="utf-8"?>
<ExchangeInfo xmlns:xsd="http://www.w3.org/2001/XMLSchema" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
<_besrPlatform>Symantec Backup Exec System Recovery Server Edition</_besrPlatform>
<_binaryPath>C:\Program Files\Microsoft\Exchange Server\bin\</_binaryPath>
<_eifVersion>2.0</_eifVersion>
<_exchangeVersion>Version 8.1 (Build 30240.6)</_exchangeVersion>
<_volumeList>
<VolumeInfo>
<_serialNumber>1218968528</_serialNumber>
<_volumeName>\\?\Volume{348c3847-0928-11dc-8e83-806e6f6e6963}\</_volumeName>
<_mountPoints>
<MountPoint>
<_path>C:\</_path>
</MountPoint>
</_mountPoints>
</VolumeInfo>
<VolumeInfo>
<_serialNumber>3027090482</_serialNumber>
<_volumeName>\\?\Volume{348c3849-0928-11dc-8e83-806e6f6e6963}\</_volumeName>
<_mountPoints>
<MountPoint>
<_path>I:\</_path>
</MountPoint>
</_mountPoints>
</VolumeInfo>
<VolumeInfo>
<_serialNumber>1357429754</_serialNumber>
<_volumeName>\\?\Volume{11a1a163-095c-11dc-aaf2-001871749458}\</_volumeName>
<_mountPoints>
<MountPoint>
<_path>N:\</_path>
</MountPoint>
</_mountPoints>
</VolumeInfo>
</_volumeList>
<_storageGroups>
<StorageGroup>
<_caption>First Storage Group</_caption>
<_logPath>I:\Logs\First Storage Group</_logPath>
<_logPrefix>E00</_logPrefix>
<_topLevel>TRUE</_topLevel>
<_messageStores>
<MessageStore>
<_caption>Mailbox Database</_caption>
<_filename>N:\First Storage Group\Mailbox Database.edb</_filename>
<_stmFilename></_stmFilename>
<_topLevel>FALSE</_topLevel>
</MessageStore>
</_messageStores>
</StorageGroup>
<StorageGroup>
<_caption>Internal Users</_caption>
<_logPath>I:\Logs\Internal Users</_logPath>
<_logPrefix>E01</_logPrefix>
<_topLevel>TRUE</_topLevel>
<_messageStores>
<MessageStore>
<_caption>Internal Users</_caption>
<_filename>N:\Internal Users\Internal Users.edb</_filename>
<_stmFilename></_stmFilename>
<_topLevel>FALSE</_topLevel>
</MessageStore>
</_messageStores>
</StorageGroup>
<StorageGroup>
<_caption>Sales East</_caption>
<_logPath>I:\Logs\Sales East</_logPath>
<_logPrefix>E03</_logPrefix>
<_topLevel>TRUE</_topLevel>
<_messageStores>
<MessageStore>
<_caption>Sales East</_caption>
<_filename>N:\Sales East\Sales East.edb</_filename>
<_stmFilename></_stmFilename>
<_topLevel>FALSE</_topLevel>
</MessageStore>
</_messageStores>
</StorageGroup>
<StorageGroup>
<_caption>Sales West</_caption>
<_logPath>I:\Logs\Sales West</_logPath>
<_logPrefix>E04</_logPrefix>
<_topLevel>TRUE</_topLevel>
<_messageStores>
<MessageStore>
<_caption>Sales West</_caption>
<_filename>N:\Sales West\Sales West.edb</_filename>
<_stmFilename></_stmFilename>
<_topLevel>FALSE</_topLevel>
</MessageStore>
</_messageStores>
</StorageGroup>
<StorageGroup>
<_caption>Management</_caption>
<_logPath>I:\Logs\Management</_logPath>
<_logPrefix>E02</_logPrefix>
<_topLevel>TRUE</_topLevel>
<_messageStores>
<MessageStore>
<_caption>Management</_caption>
<_filename>N:\Management\management.edb</_filename>
<_stmFilename></_stmFilename>
<_topLevel>FALSE</_topLevel>
</MessageStore>
</_messageStores>
</StorageGroup>
<StorageGroup>
<_caption>Archives</_caption>
<_logPath>I:\Logs\Archives</_logPath>
<_logPrefix>E05</_logPrefix>
<_topLevel>TRUE</_topLevel>
<_messageStores>
<MessageStore>
<_caption>Archives</_caption>
<_filename>N:\Archives\Archives.edb</_filename>
<_stmFilename></_stmFilename>
<_topLevel>FALSE</_topLevel>
</MessageStore>
</_messageStores>
</StorageGroup>
<StorageGroup>
<_caption>Office</_caption>
<_logPath>I:\Logs\Office</_logPath>
<_logPrefix>E06</_logPrefix>
<_topLevel>TRUE</_topLevel>
<_messageStores>
<MessageStore>
<_caption>Office</_caption>
<_filename>N:\Office\Office.edb</_filename>
<_stmFilename></_stmFilename>
<_topLevel>FALSE</_topLevel>
</MessageStore>
</_messageStores>
</StorageGroup>
</_storageGroups>
</ExchangeInfo>

 


 

 

Message Edited by Conmed Canada on 11-01-2008 04:12 PM
Highlighted

Re: Granular Restore 8.5 not able to open Exchange Mail

Mario do you have the same problme with GRO 8.51?