cancel
Showing results for 
Search instead for 
Did you mean: 
Joeshow
Not applicable
since ‎02-20-2011
‎07-19-2016

User Statistics

  • 1 Posts
  • 0 Solutions
  • 0 Kudos given
  • 0 Kudos received

User Activity

just installed NIS MAC 4.1 and every time i try to update it says there was an error, im running 10.5.8...... any ideas?
About