cancel
Showing results for 
Search instead for 
Did you mean: 

MMS servers show different info for robotic library

moniker131
Level 4

We have 8 MMS servers, and a central admin server. I typcially manage tape inventory via the central admin server by going to storage -> expanding the first MMS server -> select the robotic library. I had some jobs in a queued state, so I went onto a different MMS server, and when I look at the library, the tape information I see is very different. I checked several of these, and they all seem to have different information. I actually have two BE environemnts in two different data centers with different robotic libraries. Both environments exhibit the same behavior. So I'm guessing this is expected? Any explanation?

See the attached screenshots. These are from two different MMS servers, looking at the same slot, same tape label, and same media GUID. However, it shows the tape is in different media sets and on one it is overwrtiable. 

Does BE not automatically keep the MMS servers in sync? Which server, if any, is authoritative on the "correctness" of my tape library?

5 REPLIES 5

moniker131
Level 4

After some more searching on Google, I performed a scan on the library of server B, and now it appears to be in line with server A. I found a few people have asked before (in 2013 and 2015), and automatic inventory/scanning is not something BE does. Is that still the case? Am I suppose to be doing a scan on all my MMS servers after importing new tapes?

Larry_Fine
Moderator
Moderator
   VIP   

Normally I would expect that you should see the same thing on both MMS servers.  It appears that server B is showing stale info.  Is it just a stale GUI that needs F5 to refresh the GUI?  If you run a scan job on the library on server B, does that fix things?

Larry_Fine
Moderator
Moderator
   VIP   

@moniker131 wrote:

After some more searching on Google, I performed a scan on the library of server B, and now it appears to be in line with server A. I found a few people have asked before (in 2013 and 2015), and automatic inventory/scanning is not something BE does. Is that still the case? Am I suppose to be doing a scan on all my MMS servers after importing new tapes?


If you are doing an actual import job, then everything should update automatically.

If you are doing a bulk load (manual operation), then a scan job would be needed for BE to be made aware of the tape changes.

I right click empty slots and click import. Maybe this just updates the information on that particular MMS server?

Larry_Fine
Moderator
Moderator
   VIP   

@moniker131 wrote:

I right click empty slots and click import. Maybe this just updates the information on that particular MMS server?


In my experience, running an import job updates things everywhere.