Database upgrade problem

Hi, 

after using migration wizard to migrate EV from 11.0.1.3474 to 12.4.0.1303 i have a problem with upgrading databases.(log is attached). To cut the story short I am getting 

EnterpriseVaultAudit: Could not be upgraded. Database remains on version'3.2.0.1
.0'. Database upgrade failed because of incompatible database versions.

I tried doing this workaround but it doesn't help

https://vox.veritas.com/t5/Enterprise-Vault/EV12-0-3-EVDatabaseUpgrader-script-fails-on-Audit-DB/td-...

When importing data using wizard I didn't get any DB compatibility warnings. I tried to run Audit_Schema_Upgrade.sql manually but I get the error 

Msg 2812, Level 16, State 62, Line 642
Could not find stored procedure 'Util_DropAllConstraintsOnColumn'.
Msg 5074, Level 16, State 1, Line 644
The object 'DF_AuditTrail_info' is dependent on column 'info'.
Msg 4922, Level 16, State 9, Line 644
ALTER TABLE ALTER COLUMN info failed because one or more objects access this column.

I tried running tAudit_Schema_Upgrade.sql with problematci part commented but id doesnt work.

Any help would be greately appreciated

 

 

1 Solution

Accepted Solutions
Highlighted
Accepted Solution!

Re: Database upgrade problem

The problem is that you're trying to upgrade from EV 11.0.1 straight to EV 12.4.2.

Your log shows:

Enterprise Vault directory. The database needs to be upgraded from '11.48.0.160.0' to '12.132.8.249.3'.

11.48.0.160.0 is the schema version of the Directory DB for EV 11.0.1 with no CHFs.

12.132.8.249.3 is the schema version of the Directory DB for EV 12.4.2.

(https://www.veritas.com/content/support/en_US/article.100020901)

You cannot upgrade to a maintenance release (i.e., a triple-dot release like 12.4.2) from a previous minor version (i.e., double-dot release like 12.3). You can only reach 12.4.2 after you have already reached 12.4.

In your case, you should reinstall the binaries from the EV 12.4 full installation media, then run the Start-EVDatabaseUpgrade cmdlet to upgrade the databases to the 12.4.0 versions (Directory schema 12.132.8.249.0). Once this is complete, then reinstall the EV 12.4.2 binaries and run the Start-EVDatabaseUpgrade cmdlet again to upgrade from 12.4.0 to 12.4.2 (Directory schema 12.132.8.249.3). This is a supported upgrade path and should meet with more success.

Good luck!

--Chris

View solution in original post

3 Replies
Highlighted

Re: Database upgrade problem

make sure you don't have any connections open in sql. Query = sp_who

OR Query = sp_who2

Highlighted
Accepted Solution!

Re: Database upgrade problem

The problem is that you're trying to upgrade from EV 11.0.1 straight to EV 12.4.2.

Your log shows:

Enterprise Vault directory. The database needs to be upgraded from '11.48.0.160.0' to '12.132.8.249.3'.

11.48.0.160.0 is the schema version of the Directory DB for EV 11.0.1 with no CHFs.

12.132.8.249.3 is the schema version of the Directory DB for EV 12.4.2.

(https://www.veritas.com/content/support/en_US/article.100020901)

You cannot upgrade to a maintenance release (i.e., a triple-dot release like 12.4.2) from a previous minor version (i.e., double-dot release like 12.3). You can only reach 12.4.2 after you have already reached 12.4.

In your case, you should reinstall the binaries from the EV 12.4 full installation media, then run the Start-EVDatabaseUpgrade cmdlet to upgrade the databases to the 12.4.0 versions (Directory schema 12.132.8.249.0). Once this is complete, then reinstall the EV 12.4.2 binaries and run the Start-EVDatabaseUpgrade cmdlet again to upgrade from 12.4.0 to 12.4.2 (Directory schema 12.132.8.249.3). This is a supported upgrade path and should meet with more success.

Good luck!

--Chris

View solution in original post

Highlighted

Re: Database upgrade problem

Hi Chris, 

 

thank you, that did the trick.

 

Regards,