Forum Discussion

dorlow615's avatar
Level 4
7 years ago

Cannot force vault mailbox

I'm stumped over a mailbox vault again.  I have a user that somehow got a 120 GB mailbox.  I have to get it vaulted.  I've tried to force vault it many times and nothing.  Their vault store is empty.  I've disabled/re-enabled them for vault.  I disabled, deleted the vault store, re-enabled.  Changed where the vault store is at.  Zapped the archive and mailbox.  Deleted the mapi profiles for the server.  

In the dtrace, I do see some errors like this...

ProcessNextMessage() |ActivateObject has returned failure


Goggled the error.  States to make sure the service account for the task isn't hidden or disabled.  It's not.  The mailbox was just moved to a different database last week which should've gotten rid of corruption in the mailbox.  I've restarted the server.  


When I run this sql command, I get no results.


select * from VaultStoreEntry where VaultStoreEntryId = '1E174C048BCECD94BB48273648BF79B5A1110000EVSARCHIVE01'


I should get results (this is her EV archive ID.)





16 Replies

  • Hi dorlow,

       Really tough to say, based on just that one line.  Usually here in support we'll hone in on a thread in a dtrace and read several lines above to see where it goes wrong.  So since I'm a little blind here, I'll just throw out some of the easier points to rule in/out:


    -Do you know for sure the task works? As in, have you successfully archived any other mailboxes with it?  You mentioned a vault store is empty, so maybe if you archived a mailbox in another vault store with that task previously, did it work?

    -Are you sure that what the mailbox is full of is items that your Site settings and policy settings are configured to archive?  Meaning:  Do they have a bunch of attachments larger than your max attachment size limit? Are they mostly calendar items when you don't archive calendar items, etc?

    -Might be worth creating a new system mailbox all together, since you mentioned that it was moved.  It's easy enough to do, and there's nothing special about the mailbox that you need to set; just give the VSA full permission and send as permission.

    -Nothing stuck in the msmq's, you have an open partition, you're not in backup mode?

    -When you do a "Run now" archiving run against that mailbox, do you get the start and stop events for it? I think 3442 and 3448 (or 3446 if finished with warnings) are the ones to look for, though that's just off the top of my head.

    -Other than that, I'd suggest providing more of the dtrace.  The things I mentioned are all low hanging fruit; and likely it would be more complex.  But this is a good starting point to rule out.

      • dorlow615's avatar
        Level 4

        I've been able to get some things to go to the vault.  I've opened up Outlook on the server as the user and can select the button to move emails to vault.  That works.  The archive task doesn't work for the user.  msmq queues are empty.