Forum Discussion

Marcrp's avatar
Level 5
6 years ago

Storage Delete - Failing


As of a few days ago we are getting the following error:


Failed to delete archive 'Robyn Smith' because the Indexing Service on could not be contacted.

Check that the Indexing Service is started and has completed any pending initializations, and restart the Storage Service on to resume the deletion of the archive.

Reason: Class not registered (0x80040154)
Archive: Robyn Smith
Vault Store: Vault Store
Archive Id: 18716B141C7DEF64F81584ABAAAF65FAA1110000vault

For more information, see Help and Support Center at

In the EV Admin there are about 12 archives that have been set to delete but they haven't been removed. The error above is saying why it's failing. I'm not sure what 'class' is not registered?

We are running EV 12.4

Any help appreciated.


  • Hi Marc,

    Ofcourse... Reinstall

    If I recall correct, you're on 12.4, so no additional hotfixes/SP's. Install Binaries, fingers crossed.

7 Replies

  • Hello Marc,

    I assume you have restarted the indexing and storage service as indicated. Did they both start without issues? I have seen this error on EV servers where the EV Client was also installed, then uninstalled. Could that be the case in your situation?

    I assume your settings in EV do allow for deletion of archives (retention policies, and in general).

    You might want to run a dtrace on the StorageDelete, but verifying the logfile is a lenghty job. Look for the errorcode, and then a go up in the trace. There should be something indicating what is being looked for, and what fails.

    • Marcrp's avatar
      Level 5

      Thanks for the reply.

      I can confirm I've tried restarting the indexing and storage service and they started without issues. The client has never been installed and I've double checked this. Yes we do allow for deletion of archives. It was working up until about 1 week ago.

      I ran the dtrace and went through the log and it didn't reveal any more than the initial error in the event log - class not registered. I have also noticed that none of the Tasks within VAC are running with the exception of Exchange Mailbox Archiving Task. The others just show Error. I've tried restarting the server but no help.

      I do have a case open with Veritas but we are only on basic support so thought I'd try here for any ideas in the meantime.


      • GertjanA's avatar

        Hm.. strange. So also tasks are not running. Weird. I'll try the below:

        Logon as VSA, rightclick "Directory on xxx", properties, Service Account. Change password (just re-enter the existing password), Apply, OK, restart the services.

        Check what that does.

        If that failes, I would do a re-install of the binaries, so everything is re-initialized.