Forum Discussion

Goran_Jovanovic's avatar
19 years ago

Problem starting serivces


I have just taken over a server and BE for Windows 9.1 was installe don it. They have not had a backup since Jun 2004 because (many reasons).

This is all installed on a Windows Server 2003 (no SPs) running as a standalone server without AD. All userids are local userids.

When I tried to start the services I found that the userid Administrator was changed to director and nothing would start. Well that is easy to fix. Tried agian with the new "admin" userid and now I am getting Device and Media service could not start because "Error 1065 The database specified does not exist".

We I decided to de-install 9.1 and re-install it from scratch since I really did not know what state it was installed in. After all that I ended up with the smae problem. I followed document id 274102 and detached and reattached a new BEDB. Same problem.

Note the MSSQL$BKUPEXEC service starts just fine under the Local System id. I even changed this service to start with the same IP as Device and Media service. No go.

I followed doc id 267799 and got the MDAC checker and found that I have right version of files (or later).

So I am at a loss what is next? can anyone help me out here please.


6 Replies

  • You might check the rights the user has which is used to start the services via the local policies. To start a service a user needs to be given this right.

    Just my E0.02

    A van der Boom
  • Hi,

    The userid must have appropriate rights as other services start properly. It is the BE Device and Media service that cannot start because the "file" is not present.
  • Hello,

    Were there any other changes made on the server? Do the other services start well? Try creating a new account with administrator privileges and use this account for all the services except the remote agent service which should run under the local system account.

    If the issue persists, run a database repair as per the technote below:

    Title: How to run a Backup Exec database repair when the original Backup Exec database is found to be inconsistent

    Revert if the problem persists.

    Note : If we do not receive your reply within two business days, this post would be marked ‘assumed answered’ and would be moved to ‘answered questions’ pool.

  • Hi Priya,

    I created a brand new userid and made it a member of the local Administrators group. Changed the Device and Media Service to use it and tried to start the service. The userid was granted Logon as a service rights and the service did not start. Got the same error "Error 1065: The database specified does not exist.

    I tried the BEUtility (as per 265180) but it can not see the media servers since the Device and Media Service is not running.

    Any other thoughts?

  • Hello,

    Have you changed the name of the BackupExec media server?

    NOTE : If we do not receive your reply within two business days, this post would be marked assumed answered and would be moved to answered questions pool.
  • No the server name did not change. What it turned out to be is that there was some sort of corruption in Windows itself. I was unable to apply SP1 to the server. I had to do an inplace upgrade, then apply SP1 and then BAckup Exec had no problems whatsoever.