Forum Discussion

Hans05's avatar
Level 4
9 years ago

Off to a bad start with System Recovery 2013 R2 SP4

I was glad to see the long awaited System Recovery 2013 R2 SP4 version out today so I downloaded it and thought I'd get right to testing it on my first system.

Unfortunatly, I cannot even install the product.

I'm trying to install on a system with the following characteristics:


Intel Core i7 Processor


Boot Drive is a 500GB SSD

OS is Windows 10 with the November 2015 update, 64-Bit


I launch the install by running "browser.exe". I get the initial welcome screen with the various elements such as Getting Started, Installation, etc. At this point I click on "Install Now". At this point a screen opens that says "Loading the install. Please wait..." but within about 2 seconds the screen disappears and nothing more happens. Note that there is no error message, the program just seems to go away completely and the "Setup Launcher" disappears from the task list if I'm monitoring it while I attempt the install.

As a test, I tried the install on a Windows 7 system and it worked perfectly.

Is this possibly a problem with the November Update to Windows 10? I sure hope that we don't have to wait for another update that supports the November Update :-)

Anyone else having any better luck than me?







  • Hans05,

    What is your case number?

    I would suggest you take a look in the Windows event logs (system/application) at the time of trying the install. I suspect something is crashing causing the install to fail.

47 Replies