NetBackup 8.1 VMware - snapshot fails for invalid characters in path

I upgraded my test domain to version 8.1 last week and have been testing. During my tests with VMware (ESXi 5.5 environment), the jobs were constantly failing with error 4277: Virtual machine path contains unsupported characters

 

2017 6:58:28 PM - Info bpbrm (pid=13144) INF - vmwareLogger:  Creating snapshot for vCenter server VCENTER.FQDN, ESX host ESX-HOST.FQDN, BIOS UUID 42060caf-2365-be65-2c86-a545dfd0bb93, Instance UUID 5006cb26-5138-26d9-b173-04dc04fa1614, Display Name RHEL6-v7, Hostname RHEL6-CLIENT.FQDN 
24-Nov-2017 6:58:28 PM - Critical bpbrm (pid=13144) from client RHEL6-CLIENT.FQDN: FTL - vSphere_freeze: File path contains unsupported characters ([datastore_label_10:12] RHEL6-v7/RHEL6-v7.vmdk).
24-Nov-2017 6:58:38 PM - Critical bpbrm (pid=13144) from client RHEL6-CLIENT.FQDN: FTL - vfm_freeze: method: VMware_v2, type: FIM, function: VMware_v2_freeze

NB: The 10:12 at the tail end is a reminder for VM admins for know which SAN LUN is being used.

Partial detailed status is copied above. After checking other things, I renamed the datastore lable from "datastore_label_10:12" to "datastore_label:1012", and tried a backup again. The backup was successful. This behaviour is in accordance to VMware requirements (invalid characters list).

However, backup for the same VM using NetBackup 8.0 (and earlier 7.7.3) works fine even with the colon existing in datastore path.

So, how do I understand this behaviour:

  • New bug in NetBackup 8.1?
  • Bug fixed in NetBackup 8.1? (so that it conforms to VMware requirements)

PS: Spent 3+ hours with Veritas support on Friday with no help at all!

 

Tags (2)
1 Solution

Accepted Solutions
Accepted Solution!

Re: NetBackup 8.1 VMware - snapshot fails for invalid characters in path

Ask your VERITAS support Engineering about Etrack 3931817.

View solution in original post

4 Replies
Accepted Solution!

Re: NetBackup 8.1 VMware - snapshot fails for invalid characters in path

Ask your VERITAS support Engineering about Etrack 3931817.

View solution in original post

Re: NetBackup 8.1 VMware - snapshot fails for invalid characters in path

Thanks @eduncan I have replied to the case email to Veritas support as the link from the support site is being redirected to "Connect with the Veritas community and discover the truth in information at Vision 2017" !!

Update: The EEB fixed the issue. Not sure how long more I would have stayed on the phone with support if @eduncan didn't give the information! Thanks again.

Re: NetBackup 8.1 VMware - snapshot fails for invalid characters in path

FWIW, Mr. Duncan is Veritas Support (backline), so Support actually did answer your question. In defense of your front-line agent, this was a new issue.

Others from Support have posted answers here, and I am in a related engineering position. Vox doesn't substitute for your support agent, but it enriches the conversation.

Re: NetBackup 8.1 VMware - snapshot fails for invalid characters in path

I fully understand the difference between a support contract and online community support/knowledge sharing. That is the very reason I opened the case with Veritas support initially.

The post on Vox was out of helplessness when I clearly saw that there was absolutely no progress in the case after a 4 hour call. I also understand that support cannot be expected to know all issues at all times, and I have had long sessions with support and worked with them to resolve issues earlier. But this time the experience was disappointing to say the least. I hope this was just an anomaly or one-off.