cancel
Showing results for 
Search instead for 
Did you mean: 

Vxlogcfg for unified logs

Hamza_H
Moderator
Moderator
   VIP   

Hello VoXers,

I am curious about a 'bug' that we have using vxlogcfg command to set or disable logging for ALL oids.

when we use the below command, it won't modify the debuglevel to the desired level, the command passes ( no error) but it doesn't return the expected output as : The configuration settings were added successfully.

 

[root@master1~]# vxlogcfg -a -p 51216 -o 117 -s DebugLevel=1
The configuration settings were added successfully.
[root@master1~]# vxlogcfg -a -p 51216 -o ALL -s DebugLevel=1
[root@master1~]#

and we can see through nblog.file that the debuglevel didn't change for all OID as it should be, it only changes it for the Default.DebugLevel:

[root@master1~]# cat /usr/openv/netbackup/nblog.conf | grep -i debug
Default.DebugLevel=1
# VxUL performs the correct mapping from ALL to DebugLevel
111.DebugLevel=1
117.DebugLevel=1
137.DebugLevel=1
156.DebugLevel=1
222.DebugLevel=1
486.DebugLevel=1
512.DebugLevel=0
[root@master1~]# vxlogcfg -a -p 51216 -o ALL -s DebugLevel=6
[root@master1~]# cat /usr/openv/netbackup/nblog.conf | grep -i debug
Default.DebugLevel=6
# VxUL performs the correct mapping from ALL to DebugLevel
111.DebugLevel=1
117.DebugLevel=1
137.DebugLevel=1
156.DebugLevel=1
222.DebugLevel=1
486.DebugLevel=1
512.DebugLevel=0
[root@master1 ~]#

 

I have tried this for other versions too : 8.0, 8.2 & 8.3.0.1 on Linux & Windows.

I couldn't find any vox/article regarding this, has anyone faced this problem before? is Veritas aware of this bug?

Personnally I don't use the -o ALL, I always put the desired OID but I think a lot of people use ALL and maybe they don't check nblog.conf to confirm that the change has been taken into account or not and it may cause disk space issues on big infrastructures.

 

Thanks,

Kind regard | Hamza

 

Thanks !

 

 

4 REPLIES 4

Nbu_user911
Level 2

What levels are set in the console? 

 

Nbu_user911_0-1646752463689.png

 

 

 

Hamza_H
Moderator
Moderator
   VIP   

Hello, 

They are at minimum, but this is not the point here.

The bug is in the vxlogcfg command..

also, in this screen, only legacy logs, nbpem,nbjm & nbrb logs are concerned, the command doesn't work for these logs & other logs as well.

 

Hamza_H
Moderator
Moderator
   VIP   

Hello, any comments please? does anyone has the same problem?

NurgulG
Level 2

Hi,

I am always using Default or OID, Could you try please? Hopely help to you.

Disable logging for all daemons --> vxlogcfg -a -p 51216 -o Default -s DebugLevel=0 -s DiagnosticLevel=0

Display the default settings --> vxlogcfg -p 51216 -o Default -l  

Best Regards