cancel
Showing results for 
Search instead for 
Did you mean: 

DB2 Archive Backup Not running after upgrading the Client to NetBackup 10

prasannad
Level 3
Partner

After upgrading the NetBackup client to NetBackup 10 Vendor method is not working for archive backup. We have upgrade the client from NetBackup 8.1.1 to 10. Only one node is upgraded. Still archive backups get success in node 2. In node one Archive backup not starts. Vendor method is configured for the LOGARCHMETH2. Please check the following output for the configured archive methods and status.

$ db2 get db cfg for xmndb | grep -i logarc
 First log archive method                 (LOGARCHMETH1) = DISK:/dbarchfs/ARCH_LOGS/
 Archive compression for logarchmeth1    (LOGARCHCOMPR1) = OFF
 Options for logarchmeth1                  (LOGARCHOPT1) = 
 Second log archive method                (LOGARCHMETH2) = VENDOR:/usr/openv/netbackup/bin/nbdb2.sl64
 Archive compression for logarchmeth2    (LOGARCHCOMPR2) = OFF
 Options for logarchmeth2                  (LOGARCHOPT2) = 
$ db2pd -logs -db XMNDB
Database Member 0 -- Database XMNDB -- Active -- Up 386 days 04:28:00 -- Date 2022-06-22-18.09.06.272877

Logs:
Current Log Number            197201    
Pages Written                 135447    
Cur Commit Disk Log Reads     1                   
Cur Commit Total Log Reads    3                   
Method 1 Archive Status       Success
Method 1 Next Log to Archive  197201    
Method 1 First Failure        n/a
Method 2 Archive Status       Failure
Method 2 Next Log to Archive  197201    
Method 2 First Failure        197099    
Log Chain ID                  1         
Current LSO                   201380592994029     
Current LSN                   0x0000003488E917A2

Address            StartLSN         StartLSO             State      Size       Pages      Filename
0x0A000401352DEDA0 0000003488D87D5D 201380040909505      0x00000000 262144     262144     S0197201.LOG
0x0A000401348FCA00 0000000000000000 201381109408449      0x00000000 262144     262144     S0197202.LOG
0x0A00040134396360 0000000000000000 201382177907393      0x00000000 262144     262144     S0197203.LOG
0x0A000401348FADE0 0000000000000000 201383246406337      0x00000000 262144     262144     S0197204.LOG
0x0A0004013439CCC0 0000000000000000 201384314905281      0x00000000 262144     262144     S0197205.LOG
0x0A00040134900000 0000000000000000 201385383404225      0x00000000 262144     262144     S0197206.LOG
0x0A000401352EA360 0000000000000000 201386451903169      0x00000000 262144     262144     S0197207.LOG
0x0A000401352E92C0 0000000000000000 2013875204

 

5 REPLIES 5

Laurence_Merry
Level 4

Are you positive the upgrade was the cause?

Last week I upgraded a client from 8.2 to 9.1.0.1 and the DB administrator claimed the upgrade was the cause of the archiving stopping. Meanwhile, the logs stopped 20 minutes prior to my upgrade. In my case, there wasn't anything wrong with Netbackup. All configuration was correct and unchanged but after he stopped and started the DB (due to planned work) the archiving started working again.

Thank you for your reply. We requested a downtime to bounce the DBs. Will let you know if it work.

Nicolai
Moderator
Moderator
Partner    VIP   

Create UNIX: /usr/openv/netbackup/logs/bpdb2

make sure db2 can write in the area, no restart of services is required. The log files will tell what happens from the Netbackup side.

See also: https://www.veritas.com/support/en_US/doc/16222484-130877214-0/v15490727-130877214

Bouncing DBs did not resolved the issue.

Then as Nicolai mentioned, get the bpdb2 logs.