Highlighted

Unable to NFS mount the required file system

Hello All,

We are facing a big problem with an Active directory backup on WS2008 R2 & WS2012 R2 servers.

The system state (SCC) is not backed up, so there is no AD backup :

 

error : Unable to NFS mount the required file system

The media server is on Linux and we have other active directory servers for which the backup is successful on the same media server.

The two servers are in a DMZ, the ports 111 and 7394 are wide open (bidirectionally) and all the connection test commands are successful.

The GRT prerequisites are all configured (Netbackup services are running with a domain user with all privileged permissions), Backup selection "Shadow Copy Components" .

 

I have tested the NFS think through the famous TN : https://www.veritas.com/content/support/en_US/article.100000686

and the result is :

      • error: aborting connection, timeout period exceeded EXIT_STATUS=41

It worked once after multiple retries, and I checked the mount point with net use command and it was on Z:\ and I unmounted it and tried to mount it again, no luck.

I have reinstalled the NFS services on the client (ws2008R2) and still same issue.

server for nfs is disabled (stopped as well) and client for nfs is running.

when the "nbfs mount" exists with code 41, I see error logs on Application events : 

Event ID 16397:

      • Windows(R) Lightweight Directory Access Protocol (LDAP) failed a request to connect to Active Directory Domain Services(R) for Windows user <domain\username>.
      • Without the corresponding UNIX identity of the Windows user, the user cannot access Network File System (NFS) shared resources.
      • Verify that the Windows user is in Active Directory Domain Services and has access permissions

I checked really everywhere, but no luck..

I have tried this TN as well (even if its not the same error in the nbfsd logs):

https://www.veritas.com/support/en_US/article.100044671

note : the command descrived on the TN to confirm that its not Netbackup error didn't work for me , code 53 :

the network path was not found

C:\>mount -o timeout=10 Media_Server:/NBUFS_A_D9CA4EC2395B381B_000 Z: 

The network path was not found

For NBFSD logs I have these errors (which I can't find on the net Smiley Sad _nbfs_connect: WNetAddConnection2() failed, error = 53 )

11:01:49.938 [4728.6452] <2> logparams: nbfs mount -server mediasrvbkp -cred F5BFE4B31691EE1419BE34F2AA0A82C47C714BE6CA75C5C4BB9A80D909E7E780DCDFEB8C292F9277E0B8251798F42C59CF7FDBD13B262B90CB6453FE6E86D2DE Z:
11:01:49.969 [4728.6452] <2> rpc_connect: connecting to mediasrvbkp
11:01:49.969 [4728.6452] <2> rpc_connect: connection established to mediasrvbkp
11:01:49.985 [4728.6452] <2> nbfsd_op: making call 3915 ( cl 128, xagrs= /12,winver=6,1,2/31,acp=1252,1252 (ANSI - Latin I)/12,host=DMZ-DC1/5,mp=Z: )
11:01:50.203 [4728.6452] <2> nbfsd_op: completed call 3915 - 0 /NBUFS_A_CCB7D2169D728C25_000
11:01:50.203 [4728.6452] <2> nbfs main: mount -o mtype=soft-o timeout=60 -o retry=1 mediasrvbkp:/NBUFS_A_CCB7D2169D728C25_000 Z:
11:01:50.203 [4728.6452] <2> _nbfs_mount_info_check: last access information does not exist, setting it
11:01:50.219 [4728.6452] <8> _nbfs_mount_info_get_name: WNetOpenEnum() failed, error = 50
11:01:50.219 [4728.6452] <8> _nbfs_mount_info_set: unable to determine last export name
11:01:50.219 [4728.6452] <2> _nbfs_connect: adding connection for mediasrvbkp:/NBUFS_A_CCB7D2169D728C25_000
11:02:32.308 [4728.6452] <16> _nbfs_connect: WNetAddConnection2() failed, error = 53
11:02:33.322 [4728.6452] <16> _nbfs_connect: WNetAddConnection2() failed, error = 53
11:03:16.410 [4728.6452] <16> _nbfs_connect: WNetAddConnection2() failed, error = 53
11:03:16.410 [4728.6452] <16> _nbfs_connect: aborting connection, timeout period exceeded
11:03:16.410 [4728.6452] <2> nbfsd_op: making call 3916 ( cl 128, xagrs= )
11:03:16.488 [4728.6452] <2> nbfsd_op: completed call 3916 - 0

 

Both Master and Media server are on 8.X version, client is on 7.6.1 , do you think upgrading to 7.7.3 would fix the problem?

 

Thanks !

 

BR

8 Replies

Re: Unable to NFS mount the required file system

any reply, please?

Re: Unable to NFS mount the required file system

edit - sorry - posted wrong page

Re: Unable to NFS mount the required file system


@hha_mea wrote:

 

Both Master and Media server are on 8.X version, client is on 7.6.1 , do you think upgrading to 7.7.3 would fix the problem?

Thanks !

Even 7.7.3 is no longer supported.

Please upgrade the client to 8.x version.

If the backup is still failing after the upgrade, you can ask Veritas Support for assistance. 

Re: Unable to NFS mount the required file system

Hi @Marianne ,

Thanks for your reply, 

I know that the 7.7.X isn't supported anymore, I am just wondering if the upgrade to a later version would resolve this issue, we don't want to upgrade to v8.X because we don't want to get into certificates topics.. besides we have other servers with same version 7.6.1 for which backups are working.. I am just worndering if anyone has these errors before error 53"

And of course if get to upgrade it to 8.X we will contact veritas support.

 

Thanks !

BR.

Re: Unable to NFS mount the required file system

@sdo no problem Smiley Happy

Re: Unable to NFS mount the required file system

Please consider upgrading to 8.0 or 8.1 - it does not use cerificates and is supported by Veritas.

There is no guarantee that the upgrade will solve the problem, but you will be able to log a Support call with Veritas.

Re: Unable to NFS mount the required file system

Hi @Marianne , The upgrade is in progress.

unless mistaken, strating of 8.1, the certificate is used, no?

thanks,

BR

Re: Unable to NFS mount the required file system

Yes you are 100% correct. (I thought for a moment it was 8.1.1).

Then please upgrade the client to 8.0. 
We know this version is pre-secure-comms and is supported by Veritas.