cancel
Showing results for 
Search instead for 
Did you mean: 

Enterprise Vault Journal Archiving is very slow

Dear Team,

Suddenly Exchaneg journa archiving became very slow. I already tried below steps after cheking the attached dtrace logs , but its not working

1. Increased MSMQ storage limits

2. Deleted and recreated the journal task

3. Removed and added the traget

4. Moved journal Mailbox to another Exchange servers

5. Moved Journal Task to another EV server

6. Removed the EV cached profiles and restarted the server

7. Added exception in antivirus for MSMQ location

8. Reinstalled MSMQ

 

Below error I am getting in Dtrace, it seems MSMQ process pauses and restarts again

94 15:10:35.446 [13132] (JournalTask) <18088> EV~I :CArchivingAgent:Smiley TonguerocessUser() |Archive/Journal Task ignored a Process Mailbox Message because the Process Mailbox mutex was locked and the mailbox is being processed by another thread |

731 15:11:15.290 [13132] (JournalTask) <4832> EV:L {CQueue:Smiley Surprisedpen} (Exit) Status: [There is a sharing violation. The queue is already open for exclusive retrieval. (0xc00e0009) (anticipated err may not indicate an issue)]
732 15:11:15.290 [13132] (JournalTask) <4832> EV~I The queue .\private$\Enterprise Vault Archive Agent Admin Queue is already open.|It is likely that another process is running and will be processing the Nack messages placed on this queue.|This Nack Handler will now terminate, as it is redundant. No additional action is necessary. |

1 Solution

Accepted Solutions
Highlighted
Accepted Solution!

Re: Enterprise Vault Journal Archiving is very slow

Hi, 

This can also happen if the Vault store JournalArchive table has gotten too large and/or is heavily fragmented.  I would check the number of items in that table and the fragmentation level.  If the table is larger than 8-10 million items it could cause archiving issues.  

Regards,

Patrick 

View solution in original post

3 Replies
Highlighted

Re: Enterprise Vault Journal Archiving is very slow

Hello,

This kind of thing is mind-breaking, and hard to troubleshoot.

First, have a look at this link. It gives you the advised AntiVirus exclusions to use for EV. That might give you one you possibly forgot (or did not know).

As last resort, you can also create a new Journal Mailbox in Exchange. Define that in EV also (I assume you know what to do, based on the steps you outline what has been done already). I do advise to create a new task to archive the new Journal Mailbox, so you have 2 tasks. When all is configured, change the journal rule in Exchange to switch to using the new Journal Mailbox. Verify items arrive in the mailbox, and items are archived.

This gives the old task the opportunity to archive the old JournalMailbox, without it getting new items. It might be there is an item which is blocking the archiving process. Stop the old Archiving task. Connect to the old Journal Mailbox, sort on received date. Check that oldest date, and the item. It might be that item is 'pending archiving', so you might need to revert that. You can do that by editing the Journal Policy, Pending Shortcut Timeout. Set to 0. Set the old task in report more, sync the old Journal Mailbox, start task. after a while, the pending items should have been converted to normal items again. When so, stop the task, clear report mode. Open Journal Mailbox, and move the oldest items to a seperate folder. When done, start the task, check the archiving of items. eventually the mailbox will empty out. at that time, you can move the olditems into inbox again, and see if they archive.

That might assist in getting the old Journal Mailbox archived.

Regards. Gertjan
Highlighted

Re: Enterprise Vault Journal Archiving is very slow

Sounds like your Anti Virus software is scanning the EVstorage queue location and running into a file lock issue. You should ensure you configure your AV exclusions per  https://www.veritas.com/support/en_US/article.100017720?profileURL=https%3A%2F%2Fvam-profile.veritas...

 

 

Highlighted
Accepted Solution!

Re: Enterprise Vault Journal Archiving is very slow

Hi, 

This can also happen if the Vault store JournalArchive table has gotten too large and/or is heavily fragmented.  I would check the number of items in that table and the fragmentation level.  If the table is larger than 8-10 million items it could cause archiving issues.  

Regards,

Patrick 

View solution in original post