cancel
Showing results for 
Search instead for 
Did you mean: 

REplication completed but import is not started

Hello Team,

Replication job completed but import is not starting.

bash-3.2$ sudo ././nbstlutil stlilist -lifecycle XXXXXXXXXXXXXXX-IMPORT-SLP -image_incomplete -U
Image XXXXXXXXXXXXX for Lifecycle XXXXXXXXXXXXXX-IMPORT-SLP is IN_PROCESS
Copy to XXXXXXXXXXXXXXXX-MSDP-IMPORT-STU of type IMPORT is NOT_STARTED

Can anyone help here, how to troubleshoot the import issue?

Tags (2)
9 Replies

Re: REplication completed but import is not started

Hello Team,

1. How to check on target master if the import is completed for the problematic images, if not we have to fix the import issue on target.?

2.  How to check If the import is completed but only confirmation is not sent back ??

Regards,

 

Re: REplication completed but import is not started

Hello,

More information:

Run this command: ./nbstlutil -pendimplist -U

Image:
Master Server : XXXX-bkup
Backup ID : XXXX_XXXXX
Client : XXXXX
Backup Time : 1530696682 (2018/07/04 19:31:22)
Policy : (none specified)
Client Type : 0
Schedule Type : 0
Storage Lifecycle Policy : XXXXX-XXXXXX-IMPORT-SLP
Storage Lifecycle State : 2 (IN_PROCESS)
Storage Lifecycle Is Inactive : false
Time In Process : 1606452902 (2020/11/27 15:55:02)
Data Classification ID : (none specified)
Version Number : 0
OriginMasterServer : XXXXXX-XXXXXX
OriginMasterServerID : {00000000-0000-0000-0000-000000000000}
Import From Replica Time : 0 (0 secs)
Required Expiration Date : 0 (0 secs)
Created Date Time : 1606452884 (2020/11/27 15:54:44)

Copy:
Master Server : XXXXX-XXXXX
Backup ID : XXXX_XXXXX
Copy Number : 1
Copy Type : 4 (IMPORT)
Expire Time : 0 (0 secs)
Expire LC Time : 0 (0 secs)
Try To Keep Time : 0 (0 secs)
Residence : XXXXXXX-IMPORT-STU
Copy State : 1 (NOT_STARTED)
Job ID : 0
Retention Type : 3 (REMOTE_EXPIRATION_DATE)
MPX State : 0 (false)
RetryCount : 0
Last Retry Time : 0 (0 secs)
Source : 0
Destination ID : (none specified)
Replica: : 0
DataFormat : 0 (DF_UNDEFINED)
SLP Index : 1

Fragment:
Master Server : XXXX-XXXX
Backup ID : XXXXXX-XXXXXX
Copy Number : 1
Fragment Number : -2147482648
Resume Count : 0
Media ID : @aaabX
Media Server : XXXXXX
Storage Server : (none specified)
Media Type : 0 (DISK)
Media Sub-Type : 0 (DEFAULT)
Fragment State : 1 (ACTIVE)
Fragment Size : 0
Delete Header : 0
Fragment ID : XXXXXXXXXXXX
Snap MountHost : (none specified)
Media Description : XXXXXXXX

Re: REplication completed but import is not started

Is there a time difference between the masters?

Extract from the Dedupe Guide: https://www.veritas.com/support/en_US/doc/25074086-127355784-0/AIR-127355784

Synchronize the clocks of the master servers in the source and the target domains so that the master server in the target domain can import the images as soon as they are ready. The master server in the target domain cannot import an image until the image creation time is reached. Time zone differences are not a factor because the images use Coordinated Universal Time (UTC).

Re: REplication completed but import is not started

Hello Marianne,

For Date and time, they are synchronized between the masters... ANy more things that we can check for this issue

what does it means Storage Lifecycle State : 2 (IN_PROCESS)?

Image:
Master Server : XXXXX-XXXXX
Backup ID : XXXX_XXXX
Backup Time : 1530696682 (2018/07/04 19:31:22)
Policy : (none specified)
Client Type : 0
Schedule Type : 0
Storage Lifecycle Policy : XXXXXXX-XXXXXXIMPORT-SLP
Storage Lifecycle State : 2 (IN_PROCESS)
Storage Lifecycle Is Inactive : false
Time In Process : 1606452902 (2020/11/27 15:55:02)
Data Classification ID : (none specified)
Version Number : 0
OriginMasterServer : XXXXXXXX-XXXXXXXXX
OriginMasterServerID : {00000000-0000-0000-0000-000000000000}
Import From Replica Time : 0 (0 secs)
Required Expiration Date : 0 (0 secs)
Created Date Time : 1606452884 (2020/11/27 15:54:44)

 

Re: REplication completed but import is not started

@Dav1234 

Something does not look right - was this backup really taken more than 2 years ago?

Backup Time : 1530696682 (2018/07/04 19:31:22)

Or incorrect date/time on source master?

Re: REplication completed but import is not started

Hello Marianne,

Yes, this backup was happened 2 years back. \

Actually, this backup was replicated to target side for long term retention. And as per restore request, we will reverse replicated data to source side.

So this image is reverse replicated from target to source side. But reverse replication job completed successfully and import still not started.

Regards,

Re: REplication completed but import is not started

Hello Marianne,

Image:
Master Server :XXXX-XXXX
Backup ID : XXXX-XXXXX
Client : apsddov01
Backup Time : 1530696682 (2018/07/04 19:31:22)
Policy : (none specified)
Client Type : 0
Schedule Type : 0
Storage Lifecycle Policy : XXXXX-XXXXXX-IMPORT-SLP
Storage Lifecycle State : 2 (IN_PROCESS)  : Why it is showing in progress because Import job is not started yet??

Re: REplication completed but import is not started

@Dav1234 

I am trying to find out from you if this is really a backup from over 2 years ago:
2018/07/04 19:31:22

If so, it means that something already went wrong 2 years+ ago.
Trying to troubleshoot what went wrong when this image was replicated 2 years ago and did not import will be almost impossible.

You could try to look in nbtserv log to see if you can find anything related to image apsddov01_1530696682.

Is this image still valid, unexpired on the source?

Re: REplication completed but import is not started

Thank you Marianne for your help!!

We have openend a case with Vendor and its been resolved.

They have shared a steps to reset the workgroup. did the same and its working now.

But not sure whether its a workaround or permanent solution.