Highlighted

A read operation from a socket Failed


Helo gaise,

I have this enviroment.

Two Netbackup server

                      SRVNETBKP1 (windows)
                      SRVNETBKP2 (linux)

One Media Server

                     SRVMEDIA SERVER (windows)

the connection from SRVNETBKP2 to SRVMEDIASERVER don't work. the message below appears



below, i have more informations



I have connectivity on host and don't work.

what more I can make?
angry

1 Solution

Accepted Solutions
Accepted Solution!

I agree with Nicolai - rather

I agree with Nicolai - rather use short names everywhere.
If you are using hosts files for name lookup and If FQDN is used, checked that hosts entries match on media and master servers.
For example:
On master:
10.10.10.1 master master.company loghost
10.10.10.2 media media.company

Media Server:

10.10.10.2 media media.company loghost
10.10.10.1 master master.company


View solution in original post

15 Replies

You should check that the

You should check that the name of the media server is resolved properly on the Linux server (check with 'host' or 'nslookup')

Yes. i can connect to the


Yes. i can connect to the host by name or IP.

And i can cannect to the host by console java.

Tks.

Yes but what happens if your

Yes but what happens if your run 'host mediaservername' on SRVNETBKP2 ?

Multiple NIC's ?


If you have multiple NIC on master and media, the traffic may select interfaces you don't expect. A update on bp.conf & vm.conf with those interface name will resolve the issue.

You may also set the REQUIRED_INTERFACE to force traffic thru a NIC.


when i run host mediaserver


when i run host mediaserver on srvnetbkp2 that is work!!!

Nicolai, i have a only one


Nicolai,

i have a only one NIC on the booth hosts.

Super :-)



One thing to leave out then :-)
Accepted Solution!

I agree with Nicolai - rather

I agree with Nicolai - rather use short names everywhere.
If you are using hosts files for name lookup and If FQDN is used, checked that hosts entries match on media and master servers.
For example:
On master:
10.10.10.1 master master.company loghost
10.10.10.2 media media.company

Media Server:

10.10.10.2 media media.company loghost
10.10.10.1 master master.company


View solution in original post

Marianne, i test by hostname


Marianne,

i test by hostname and dont work again.

thanks. i don't know what i do!angry


S/W Firewall?

Is there a firewall running on the Windows Server... This will also cause the stataus 23... If on, try disabling!

-Kevin

Miller, Firewall is disable


Miller,

Firewall is disable wink

FQDN

Are you sure the domain name of the server should be lab.local ?.

You need to check the lab.local name is used in all configuration files and can be resolved both forward and reverse from the master server. Else you might confuse Netbackup.

The master server uses short name, can you use sort name for the media server as well  (KISS Principe) ?

hosts file

I take it you checked hosts file entries on all servers and not only the media server.

Also confirm subnet and gateway on media server -

Do you have 2 master servers: SRVNETBKP1 (windows) as on the GUI you are using SRVNETBKP2.local.lab?

Ok Mohamed, Tomorrow i try to


Ok Mohamed, Tomorrow i try to do it and post the results here.

Thanks..

Add ip's with fully qualified

Add ip's with fully qualified domain name in both the servers host files and then verify the connectivity.

I think you have one linux and one windows master server . Why you are trying to connect windows server as media server . please confirm


Regards,
rajesh