Snapshot could not be created with VMware method

Trying to get this working with Netbackup 6.5.1 and VCB 1.1. This is with the Master server/Media Server and VCB proxy on the same box, which is Windows Server 2003 x64 SP2.
 
I get the error message in the subject plus the BPFIS loglooks like this
 
14:45:11.394 [1760.4912] <2> logparams: C:\Program Files\Veritas\NetBackup\bin\bpfis.exe verify -nbu -pt 29 -backup_copy 0 -fim VMware:mntpt=c:\mnt,Virtual_machine_backup=0 -vm_client scoav1p.siga.sk.ca
14:45:11.394 [1760.4912] <4> bpfis: INF - BACKUP START 1760
14:45:11.394 [1760.4912] <2> bpfis main: receive filelist:<ALL_LOCAL_DRIVES>
14:45:11.394 [1760.4912] <2> bpfis main: receive filelist:<CONTINUE>
14:45:11.394 [1760.4912] <2> ol_initialize: get snap_lock_timeout for scobk3p
14:45:11.394 [1760.4912] <2> ol_initialize: use default snap_lock_timeout 15 minutes for scobk3p
14:45:11.457 [1760.4912] <8> onlfi_initialize_vfms: VfMS error 10; see following messages:
14:45:11.457 [1760.4912] <8> onlfi_initialize_vfms: Non-fatal method error was reported
14:45:11.457 [1760.4912] <8> onlfi_initialize_vfms: vfm_configure_fi_one: method: FlashSnap, type: FIM, function: FlashSnap_init
14:45:11.457 [1760.4912] <8> onlfi_initialize_vfms: VfMS method error 3; see following message:
14:45:11.457 [1760.4912] <8> onlfi_initialize_vfms: FlashSnap_init: Veritas Volume Manager not installed.
14:45:11.457 [1760.4912] <8> onlfi_initialize_vfms: VfMS error 10; see following messages:
14:45:11.457 [1760.4912] <8> onlfi_initialize_vfms: Non-fatal method error was reported
14:45:11.457 [1760.4912] <8> onlfi_initialize_vfms: vfm_configure_fi_one: method: vxvm, type: FIM, function: vxvm_init
14:45:11.457 [1760.4912] <8> onlfi_initialize_vfms: VfMS method error 3; see following message:
14:45:11.457 [1760.4912] <8> onlfi_initialize_vfms: vxvm_init: Veritas Volume Manager not installed.
14:45:11.457 [1760.4912] <4> bpfis: INF - FIS_ID=1210365911
14:45:11.457 [1760.4912] <2> onlfi_process_fs_list_fs_entry: Adding file system ALL_LOCAL_DRIVES to list
14:45:11.457 [1760.4912] <4> onlfi_freeze_fim: Testing freeze of ALL_LOCAL_DRIVES using snapshot method VMware.
14:45:11.457 [1760.4912] <4> create_mount_point: Created mount point C:\Program Files\Veritas\NetBackup\temp\_vrts_frzn_img_ALL_LOCAL_DRIVES_1760
14:45:13.472 [1760.4912] <4> delete_mount_point: Deleted mount point C:\Program Files\Veritas\NetBackup\temp\_vrts_frzn_img_ALL_LOCAL_DRIVES_1760
14:45:13.472 [1760.4912] <32> onlfi_freeze_fim_fs: VfMS error 11; see following messages:
14:45:13.472 [1760.4912] <32> onlfi_freeze_fim_fs: Fatal method error was reported
14:45:13.472 [1760.4912] <32> onlfi_freeze_fim_fs: vfm_freeze: method: VMware, type: FIM, function: VMware_freeze
14:45:13.472 [1760.4912] <32> onlfi_freeze_fim_fs: VfMS method error 7; see following message:
14:45:13.472 [1760.4912] <32> onlfi_freeze_fim_fs: VMware_freeze: Unable to find VCB path
14:45:13.472 [1760.4912] <32> onlfi_verify: VfMS error 11; see following messages:
14:45:13.472 [1760.4912] <32> onlfi_verify: Fatal method error was reported
14:45:13.472 [1760.4912] <32> onlfi_verify: vfm_freeze: method: VMware, type: FIM, function: VMware_freeze
14:45:13.472 [1760.4912] <32> onlfi_verify: VfMS method error 7; see following message:
14:45:13.472 [1760.4912] <32> onlfi_verify: VMware_freeze: Unable to find VCB path
14:45:13.472 [1760.4912] <16> bpfis: FTL - snapshot verify failed, status 156
14:45:13.472 [1760.4912] <4> bpfis: INF - EXIT STATUS 156: snapshot error encountered
14:45:13.472 [1760.4912] <2> online_util: release_id_lock:fis_id = 1210365911
I'm not sure why it is unable to find VCB path. Is there somewhere I can set this value?
4 Replies

Re: Snapshot could not be created with VMware method

Resolved by moving the VCB install from Program Files(x86) to just Program Files.

Re: Snapshot could not be created with VMware method

Hi

 

Just an FYI I have the same problem but if was related to the vfm.conf file

 

Support and I look in the bpfis log and discovered that this

 

onlfi_initialize_vfms: VfMS error 9; see following messages:
08:38:06.253 [5548.9712] <8> onlfi_initialize_vfms: vfm_fi_init: access() error on library /usr/openv/lib/libvfms.dll: The system cannot find the file specified.
08:38:06.253 [5548.9712] <8> onlfi_initialize_vfms: vfm_fi_init: access() error on library /usr/openv/lib/libvfms.dll: The system cannot find the file specified.
08:38:06.253 [5548.9712] <8> onlfi_initialize_vfms: VfMS error 9; see following messages:
08:38:06.253 [5548.9712] <8> onlfi_initialize_vfms: Operating system error was reported
08:38:06.253 [5548.9712] <8> onlfi_initialize_vfms: vfm_fi_init: access() error on library /usr/openv/lib/libfi_FlashSnap.dll: The system cannot find the file specified.
08:38:06.253 [5548.9712] <8> onlfi_initialize_vfms: VfMS error 9; see following messages:
08:38:06.253 [5548.9712] <8> onlfi_initialize_vfms: Operating system error was reported
08:38:06.253 [5548.9712] <8> onlfi_initialize_vfms: vfm_fi_init: access() error on library /usr/openv/lib/libfi_vxvm.dll: The system cannot find the file specified.
08:38:06.253 [5548.9712] <8> onlfi_initialize_vfms: VfMS error 9; see following messages:
08:38:06.253 [5548.9712] <8> onlfi_initialize_vfms: Operating system error was reported
08:38:06.253 [5548.9712] <8> onlfi_initialize_vfms: vfm_fi_init: access() error on library /usr/openv/lib/libfi_VMware.dll: The system cannot find the file specified.
08:38:06.253 [5548.9712] <8> onlfi_initialize_vfms: VfMS error 9; see following messages:
08:38:06.253 [5548.9712] <8> onlfi_initialize_vfms: Operating system error was reported
08:38:06.253 [5548.9712] <8> onlfi_initialize_vfms: vfm_fi_init: access() error on library /usr/openv/lib/libfi_NAS_Snapshot.dll: The system cannot find the file specified.
08:38:06.253 [5548.9712] <8> onlfi_initialize_vfms: VfMS error 9; see following messages:
08:38:06.253 [5548.9712] <8> onlfi_initialize_vfms: Operating system error was reported
08:38:06.253 [5548.9712] <8> onlfi_initialize_vfms: vfm_fi_init: access() error on library /usr/openv/lib/libfi_vss_writer.dll: The system cannot find the file specified.

 

The *.dll were pointing to a unix file location not a windows file location. I hard code the location to where my veritas software was installed on the windows 2003 enterprise server

ie F:\veritas\netbackup\bin\libfi_auto.dll

 

Everyting is now working great.

 

Thanks

Message Edited by Todd Smith on 01-28-2009 06:00 AM

Hi Todd, I just had exactly

Hi Todd, I just had exactly the same issue when configuring a new vCenter/FlashBackup-Windows deployment and resolved by editing vfm.conf so a Windows file structure is used on a Windows Media Server and not Unix.

We're running 6.5.4 and vSphere so I am little surprised Symantec haven't resolved this yet. I have raised it with them anyway.

Thanks.

Please create a new thread rather than bringing up a really old

Please create a new thread rather than bringing up a really old one.  Some people will see how old it is and will be less likely to respond.