Error 156 (snapshot error encountered)

Could anybody help that how to resolve 156 error and tell the process to resolve the snapshot issue.Please give it in stap by step so that it will be easy to resolve.
1 Solution

Accepted Solutions
Accepted Solution!

Look for 156 in the following:

This Technote contains a table for NetBackup's Status Codes, with links to potential resolutions for...

for what matches the issue you are encountering.


***EDIT***

Plus, the following document has just been updated on the Digest

Snapshot client backups using VSS transportable snapshots are failing with status 156 for Windows 20...

At the end of the day, it all depends on your environment & what you are trying to do - the more info you supply the easier it will be to provide a possible resolution.

View solution in original post

6 Replies

There could be many reasons

There could be many reasons that may cause a 156 snapshot error.  Please can you give more details on your setup and what kind of backup job you are running?  Is it a regular client backup or maybe a VCB backup etc?
Accepted Solution!

Look for 156 in the following:

This Technote contains a table for NetBackup's Status Codes, with links to potential resolutions for...

for what matches the issue you are encountering.


***EDIT***

Plus, the following document has just been updated on the Digest

Snapshot client backups using VSS transportable snapshots are failing with status 156 for Windows 20...

At the end of the day, it all depends on your environment & what you are trying to do - the more info you supply the easier it will be to provide a possible resolution.

Details please

Please provide info on which version of NBU you are running on the master and client.  Media server as well if there is one involved.

Is this a standard Windows snapshot or is this a VCB backup, this will make a huge determination in how to move forward with troubleshooting.

For snapshot error

we are using the version as 6.5.3

Rebooting the server in its maintenance window

Hi Ven,

In our environment too we have faced EC 156 error.

This failure is often caused by the VSP/VSS cache file not been cleared.
These files have been created during the previous backup and it is not cleared yet.

The method we follow to clear this issue, is rebooting the server in its maintenance window.
Rebooting clears this snap captured files and the successive backups completes successfully.

Thanks.

VEN, still not enough info

VEN , you are still not giving enough info. What is the policy type of the failing backup? What is the client O/S? NetBackup will by default try to use VSP for open file backups on Windows. If the client is W2003 or W2008, you should change the config on the Master server Host Properties -> Client Attributes, add Windows client name, and select VSS.
See this TechNote for more info (although the status code is not the same): http://seer.support.veritas.com/docs/317730.htm
By default any new client added to a backup policy will use a Windows Open File Backup (WOFB) method for MS-Windows-NT policies. The default snapshot for WOFB uses the Veritas Snapshot Provider (VSP).

To change the snapshot provider from Veritas Snapshot Provider (VSP) to Microsoft Volume Shadow Copy Service (VSS).

1. In the NetBackup Administration console go to Host Properties, Master Server.
2. Open the Master Server.
3. Go to Client Attributes.
4. Add the name of the client and be sure to use the same case sensitivity as that used in the policy.
Note: If the client name is LEVEL in the policy do not add the client name LeVeL in host properties.
NetBackup may treat LEVEL and LeVeL as two different clients.
5. Once the client is added, close the client add dialog box and select (highlight) the client.
6. Select the tab for Windows Open File Backup.
7. Select Use Microsoft Volume Shadow Copy Service (VSS).
8. Click OK to save the change.

Note: A restart of services or daemons is not required for this action.