cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted

VMware Restoration

Hi All,

I am trying to restore my Vmware from netbackup to another EXSI via Netbackup BAR (Virtual Machine Recovery) and recover the virtual machine to alternate location.

I was not able to restore for this particular VM. I was able to restore the rest of the VM in the same environment except this one (let call this VM100).

I have enable the bpvmutil logging and below is the logs.

(Removed and re-added as attachment by Marianne)

 

It seems that the failure is related to this "Invalid configuration for device '1'." as i have compared those VM that has no problems.

May i know how do i resolve this issue? I tried find the information on veritas and it points me to this document https://www.veritas.com/support/en_US/article.000068086

Please helps. Am lost in troubleshooting

1 Solution

Accepted Solutions
Highlighted
Accepted Solution!

Re: VMware Restoration

This issue can happen if the virtual machine backed up has either a floppy diskette drive or CD-ROM drive connected to it.
 
To ensure the restore is successful, remove any floppy diskette drives or CD-ROM drives from the configuration.
 
To remove floppy diskette drives or CD-ROM drives, check remove backing information for devices like DVD/CD-ROM drive  in the restore wizard
 
NetBackup-restore-VMware-VM-backup-10.jpg

View solution in original post

5 Replies
Highlighted

Re: VMware Restoration

Hello,

I think you should put this to a VMware forum, it looks like VMware related issue.

Please in a future insert log contents as attachments here, no as plain text  - or at least copy just their important parts. It looks you have isolated the problem, so no need to paste here the whole log stuff.

Michal

Highlighted

Re: VMware Restoration

Check if the link below helps

http://kb.vmware.com/selfservice/microsites/search.do?language=en_US&cmd=displayKC&externalId=1001416

Highlighted

Re: VMware Restoration

Hello lowkh 76

Because you sad that this error happens only on one machine, then it should not be related to netbackup only, but I ve found a techhnote from the veritas side that can give you advice.

https://support.symantec.com/en_US/article.TECH179432.html

I do no say that this is the same for you, but something similar can happen. Check if not a specif configuration setting on the vm is making this error, and if a reread or reaply of , exemple a vm template breaks the blocking point.

Do also like you have been told before, report the issue to vmware support.

 

Best regards,

Cruisen

Highlighted

Re: VMware Restoration

Hi All,

manage to resolve the problem. It seems that the VM configuration has an ISO mounted on the Virtual CDROM. As such when i do an alternate location restore, the backup image contains the information of that ISO being mounted and the alternate location did not have that ISO image.

I edit the configuration of that VM and redo it backup again. After which i proceed with the alternate restoration and this time it completed successfully.

Thanks all.

 

Highlighted
Accepted Solution!

Re: VMware Restoration

This issue can happen if the virtual machine backed up has either a floppy diskette drive or CD-ROM drive connected to it.
 
To ensure the restore is successful, remove any floppy diskette drives or CD-ROM drives from the configuration.
 
To remove floppy diskette drives or CD-ROM drives, check remove backing information for devices like DVD/CD-ROM drive  in the restore wizard
 
NetBackup-restore-VMware-VM-backup-10.jpg

View solution in original post