cancel
Showing results for 
Search instead for 
Did you mean: 

upgradeing to netbackup OPSCenter 8.3 - upgrade server or agent first?

bc1410
Level 5

Windows 2012 R2 Server.   

We have currently netbackup opscenter 8.2 in our netbackup environment.  

We want to upgrade opscenter 8.3 as I know ops center can alwasy be 1 version higher then the netbackup environment.

Im reading the documentation on upgradeing steps and i see some conflicting steps in the OpsCenter 8.3 admin documentation compared to the the Veritas SORT Tool Checklist.

The 8.3 opscenter admin guides states to upgrade in the following ORDER-

Upgrade the OpsCenter Server
 Upgrade the OpsCenter Agent
 Upgrade the OpsCenter View Builde

 

And the Veritas SORT tool install checker states the following:

Procedure Overview:
Plan the NetBackup OpsCenter installation by reviewing the "About planning an OpsCenter installation" topic of the NetBackup OpsCenter 8.3 Administrator's Guide.
In order to install NetBackup OpsCenter 8.3, follow the installation instruction found in the upgrading OpsCenter topic in chapter 2. Upgrades must be performed in the following order: NetBackup OpsCenter Agent, NetBackup OpsCenter Server, NetBackup OpsCenter View Builder, then your data protection product.

So which is it???     Upgrade the Agent first or the Server part of Opscenter???  

Thanks
BC

1 ACCEPTED SOLUTION

Accepted Solutions

davidmoline
Level 6
Employee

Hi @bc1410 

The order should be Server first. Then agent, then View builder. However, if you are only monitoring NetBackup, then there is no requirement to install the agent (used for monitoring BackupExec now) and I would uninstall the agent before you start the upgrade process. I would also review the need for the view builder - if you are not using it, why bother having it installed.

Also, there is no real limitation on what version you can upgrade to with OpsCenter - it does have to be higher than the master server version but that is all. So you could potentially upgrade to OpsCenter 9.1.

So if it was me I'd do the following:

  1. Uninstall the OpsCenter agent & view builder (assuming not required)
  2. Upgrade OpsCenter Server
  3. Upgrade OpsCenter View Builder (only if using)

Cheers
David

View solution in original post

2 REPLIES 2

davidmoline
Level 6
Employee

Hi @bc1410 

The order should be Server first. Then agent, then View builder. However, if you are only monitoring NetBackup, then there is no requirement to install the agent (used for monitoring BackupExec now) and I would uninstall the agent before you start the upgrade process. I would also review the need for the view builder - if you are not using it, why bother having it installed.

Also, there is no real limitation on what version you can upgrade to with OpsCenter - it does have to be higher than the master server version but that is all. So you could potentially upgrade to OpsCenter 9.1.

So if it was me I'd do the following:

  1. Uninstall the OpsCenter agent & view builder (assuming not required)
  2. Upgrade OpsCenter Server
  3. Upgrade OpsCenter View Builder (only if using)

Cheers
David

View solution in original post

Hey David - 

Thanks so much for the reply.   I had in my previous notes to do Server first but when I was looking at the Veritas Sort tool it had listed agent first.   Thanks for confirming.

Also I didnt realize about installing any version higher then master server.   I thought the rule of thumb was that it couldnt go no higher then 1 version.   Good info

Thanks