cancel
Showing results for 
Search instead for 
Did you mean: 

had failed to start on nodeXX

Zahid_Haseeb
Level 6
Partner    VIP    Accredited

Environment

OS = Centos 6.2

SFHA = 6.0

Cluster nodes = 2Nodes

Problem

While configuring SFHA the below error occured. I created two node cluster more than two times and faced same problem.

====================================

Veritas Storage Foundation and High Availability Startup did not complete
successfully

had failed to start on node1
had failed to start on node2
 

===================================

1 ACCEPTED SOLUTION

Accepted Solutions

TonyGriffiths
Level 6
Employee Accredited Certified

Hi

Can you confirm the o/s ? CentOS is not supported:

https://sort.symantec.com/public/documents/vcs/6.0/linux/productguides/html/vcs_notes/ch01s09s02.htm

cheers

tony

View solution in original post

10 REPLIES 10

arangari
Level 5

check the errors in installer logs, or /var/VRTSvcs/log/engine_A.log.

Zahid_Haseeb
Level 6
Partner    VIP    Accredited

]# cat /var/VRTSvcs/log/engine_A.log
#
# Log Name:     engine
# System:       node2
# SysInfo:      Linux:node2,#1 SMP Tue Dec 6 19:48:22 GMT 2011,2.6.32-220.el6.x86_64,x86_64
# Created:      2012/04/25 09:57:30
#

2012/04/25 09:57:30 VCS INFO V-16-1-10196 Cluster logger started
2012/04/25 09:57:30 VCS NOTICE V-16-1-11022 VCS engine (had) started
2012/04/25 09:57:30 VCS NOTICE V-16-1-11050 VCS engine version=6.0
2012/04/25 09:57:30 VCS NOTICE V-16-1-11051 VCS engine join version=6.0.00.0
2012/04/25 09:57:30 VCS NOTICE V-16-1-11052 VCS engine pstamp=6.0.000.000-6.0-2011-11-14-09.00.00
2012/04/25 10:19:51 VCS NOTICE V-16-1-11022 VCS engine (had) started
[root@node2 ~]#

 

[root@node2 ~]# /opt/VRTSvcs/bin/hastatus -sum
VCS ERROR V-16-1-10600 Cannot connect to VCS engine
VCS WARNING V-16-1-11046 Local system not available
 

 

arangari
Level 5

are these the complete logs? it states 'had' has started...

 

 

 

TonyGriffiths
Level 6
Employee Accredited Certified

Hi

Can you confirm the o/s ? CentOS is not supported:

https://sort.symantec.com/public/documents/vcs/6.0/linux/productguides/html/vcs_notes/ch01s09s02.htm

cheers

tony

View solution in original post

Zahid_Haseeb
Level 6
Partner    VIP    Accredited

CentOS 6.2 (64bit)

I tried version SFHA 5x and that was working fine.

Zahid_Haseeb
Level 6
Partner    VIP    Accredited

yes its complete logs of engine. it says it is started in the logs but the hastatus command is not showing that vcs is fine

Zahid_Haseeb
Level 6
Partner    VIP    Accredited

Any additional comment ?

Eric_Hennessey1
Level 5
Employee Certified

CentOS is definitely not a supported platform. The only supported Linux platforms are Red Hat and Suse Linux.

Zahid_Haseeb
Level 6
Partner    VIP    Accredited

After installing on Redhat, had started but other files didnot. Although hastatus result shows running/online See below for reference:

 

 

Estimated time remaining: (mm:ss) 0:05                          18 of 19

    Starting vxesd .................................................... Done
    Starting vxrelocd ................................................. Done
    Starting vxcached ................................................. Done
    Starting vxconfigbackupd .......................................... Done
    Starting vxattachd ................................................ Done
    Starting vvr ...................................................... Done
    Starting vxportal ............................................... Failed
    Starting fdd .................................................... Failed
    Starting amf ...................................................... Done
    Starting had ...................................................... Done
    Starting CmdServer ................................................ Done
    Starting vxdbd .................................................... Done
    Starting vxodm .................................................. Failed


Veritas Storage Foundation and High Availability Startup did not complete
successfully

vxportal failed to start on cluster-dr
fdd failed to start on cluster-dr
vxodm failed to start on cluster-d
r



# /opt/VRTSvcs/bin/hastatus
attempting to connect....
attempting to connect....connected


group           resource             system               message             
--------------- -------------------- -------------------- --------------------
                                     cluster-dr           RUNNING             
ClusterService                       cluster-dr           ONLINE              
                wac                  cluster-dr           ONLINE              
                gcoip                cluster-dr           ONLINE              
-------------------------------------------------------------------------
                gconic               cluster-dr           ONLINE              

 

Zahid_Haseeb
Level 6
Partner    VIP    Accredited

Thanks tony for your kind support

Marking your post as solution